aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fonteditfs
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-05-13 04:08:02 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-05-13 04:08:02 +0000
commit8d61d21b484a020678da65b4cf9840110383c287 (patch)
treee055ec228fbd14a9321aaa47c5ac898efcbaffed /sysutils/fonteditfs
parente3ccb88664caee08baade6f66646a33689a3fad1 (diff)
downloadports-8d61d21b484a020678da65b4cf9840110383c287.tar.gz
ports-8d61d21b484a020678da65b4cf9840110383c287.zip
Add fonteditfs 1.0, a Full Screen Syscons Font Editor.
PR: 45965 Submitted by: uri@keves.org
Notes
Notes: svn path=/head/; revision=80881
Diffstat (limited to 'sysutils/fonteditfs')
-rw-r--r--sysutils/fonteditfs/Makefile27
-rw-r--r--sysutils/fonteditfs/distinfo1
-rw-r--r--sysutils/fonteditfs/files/patch-Makefile27
-rw-r--r--sysutils/fonteditfs/files/patch-aa19
-rw-r--r--sysutils/fonteditfs/pkg-descr3
-rw-r--r--sysutils/fonteditfs/pkg-plist1
6 files changed, 78 insertions, 0 deletions
diff --git a/sysutils/fonteditfs/Makefile b/sysutils/fonteditfs/Makefile
new file mode 100644
index 000000000000..51caffb7cfbc
--- /dev/null
+++ b/sysutils/fonteditfs/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: fnteditfs
+# Date created: Sat Oct 12 21:03:00 IST 2002
+# Whom: uri@keves.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= fonteditfs
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= fnteditfs-${PORTVERSION}
+EXTRACT_SUFX=.tgz
+
+MAINTAINER= uri@keves.org
+COMMENT= A Full Screen Syscons Font Editor
+USE_REINPLACE= yes
+
+MAN1=fnteditfs.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|__PREFIX__|${PREFIX}|g ; \
+ s|__INSTALL_MAN__|${INSTALL_MAN}|g ; \
+ s|__INSTALL_SCRIPT__|${INSTALL_SCRIPT}|g' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/sysutils/fonteditfs/distinfo b/sysutils/fonteditfs/distinfo
new file mode 100644
index 000000000000..551759b0bcf9
--- /dev/null
+++ b/sysutils/fonteditfs/distinfo
@@ -0,0 +1 @@
+MD5 (fnteditfs-1.0.tgz) = 07f126a9145af8564ddca571c2cd33c3
diff --git a/sysutils/fonteditfs/files/patch-Makefile b/sysutils/fonteditfs/files/patch-Makefile
new file mode 100644
index 000000000000..9bf93ccfd8dd
--- /dev/null
+++ b/sysutils/fonteditfs/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig Sun Sep 29 18:01:01 2002
++++ Makefile Sat Oct 12 21:05:22 2002
+@@ -1,20 +1,14 @@
+ # This makefile should work under most POSIX OSes (at least FreeBSD)
+
+-BINDIR = /usr/local/bin
+-MANDIR = /usr/local/man
+-
+-
+-CFLAGS = -O2 -pipe -Wall
++all: fnteditfs
+
+ fnteditfs: fnteditfs.o
+- gcc -o fnteditfs fnteditfs.c -lcurses
++ gcc -o fnteditfs fnteditfs.o -lcurses
+ strip fnteditfs
+
+-fnteditfs.o: fnteditfs.c
+-
+ install: fnteditfs fnteditfs.1
+- cp fnteditfs $(BINDIR)
+- gzip < fnteditfs.1 > $(MANDIR)/man1/fnteditfs.1.gz
++ __INSTALL_SCRIPT__ fnteditfs __PREFIX__/bin
++ __INSTALL_MAN__ fnteditfs.1 __PREFIX__/man/man1
+
+ clean:
+ rm -f *.o fnteditfs
diff --git a/sysutils/fonteditfs/files/patch-aa b/sysutils/fonteditfs/files/patch-aa
new file mode 100644
index 000000000000..e5da6cb9a7f4
--- /dev/null
+++ b/sysutils/fonteditfs/files/patch-aa
@@ -0,0 +1,19 @@
+--- version.orig Wed Oct 2 16:30:17 2002
++++ version Tue Dec 3 14:46:52 2002
+@@ -2,4 +2,4 @@
+ Version: 1.0
+ Date: Wed Oct 2 13:27:20 GMT 2002
+ Authors: Uri Shaked <uri@keves.org>, Amir Shalem <amir@boom.org.il>
+-Homepage: http://www.a-i-systems.net/~uri/projects/fonteditfs/
++Homepage: http://fonteditfs.sourceforge.net/
+--- fnteditfs.1.orig Tue Oct 1 22:10:07 2002
++++ fnteditfs.1 Tue Dec 3 14:46:40 2002
+@@ -43,7 +43,7 @@
+ .Sh AVAILABILITY
+ The latest release and some online documentation are available on the
+ .Nm fnteditfs
+-Page, URL http://www.a-i-systems.net/~uri/projects/fonteditfs/
++Page, URL http://fonteditfs.sourceforge.net/
+ .Sh BUGS
+ Sure to be some. Please report the author if you find any.
+ .Sh AUTHORS
diff --git a/sysutils/fonteditfs/pkg-descr b/sysutils/fonteditfs/pkg-descr
new file mode 100644
index 000000000000..113924c00617
--- /dev/null
+++ b/sysutils/fonteditfs/pkg-descr
@@ -0,0 +1,3 @@
+fnteditfs is a small, simple font editor, designed for editing FreeBSD's
+syscons and linux fonts (but may also work for other OSes). It's written
+in C, using the ncurses library for its display library.
diff --git a/sysutils/fonteditfs/pkg-plist b/sysutils/fonteditfs/pkg-plist
new file mode 100644
index 000000000000..c7fd2dd7329b
--- /dev/null
+++ b/sysutils/fonteditfs/pkg-plist
@@ -0,0 +1 @@
+bin/fnteditfs