aboutsummaryrefslogtreecommitdiff
path: root/sysutils/foremost/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-30 20:34:54 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-30 20:34:54 +0000
commitb4bc14d8e54432215b34a5c6153b8194cf5a9711 (patch)
tree470092d9085dfe134f19390c8a64c792b5f1bc25 /sysutils/foremost/Makefile
parent9c14a3d3a854d92d752a4bedca7b83c5081311fa (diff)
downloadports-b4bc14d8e54432215b34a5c6153b8194cf5a9711.tar.gz
ports-b4bc14d8e54432215b34a5c6153b8194cf5a9711.zip
Update to 1.0
PR: ports/82781 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=138267
Diffstat (limited to 'sysutils/foremost/Makefile')
-rw-r--r--sysutils/foremost/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/sysutils/foremost/Makefile b/sysutils/foremost/Makefile
index 62922849d0c6..84110cf7a7c9 100644
--- a/sysutils/foremost/Makefile
+++ b/sysutils/foremost/Makefile
@@ -6,26 +6,28 @@
#
PORTNAME= foremost
-PORTVERSION= 0.69
+PORTVERSION= 1.0
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://${PORTNAME}.sourceforge.net/pkg/
MAINTAINER= onatan@gmail.com
COMMENT= Console program to recover files based on their headers and footers
USE_GMAKE= yes
-ALL_TARGET= openbsd
+ALL_TARGET= freebsd
MAN1= foremost.1
USE_REINPLACE= yes
PLIST_FILES= bin/foremost etc/foremost.conf.sample
post-patch:
- @${REINPLACE_CMD} -e 's|PREFIX|${PREFIX}|' ${WRKSRC}/foremost.h
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|-Wall -O2|${CFLAGS}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/config.c
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/${MAN1}
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/foremost
- @${INSTALL} -Cm 644 ${WRKSRC}/foremost.conf ${PREFIX}/etc/foremost.conf.sample
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/foremost.conf ${PREFIX}/etc/foremost.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>