aboutsummaryrefslogtreecommitdiff
path: root/sysutils/freecolor
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2010-07-26 15:38:37 +0000
committerTim Bishop <tdb@FreeBSD.org>2010-07-26 15:38:37 +0000
commit54685f75fffc7ccc196febc75375e95aed387b08 (patch)
tree7ffa13da711f34edca074acd64746cb38cd2f64c /sysutils/freecolor
parentbbd6e21a0563c0489a09b5cc2f43f44fa43f3e2d (diff)
downloadports-54685f75fffc7ccc196febc75375e95aed387b08.tar.gz
ports-54685f75fffc7ccc196febc75375e95aed387b08.zip
- Use INSTALL_PROGRAM to respect STRIP.
- Mark BROKEN on non-i386 architectures. PR: ports/148948 Submitted by: swell.k@gmail.com
Notes
Notes: svn path=/head/; revision=258288
Diffstat (limited to 'sysutils/freecolor')
-rw-r--r--sysutils/freecolor/Makefile14
-rw-r--r--sysutils/freecolor/files/patch-Makefile.in20
2 files changed, 28 insertions, 6 deletions
diff --git a/sysutils/freecolor/Makefile b/sysutils/freecolor/Makefile
index 98bb287227a0..8b875f9c6538 100644
--- a/sysutils/freecolor/Makefile
+++ b/sysutils/freecolor/Makefile
@@ -16,6 +16,18 @@ COMMENT= Displays free memory as a bargraph
LIB_DEPENDS= statgrab.8:${PORTSDIR}/devel/libstatgrab
GNU_CONFIGURE= yes
+MAKE_ENV+= INSTALL="${INSTALL}" INSTALL_PROGRAM="${INSTALL_PROGRAM}"
PLIST_FILES= bin/freecolor
-.include <bsd.port.mk>
+.if !defined(WITHOUT_SETGID)
+BINGRP?= kmem
+BINMODE?= 2555
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= Does not function correctly on !i386
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/freecolor/files/patch-Makefile.in b/sysutils/freecolor/files/patch-Makefile.in
index 51bb11e0a299..572e0ce8c697 100644
--- a/sysutils/freecolor/files/patch-Makefile.in
+++ b/sysutils/freecolor/files/patch-Makefile.in
@@ -1,11 +1,21 @@
---- Makefile.in.bak Sun Oct 30 09:50:03 2005
-+++ Makefile.in Sun Oct 30 09:50:13 2005
-@@ -21,7 +21,7 @@
+--- ./Makefile.in.orig 2005-06-04 15:52:52.000000000 +0100
++++ ./Makefile.in 2010-07-26 12:40:15.000000000 +0100
+@@ -2,7 +2,6 @@
+ CFLAGS = -Wall @CFLAGS@ @DEFS@
+ CPPFLAGS = @CPPFLAGS@ @DEFS@
+ LDFLAGS = @LDFLAGS@ @LIBS@
+-INSTALL = @INSTALL@
+
+ prefix = @prefix@
+ mandir = @mandir@
+@@ -19,9 +18,8 @@
+ cp -i free `which free`
+
install:
- strip free
+- strip free
-$(INSTALL) -d $(bindir)
- $(INSTALL) -m 755 free $(bindir)/freecolor
-+ $(INSTALL) -g kmem -m 2755 free $(bindir)/freecolor
++ $(INSTALL_PROGRAM) free $(bindir)/freecolor
clean:
rm -f core free *~