aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fsearch
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-02-03 12:37:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-02-03 12:37:54 +0000
commitc47731cb1ca254c3314113e179c8a630f6c924f0 (patch)
tree4e35513d23f0b9185025d5fc0c9ea49ee4a32594 /sysutils/fsearch
parentd5a74aea236d936ee8ce227f554e10ff3affd7f0 (diff)
downloadports-c47731cb1ca254c3314113e179c8a630f6c924f0.tar.gz
ports-c47731cb1ca254c3314113e179c8a630f6c924f0.zip
Add a port of FSearch, search utility focusing on performance and advanced
features, based on GTK+3. WWW: http://www.fsearch.org/ Because GitHub releases (tarballs) are not fetched with correct modification time, set TIMESTAMP to 1476634045 which corresponds to commit cd0f03c tagged as this release.
Notes
Notes: svn path=/head/; revision=433223
Diffstat (limited to 'sysutils/fsearch')
-rw-r--r--sysutils/fsearch/Makefile32
-rw-r--r--sysutils/fsearch/distinfo3
-rw-r--r--sysutils/fsearch/files/patch-src_string__utils.c41
-rw-r--r--sysutils/fsearch/files/patch-src_string__utils.h10
-rw-r--r--sysutils/fsearch/pkg-descr11
5 files changed, 97 insertions, 0 deletions
diff --git a/sysutils/fsearch/Makefile b/sysutils/fsearch/Makefile
new file mode 100644
index 000000000000..82cd635623bc
--- /dev/null
+++ b/sysutils/fsearch/Makefile
@@ -0,0 +1,32 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fsearch
+DISTVERSION= 0.1beta1
+CATEGORIES= sysutils
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Search utility focusing on performance and advanced features
+
+LICENSE= GPLv2+
+LICENSE_FILES= ${WRKSRC}/License
+
+BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_check_compile_flag.m4:devel/autoconf-archive
+LIB_DEPENDS= libpcre.so:devel/pcre
+
+USE_GITHUB= yes
+GH_ACCOUNT= cboxdoerfer
+
+USES= autoreconf gettext gmake pkgconfig
+GNU_CONFIGURE= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30 intltool
+
+PLIST_FILES= bin/fsearch \
+ share/applications/fsearch.desktop \
+ share/locale/de/LC_MESSAGES/fsearch.mo
+
+post-patch:
+ @${GREP} -Rl linux/limits\\.h ${WRKSRC}/src | ${XARGS} \
+ ${REINPLACE_CMD} -e '/linux\/limits\.h/d'
+
+.include <bsd.port.mk>
diff --git a/sysutils/fsearch/distinfo b/sysutils/fsearch/distinfo
new file mode 100644
index 000000000000..878784bd9887
--- /dev/null
+++ b/sysutils/fsearch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476634045
+SHA256 (cboxdoerfer-fsearch-0.1beta1_GH0.tar.gz) = 39daf6261e86b1485945e570a5100af0015512b86e8d55003fdbb58556355ea2
+SIZE (cboxdoerfer-fsearch-0.1beta1_GH0.tar.gz) = 71282
diff --git a/sysutils/fsearch/files/patch-src_string__utils.c b/sysutils/fsearch/files/patch-src_string__utils.c
new file mode 100644
index 000000000000..749c18173df2
--- /dev/null
+++ b/sysutils/fsearch/files/patch-src_string__utils.c
@@ -0,0 +1,41 @@
+--- src/string_utils.c.orig 2016-10-16 16:07:25 UTC
++++ src/string_utils.c
+@@ -17,6 +17,7 @@
+ */
+
+ #define _GNU_SOURCE
++#include <glib.h>
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <stdint.h>
+@@ -52,9 +53,6 @@ fourbyte_strstr(const unsigned char *h,
+ return *h ? (char *)h-3 : 0;
+ }
+
+-#define MAX(a,b) ((a)>(b)?(a):(b))
+-#define MIN(a,b) ((a)<(b)?(a):(b))
+-
+ #define BITOP(a,b,op) \
+ ((a)[(size_t)(b)/(8*sizeof *(a))] op (size_t)1<<((size_t)(b)%(8*sizeof *(a))))
+
+@@ -220,3 +218,20 @@ fsearch_strstr (const char *haystack,
+ {
+ return my_strstr (haystack, needle);
+ }
++
++int
++strverscmp (const char *s1,
++ const char *s2)
++{
++ gchar *tmp1, *tmp2;
++ gint ret;
++
++ tmp1 = g_utf8_collate_key_for_filename(s1, -1);
++ tmp2 = g_utf8_collate_key_for_filename(s2, -1);
++
++ ret = strcmp(tmp1, tmp2);
++
++ g_free(tmp1);
++ g_free(tmp2);
++ return ret;
++}
diff --git a/sysutils/fsearch/files/patch-src_string__utils.h b/sysutils/fsearch/files/patch-src_string__utils.h
new file mode 100644
index 000000000000..04d85a696f98
--- /dev/null
+++ b/sysutils/fsearch/files/patch-src_string__utils.h
@@ -0,0 +1,10 @@
+--- src/string_utils.h.orig 2016-10-16 16:07:25 UTC
++++ src/string_utils.h
+@@ -28,3 +28,7 @@ const char *
+ fsearch_strcasestr (const char *haystack,
+ const char *needle,
+ size_t needle_len);
++
++int
++strverscmp (const char *s1,
++ const char *s2);
diff --git a/sysutils/fsearch/pkg-descr b/sysutils/fsearch/pkg-descr
new file mode 100644
index 000000000000..91fc5ae082ce
--- /dev/null
+++ b/sysutils/fsearch/pkg-descr
@@ -0,0 +1,11 @@
+FSearch is a fast file search utility, inspired by Everything Search
+Engine. It is written in C and based on GTK+3. It features:
+
+ - Instant (as you type) results
+ - Wildcard support and regular expression support
+ - Filter support (only search for files, folders or everything)
+ - Include and exclude specific folders to be indexed
+ - Fast sort by file name, path, size, or modification time
+ - Customizable interface
+
+WWW: http://www.fsearch.org/