aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-afuse
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-10 13:47:53 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-10 13:47:53 +0000
commitc0aa405b20df26dfeeb5c7a6e28719beb28f132f (patch)
treef42bc8bb355f7c6ca6f6479951b88d8d4d91e33f /sysutils/fusefs-afuse
parentee0a3a926b9d5f32619fbc07d30a700f39635857 (diff)
downloadports-c0aa405b20df26dfeeb5c7a6e28719beb28f132f.tar.gz
ports-c0aa405b20df26dfeeb5c7a6e28719beb28f132f.zip
- Add LICENSE_FILE
- Don't install empty ChangeLog - No need to store manpage in files/ as patch, convert to plain file - pkg-message is only meaningful when DOCS are enabled
Notes
Notes: svn path=/head/; revision=408631
Diffstat (limited to 'sysutils/fusefs-afuse')
-rw-r--r--sysutils/fusefs-afuse/Makefile10
-rw-r--r--sysutils/fusefs-afuse/files/afuse.195
-rw-r--r--sysutils/fusefs-afuse/files/patch-afuse.198
-rw-r--r--sysutils/fusefs-afuse/files/patch-src_afuse.c3
4 files changed, 103 insertions, 103 deletions
diff --git a/sysutils/fusefs-afuse/Makefile b/sysutils/fusefs-afuse/Makefile
index cbc0ff4f4a85..49978761c9d7 100644
--- a/sysutils/fusefs-afuse/Makefile
+++ b/sysutils/fusefs-afuse/Makefile
@@ -11,18 +11,20 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= File system automounting implemented in user-space using FUSE
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= fuse pkgconfig
GNU_CONFIGURE= yes
-SUB_FILES= pkg-message
-
-PORTDOCS= AUTHORS ChangeLog README
+PORTDOCS= AUTHORS README
OPTIONS_DEFINE= DOCS
+DOCS_SUB_FILES= pkg-message
post-install:
- ${INSTALL_MAN} ${WRKSRC}/afuse.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${FILESDIR}/afuse.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/sysutils/fusefs-afuse/files/afuse.1 b/sysutils/fusefs-afuse/files/afuse.1
new file mode 100644
index 000000000000..f6212f74aa3f
--- /dev/null
+++ b/sysutils/fusefs-afuse/files/afuse.1
@@ -0,0 +1,95 @@
+.TH AFUSE 1 "October 12, 2006"
+.SH NAME
+AFUSE \- automounting file system implemented in user-space using FUSE
+.SH DESCRIPTION
+usage: afuse mountpoint [options]
+.SS "general options:"
+.TP
+\fB\-o\fR opt,[opt...]
+mount options
+.TP
+\fB\-h\fR \fB\-\-help\fR
+print help
+.TP
+\fB\-V\fR \fB\-\-version\fR
+print FUSE version information
+.SS "AFUSE options:"
+.TP
+\fB\-o\fR \fB\ mount_template=CMD\fR
+template for CMD to execute to mount (*)
+.TP
+\fB\-o\fR \fB\ unmount_template=CMD\fR
+template for CMD to execute to unmount (*) (**)
+.TP
+(*) - When executed, %r and %m are expanded in templates to the root
+directory name for the new mount point, and the actual directory to
+mount onto respectively to mount onto. Both templates are REQUIRED.
+.TP
+(**)- The unmount command must perform a lazy unmount operation. E.g. the
+\-u \-z options to fusermount, or \-l for regular mount.
+.SS "FUSE options:"
+.TP
+\fB\-d\fR \fB\-o\fR debug
+enable debug output (implies \fB\-f\fR)
+.TP
+\fB\-f\fR
+foreground operation
+.TP
+\fB\-s\fR
+disable multi\-threaded operation
+.TP
+\fB\-o\fR allow_other
+allow access to other users
+.TP
+\fB\-o\fR allow_root
+allow access to root
+.TP
+\fB\-o\fR nonempty
+allow mounts over non\-empty file/dir
+.HP
+\fB\-o\fR default_permissions enable permission checking by kernel
+.TP
+\fB\-o\fR fsname=NAME
+set filesystem name
+.TP
+\fB\-o\fR large_read
+issue large read requests (2.4 only)
+.TP
+\fB\-o\fR max_read=N
+set maximum size of read requests
+.TP
+\fB\-o\fR hard_remove
+immediate removal (don't hide files)
+.TP
+\fB\-o\fR use_ino
+let filesystem set inode numbers
+.TP
+\fB\-o\fR readdir_ino
+try to fill in d_ino in readdir
+.TP
+\fB\-o\fR direct_io
+use direct I/O
+.TP
+\fB\-o\fR kernel_cache
+cache files in kernel
+.TP
+\fB\-o\fR umask=M
+set file permissions (octal)
+.TP
+\fB\-o\fR uid=N
+set file owner
+.TP
+\fB\-o\fR gid=N
+set file group
+.TP
+\fB\-o\fR entry_timeout=T
+cache timeout for names (1.0s)
+.TP
+\fB\-o\fR negative_timeout=T
+cache timeout for deleted names (0.0s)
+.TP
+\fB\-o\fR attr_timeout=T
+cache timeout for attributes (1.0s)
+.SH AUTHOR
+This manual page was written by Varun Hiremath <varunhiremath@gmail.com>,
+for the Debian project (but may be used by others).
diff --git a/sysutils/fusefs-afuse/files/patch-afuse.1 b/sysutils/fusefs-afuse/files/patch-afuse.1
deleted file mode 100644
index b316e0a1197e..000000000000
--- a/sysutils/fusefs-afuse/files/patch-afuse.1
+++ /dev/null
@@ -1,98 +0,0 @@
---- afuse.1.orig
-+++ afuse.1
-@@ -0,0 +1,95 @@
-+.TH AFUSE 1 "October 12, 2006"
-+.SH NAME
-+AFUSE \- automounting file system implemented in user-space using FUSE
-+.SH DESCRIPTION
-+usage: afuse mountpoint [options]
-+.SS "general options:"
-+.TP
-+\fB\-o\fR opt,[opt...]
-+mount options
-+.TP
-+\fB\-h\fR \fB\-\-help\fR
-+print help
-+.TP
-+\fB\-V\fR \fB\-\-version\fR
-+print FUSE version information
-+.SS "AFUSE options:"
-+.TP
-+\fB\-o\fR \fB\ mount_template=CMD\fR
-+template for CMD to execute to mount (*)
-+.TP
-+\fB\-o\fR \fB\ unmount_template=CMD\fR
-+template for CMD to execute to unmount (*) (**)
-+.TP
-+(*) - When executed, %r and %m are expanded in templates to the root
-+directory name for the new mount point, and the actual directory to
-+mount onto respectively to mount onto. Both templates are REQUIRED.
-+.TP
-+(**)- The unmount command must perform a lazy unmount operation. E.g. the
-+\-u \-z options to fusermount, or \-l for regular mount.
-+.SS "FUSE options:"
-+.TP
-+\fB\-d\fR \fB\-o\fR debug
-+enable debug output (implies \fB\-f\fR)
-+.TP
-+\fB\-f\fR
-+foreground operation
-+.TP
-+\fB\-s\fR
-+disable multi\-threaded operation
-+.TP
-+\fB\-o\fR allow_other
-+allow access to other users
-+.TP
-+\fB\-o\fR allow_root
-+allow access to root
-+.TP
-+\fB\-o\fR nonempty
-+allow mounts over non\-empty file/dir
-+.HP
-+\fB\-o\fR default_permissions enable permission checking by kernel
-+.TP
-+\fB\-o\fR fsname=NAME
-+set filesystem name
-+.TP
-+\fB\-o\fR large_read
-+issue large read requests (2.4 only)
-+.TP
-+\fB\-o\fR max_read=N
-+set maximum size of read requests
-+.TP
-+\fB\-o\fR hard_remove
-+immediate removal (don't hide files)
-+.TP
-+\fB\-o\fR use_ino
-+let filesystem set inode numbers
-+.TP
-+\fB\-o\fR readdir_ino
-+try to fill in d_ino in readdir
-+.TP
-+\fB\-o\fR direct_io
-+use direct I/O
-+.TP
-+\fB\-o\fR kernel_cache
-+cache files in kernel
-+.TP
-+\fB\-o\fR umask=M
-+set file permissions (octal)
-+.TP
-+\fB\-o\fR uid=N
-+set file owner
-+.TP
-+\fB\-o\fR gid=N
-+set file group
-+.TP
-+\fB\-o\fR entry_timeout=T
-+cache timeout for names (1.0s)
-+.TP
-+\fB\-o\fR negative_timeout=T
-+cache timeout for deleted names (0.0s)
-+.TP
-+\fB\-o\fR attr_timeout=T
-+cache timeout for attributes (1.0s)
-+.SH AUTHOR
-+This manual page was written by Varun Hiremath <varunhiremath@gmail.com>,
-+for the Debian project (but may be used by others).
diff --git a/sysutils/fusefs-afuse/files/patch-src_afuse.c b/sysutils/fusefs-afuse/files/patch-src_afuse.c
index 0433b501c9a1..31a49171dcfc 100644
--- a/sysutils/fusefs-afuse/files/patch-src_afuse.c
+++ b/sysutils/fusefs-afuse/files/patch-src_afuse.c
@@ -1,4 +1,5 @@
-Index: src/afuse.c
+--- src/afuse.c.orig 2013-02-13 02:36:47 UTC
++++ src/afuse.c
@@ -29,7 +29,7 @@
#include <string.h>
#include <stddef.h>