aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-encfs
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-06-19 03:26:35 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-06-19 03:26:35 +0000
commit392806adca96594002ff9ffe0a0dbeb1e3911842 (patch)
tree3411b9b71688495129fff40e6a59ad7210b640a5 /sysutils/fusefs-encfs
parentff6e29d9857bbb7732eb59e1420155d86686ebe0 (diff)
downloadports-392806adca96594002ff9ffe0a0dbeb1e3911842.tar.gz
ports-392806adca96594002ff9ffe0a0dbeb1e3911842.zip
Notes
Diffstat (limited to 'sysutils/fusefs-encfs')
-rw-r--r--sysutils/fusefs-encfs/Makefile26
-rw-r--r--sysutils/fusefs-encfs/distinfo5
-rw-r--r--sysutils/fusefs-encfs/files/patch-encfs__encfsctl.cpp12
-rw-r--r--sysutils/fusefs-encfs/files/patch-encfs_encfs.cpp20
-rw-r--r--sysutils/fusefs-encfs/files/patch-encfs_encfs.h10
-rw-r--r--sysutils/fusefs-encfs/files/patch-encfs_main.cpp10
-rw-r--r--sysutils/fusefs-encfs/files/patch-encfs_makeKey.cpp10
-rw-r--r--sysutils/fusefs-encfs/files/patch-implement-encf_create46
-rw-r--r--sysutils/fusefs-encfs/pkg-plist7
9 files changed, 66 insertions, 80 deletions
diff --git a/sysutils/fusefs-encfs/Makefile b/sysutils/fusefs-encfs/Makefile
index 2aabf7fa881e..dc59822bc397 100644
--- a/sysutils/fusefs-encfs/Makefile
+++ b/sysutils/fusefs-encfs/Makefile
@@ -2,31 +2,31 @@
# $FreeBSD$
PORTNAME= encfs
-PORTVERSION= 1.7.4
-PORTREVISION= 7
+PORTVERSION= 1.8.1
+DISTVERSIONPREFIX= v
CATEGORIES= sysutils
-MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= fusefs-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dg@syrec.org
COMMENT= Encrypted pass-through FUSE filesystem
-BROKEN_powerpc64= Does not build
+LICENSE= GPLv3
LIB_DEPENDS= librlog.so:devel/rlog \
libboost_serialization.so:devel/boost-libs
-BROKEN_sparc64= cannot link with boost
+BROKEN_powerpc64= does not build
+BROKEN_sparc64= cannot link with boost
WRKSRC= ${WRKDIR}/encfs-${PORTVERSION}
+USES= compiler:c++11-lib fuse autoreconf libtool pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= vgough
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-boost-serialization=boost_serialization \
- --with-boost-system=boost_system \
- --with-boost-filesystem=boost_filesystem
+CONFIGURE_ARGS= --with-boost-serialization=boost_serialization
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES= fuse gmake libtool pkgconfig tar:tgz
USE_LDCONFIG= yes
USE_OPENSSL= yes
INSTALL_TARGET= install-strip
@@ -36,10 +36,8 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-post-patch:
+pre-configure:
@${REINPLACE_CMD} '/OPENSSL_LIBS=/s/-lssl/& -lcrypto/' \
- ${WRKSRC}/configure
- @${FIND} ${WRKSRC}/encfs -type f | ${XARGS} ${REINPLACE_CMD} -E \
- 's/(^|[[:space:]])(shared_ptr)/\1boost::\2/g'
+ ${WRKSRC}/configure.ac
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-encfs/distinfo b/sysutils/fusefs-encfs/distinfo
index 8d8d0cb605d2..473629579032 100644
--- a/sysutils/fusefs-encfs/distinfo
+++ b/sysutils/fusefs-encfs/distinfo
@@ -1,2 +1,3 @@
-SHA256 (encfs-1.7.4.tgz) = 282ef0f04f2dd7ba3527b45621fab485b7cc510c2ceee116600d0348dc2170a8
-SIZE (encfs-1.7.4.tgz) = 931048
+TIMESTAMP = 1465595410
+SHA256 (vgough-encfs-v1.8.1_GH0.tar.gz) = ed6b69d8aba06382ad01116bbce2e4ad49f8de85cdf4e2fab7ee4ac82af537e9
+SIZE (vgough-encfs-v1.8.1_GH0.tar.gz) = 316534
diff --git a/sysutils/fusefs-encfs/files/patch-encfs__encfsctl.cpp b/sysutils/fusefs-encfs/files/patch-encfs__encfsctl.cpp
deleted file mode 100644
index e44816c5d1d5..000000000000
--- a/sysutils/fusefs-encfs/files/patch-encfs__encfsctl.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- encfs/encfsctl.cpp.orig 2014-08-17 19:49:24 UTC
-+++ encfs/encfsctl.cpp
-@@ -40,7 +40,8 @@
- #include <sys/stat.h>
- #include <fcntl.h>
- #ifdef __FreeBSD__
--#include <libintl.h>
-+#include "gettext.h"
-+#include <climits>
- #endif
-
- #include "i18n.h"
diff --git a/sysutils/fusefs-encfs/files/patch-encfs_encfs.cpp b/sysutils/fusefs-encfs/files/patch-encfs_encfs.cpp
new file mode 100644
index 000000000000..655621717008
--- /dev/null
+++ b/sysutils/fusefs-encfs/files/patch-encfs_encfs.cpp
@@ -0,0 +1,20 @@
+--- encfs/encfs.cpp.orig 2015-03-24 20:45:16 UTC
++++ encfs/encfs.cpp
+@@ -529,6 +529,17 @@ int encfs_open(const char *path, struct
+ return res;
+ }
+
++int encfs_create(const char *path, mode_t mode, struct fuse_file_info *file)
++{
++ int res;
++
++ res = encfs_mknod(path, mode, 0);
++ if (res)
++ return res;
++
++ return encfs_open(path, file);
++}
++
+ int _do_flush(FileNode *fnode) {
+ /* Flush can be called multiple times for an open file, so it doesn't
+ close the file. However it is important to call close() for some
diff --git a/sysutils/fusefs-encfs/files/patch-encfs_encfs.h b/sysutils/fusefs-encfs/files/patch-encfs_encfs.h
new file mode 100644
index 000000000000..9cb6211e6ca1
--- /dev/null
+++ b/sysutils/fusefs-encfs/files/patch-encfs_encfs.h
@@ -0,0 +1,10 @@
+--- encfs/encfs.h.orig 2015-03-24 20:45:16 UTC
++++ encfs/encfs.h
+@@ -74,6 +74,7 @@ int encfs_chown(const char *path, uid_t
+ int encfs_truncate(const char *path, off_t size);
+ int encfs_ftruncate(const char *path, off_t size, struct fuse_file_info *fi);
+ int encfs_utime(const char *path, struct utimbuf *buf);
++int encfs_create(const char *path, mode_t mode, struct fuse_file_info *info);
+ int encfs_open(const char *path, struct fuse_file_info *info);
+ int encfs_release(const char *path, struct fuse_file_info *info);
+ int encfs_read(const char *path, char *buf, size_t size, off_t offset,
diff --git a/sysutils/fusefs-encfs/files/patch-encfs_main.cpp b/sysutils/fusefs-encfs/files/patch-encfs_main.cpp
new file mode 100644
index 000000000000..e541aee3e23d
--- /dev/null
+++ b/sysutils/fusefs-encfs/files/patch-encfs_main.cpp
@@ -0,0 +1,10 @@
+--- encfs/main.cpp.orig 2016-06-18 20:53:13 UTC
++++ encfs/main.cpp
+@@ -27,6 +27,7 @@
+ #include <sys/time.h>
+ #include <cerrno>
+ #include <cstring>
++#include <cstdlib>
+
+ #include <getopt.h>
+
diff --git a/sysutils/fusefs-encfs/files/patch-encfs_makeKey.cpp b/sysutils/fusefs-encfs/files/patch-encfs_makeKey.cpp
new file mode 100644
index 000000000000..2e08a63adadc
--- /dev/null
+++ b/sysutils/fusefs-encfs/files/patch-encfs_makeKey.cpp
@@ -0,0 +1,10 @@
+--- encfs/makeKey.cpp.orig 2016-06-18 20:53:44 UTC
++++ encfs/makeKey.cpp
+@@ -25,6 +25,7 @@
+ #include "openssl.h"
+
+ #include <iostream>
++#include <cstdlib>
+
+ #include <sys/types.h>
+ #include <unistd.h>
diff --git a/sysutils/fusefs-encfs/files/patch-implement-encf_create b/sysutils/fusefs-encfs/files/patch-implement-encf_create
deleted file mode 100644
index 3dc1d8aa2109..000000000000
--- a/sysutils/fusefs-encfs/files/patch-implement-encf_create
+++ /dev/null
@@ -1,46 +0,0 @@
-As described in PR 192563
-
---- encfs/encfs.cpp.orig 2014-04-21 15:10:48.592664000 +0000
-+++ encfs/encfs.cpp
-@@ -587,6 +587,19 @@
- return res;
- }
-
-+int encfs_create(const char *path, mode_t mode, struct fuse_file_info *file)
-+{
-+ int res;
-+
-+ res = encfs_mknod(path, mode, 0);
-+ if (res)
-+ return res;
-+
-+ res = encfs_open(path, file);
-+
-+ return res;
-+}
-+
- int _do_flush(FileNode *fnode, int )
- {
- /* Flush can be called multiple times for an open file, so it doesn't
---- encfs/encfs.h.orig 2014-04-21 15:10:48.592664000 +0000
-+++ encfs/encfs.h
-@@ -74,6 +74,7 @@
- struct fuse_file_info *fi);
- int encfs_utime(const char *path, struct utimbuf *buf);
- int encfs_open(const char *path, struct fuse_file_info *info);
-+int encfs_create(const char *path, mode_t mode, struct fuse_file_info *info);
- int encfs_release(const char *path, struct fuse_file_info *info);
- int encfs_read(const char *path, char *buf, size_t size, off_t offset,
- struct fuse_file_info *info);
-diff -ur encfs-1.7.4.orig/encfs/main.cpp encfs-1.7.4/encfs/main.cpp
---- encfs/main.cpp.orig 2014-04-21 15:10:48.592664000 +0000
-+++ encfs/main.cpp
-@@ -563,7 +563,7 @@
- encfs_oper.init = encfs_init;
- encfs_oper.destroy = encfs_destroy;
- //encfs_oper.access = encfs_access;
-- //encfs_oper.create = encfs_create;
-+ encfs_oper.create = encfs_create;
- encfs_oper.ftruncate = encfs_ftruncate;
- encfs_oper.fgetattr = encfs_fgetattr;
- //encfs_oper.lock = encfs_lock;
diff --git a/sysutils/fusefs-encfs/pkg-plist b/sysutils/fusefs-encfs/pkg-plist
index 3ff9f7a2da4d..7327ed136d22 100644
--- a/sysutils/fusefs-encfs/pkg-plist
+++ b/sysutils/fusefs-encfs/pkg-plist
@@ -3,7 +3,7 @@ bin/encfsctl
bin/encfssh
lib/libencfs.so
lib/libencfs.so.6
-lib/libencfs.so.6.0.1
+lib/libencfs.so.6.0.2
man/man1/encfs.1.gz
man/man1/encfsctl.1.gz
%%NLS%%share/locale/ar/LC_MESSAGES/encfs.mo
@@ -31,17 +31,13 @@ man/man1/encfsctl.1.gz
%%NLS%%share/locale/fr_FR/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/gl/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/he/LC_MESSAGES/encfs.mo
-%%NLS%%share/locale/hi/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/hr/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/hu/LC_MESSAGES/encfs.mo
-%%NLS%%share/locale/hu_HU/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/id/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/it/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/ja/LC_MESSAGES/encfs.mo
-%%NLS%%share/locale/ka/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/ko/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/lv/LC_MESSAGES/encfs.mo
-%%NLS%%share/locale/mr/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/nb/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/nds/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/nl/LC_MESSAGES/encfs.mo
@@ -57,7 +53,6 @@ man/man1/encfsctl.1.gz
%%NLS%%share/locale/sr/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/sv/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/ta/LC_MESSAGES/encfs.mo
-%%NLS%%share/locale/te/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/tr/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/uk/LC_MESSAGES/encfs.mo
%%NLS%%share/locale/vi/LC_MESSAGES/encfs.mo