aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-gitfs
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-11-17 10:23:44 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-11-17 10:23:44 +0000
commit397d2e6607e29e91cc54c7574e742a826646f991 (patch)
tree684008da4b99505d9739315b1aa9a71ca617bd08 /sysutils/fusefs-gitfs
parentc757c01e9839843363543cfc1170e503b5f85614 (diff)
downloadports-397d2e6607e29e91cc54c7574e742a826646f991.tar.gz
ports-397d2e6607e29e91cc54c7574e742a826646f991.zip
sysutils/fusefs-gitfs: update to 0.5.2
Changes: https://github.com/PressLabs/gitfs/compare/0.4.5.1...0.5.2 Reported by: GitHub (watch releases)
Notes
Notes: svn path=/head/; revision=517812
Diffstat (limited to 'sysutils/fusefs-gitfs')
-rw-r--r--sysutils/fusefs-gitfs/Makefile17
-rw-r--r--sysutils/fusefs-gitfs/distinfo6
-rw-r--r--sysutils/fusefs-gitfs/files/patch-gitfs_utils_args.py26
3 files changed, 25 insertions, 24 deletions
diff --git a/sysutils/fusefs-gitfs/Makefile b/sysutils/fusefs-gitfs/Makefile
index 8f21f898e15a..9127dde30bf7 100644
--- a/sysutils/fusefs-gitfs/Makefile
+++ b/sysutils/fusefs-gitfs/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gitfs
-DISTVERSION= 0.4.5.1
-PORTREVISION= 1
+DISTVERSION= 0.5.2
CATEGORIES= sysutils devel
PKGNAMEPREFIX= fusefs-
@@ -12,12 +11,14 @@ COMMENT= Version controlled file system
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}atomiclong>0:devel/py-atomiclong@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}fusepy>=2.0.2:devel/py-fusepy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pygit2>=0.24.1:devel/py-pygit2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}raven>=5.27.0:devel/py-raven@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.6.1:devel/py-pytest@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}atomiclong>=0.1.1:devel/py-atomiclong@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cffi>=1.12.3:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fusepy>=3.0.1:devel/py-fusepy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycparser>=2.19:devel/py-pycparser@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygit2>=0.28.2:devel/py-pygit2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}raven>=6.10.0:devel/py-raven@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.12.0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=4.6.5:devel/py-pytest@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= PressLabs
diff --git a/sysutils/fusefs-gitfs/distinfo b/sysutils/fusefs-gitfs/distinfo
index 478515b74250..a44e0ec16308 100644
--- a/sysutils/fusefs-gitfs/distinfo
+++ b/sysutils/fusefs-gitfs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1481188259
-SHA256 (PressLabs-gitfs-0.4.5.1_GH0.tar.gz) = 6049fd81182d9172e861d922f3e2660f76366f85f47f4c2357f769d24642381c
-SIZE (PressLabs-gitfs-0.4.5.1_GH0.tar.gz) = 57695
+TIMESTAMP = 1571569210
+SHA256 (PressLabs-gitfs-0.5.2_GH0.tar.gz) = 921e24311e3b8ea3a5448d698a11a747618ee8dd62d5d43a85801de0b111cbf3
+SIZE (PressLabs-gitfs-0.5.2_GH0.tar.gz) = 64141
diff --git a/sysutils/fusefs-gitfs/files/patch-gitfs_utils_args.py b/sysutils/fusefs-gitfs/files/patch-gitfs_utils_args.py
index 50a7e3ef3432..bc4d1d42d80d 100644
--- a/sysutils/fusefs-gitfs/files/patch-gitfs_utils_args.py
+++ b/sysutils/fusefs-gitfs/files/patch-gitfs_utils_args.py
@@ -1,18 +1,18 @@
https://github.com/PressLabs/gitfs/issues/258
https://github.com/PressLabs/gitfs/issues/257
---- gitfs/utils/args.py.orig 2016-10-19 15:12:59 UTC
+--- gitfs/utils/args.py.orig 2019-10-20 11:00:10 UTC
+++ gitfs/utils/args.py
-@@ -43,7 +43,7 @@ class Args(object):
- ("foreground", (False, "bool")),
- ("branch", ("master", "string")),
- ("allow_other", (False, "bool")),
-- ("allow_root", (True, "bool")),
-+ ("allow_root", (False, "bool")),
- ("commiter_name", (self.get_commiter_user, "string")),
- ("commiter_email", (self.get_commiter_email, "string")),
- ("max_size", (10, "float")),
-@@ -71,12 +71,6 @@ class Args(object):
+@@ -44,7 +44,7 @@ class Args(object):
+ ("foreground", (False, "bool")),
+ ("branch", ("master", "string")),
+ ("allow_other", (False, "bool")),
+- ("allow_root", (True, "bool")),
++ ("allow_root", (False, "bool")),
+ ("commiter_name", (self.get_commiter_user, "string")),
+ ("commiter_email", (self.get_commiter_email, "string")),
+ ("max_size", (10, "float")),
+@@ -76,12 +76,6 @@ class Args(object):
return self.check_args(self.set_defaults(args))
def check_args(self, args):
@@ -24,8 +24,8 @@ https://github.com/PressLabs/gitfs/issues/257
-
# check log_level
if args.debug:
- args.log_level = 'debug'
-@@ -169,7 +163,7 @@ class Args(object):
+ args.log_level = "debug"
+@@ -182,7 +176,7 @@ class Args(object):
return "{}@{}".format(args.user, socket.gethostname())
def get_repo_path(self, args):