aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-gstfs
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-28 12:57:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-28 12:57:40 +0000
commit6ad1ecb6442d48a162317127d50ed1435c1ec372 (patch)
tree15328d6e411cd544a904e02f738691b16fa67d37 /sysutils/fusefs-gstfs
parent3627e55ba8fced92dfc28e2b470545734f45009f (diff)
GSTFS is a filesystem for on-demand transcoding of music files
between different formats. It utilizes the gstreamer library for conversion so any formats supported by gstreamer should also be supported by gstfs. The filesystem's only requirement is that the gstreamer pipeline begin with a filesrc with the name "_source" and end with an fdsink with the name "_dest". The filesystem will automatically substitute the filename and fd number in these pipelines. WWW: http://bobcopeland.com/gstfs/ PR: ports/129984 Submitted by: Dennis Herrmann <adox at mcx2.org>
Notes
Notes: svn path=/head/; revision=224890
Diffstat (limited to 'sysutils/fusefs-gstfs')
-rw-r--r--sysutils/fusefs-gstfs/Makefile41
-rw-r--r--sysutils/fusefs-gstfs/distinfo3
-rw-r--r--sysutils/fusefs-gstfs/pkg-descr10
3 files changed, 54 insertions, 0 deletions
diff --git a/sysutils/fusefs-gstfs/Makefile b/sysutils/fusefs-gstfs/Makefile
new file mode 100644
index 000000000000..5c831be6010a
--- /dev/null
+++ b/sysutils/fusefs-gstfs/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: fusefs-gstfs
+# Date created: 2008-12-26
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gstfs
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://bobcopeland.com/gstfs/releases/ \
+ http://mirror.mcx2.org/
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= adox@mcx2.org
+COMMENT= On-demand, transcoding filesystem (using GStreamer pipeline)
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+
+USE_GNOME= pkgconfig
+USE_GSTREAMER= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+PORTDOCS= README
+PORTEXAMPLES= ogg2mp3.sh mp32wav.sh
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/,} ${EXAMPLESDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-gstfs/distinfo b/sysutils/fusefs-gstfs/distinfo
new file mode 100644
index 000000000000..e037fe41dd1a
--- /dev/null
+++ b/sysutils/fusefs-gstfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (gstfs-0.1.tar.gz) = 2cd1e2f6d29424baf761b9aa96e45a8a
+SHA256 (gstfs-0.1.tar.gz) = 5b159e537a87024fa76267f076784fe038a09809c53ad863ed6e52df7d32be35
+SIZE (gstfs-0.1.tar.gz) = 7689
diff --git a/sysutils/fusefs-gstfs/pkg-descr b/sysutils/fusefs-gstfs/pkg-descr
new file mode 100644
index 000000000000..147be24f002d
--- /dev/null
+++ b/sysutils/fusefs-gstfs/pkg-descr
@@ -0,0 +1,10 @@
+GSTFS is a filesystem for on-demand transcoding of music files
+between different formats. It utilizes the gstreamer library for
+conversion so any formats supported by gstreamer should also be
+supported by gstfs. The filesystem's only requirement is that the
+gstreamer pipeline begin with a filesrc with the name "_source"
+and end with an fdsink with the name "_dest". The filesystem will
+automatically substitute the filename and fd number in these
+pipelines.
+
+WWW: http://bobcopeland.com/gstfs/