aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-ifuse/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-11-23 01:53:31 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-11-23 01:53:31 +0000
commit142996a9dd9bcd6e39b142932b462076ab3f186e (patch)
treec6e2591cafd95b9ae402edf98421e21d95566017 /sysutils/fusefs-ifuse/Makefile
parentea022cad3bbe3ed7910e8d9162b51e3d254b5c76 (diff)
downloadports-142996a9dd9bcd6e39b142932b462076ab3f186e.tar.gz
ports-142996a9dd9bcd6e39b142932b462076ab3f186e.zip
Notes
Diffstat (limited to 'sysutils/fusefs-ifuse/Makefile')
-rw-r--r--sysutils/fusefs-ifuse/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/fusefs-ifuse/Makefile b/sysutils/fusefs-ifuse/Makefile
new file mode 100644
index 000000000000..f1694e71d9bb
--- /dev/null
+++ b/sysutils/fusefs-ifuse/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: fusefs-ifuse
+# Date created: 09 October 2011
+# Whom: Gabor Zahemszky
+#
+# $FreeBSD$
+#
+
+PORTNAME= ifuse
+PORTVERSION= 1.1.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.libimobiledevice.org/downloads/
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= Gabor@Zahemszky.HU
+COMMENT= Mount iPod Touch / iPhone directories over USB
+
+# LICENSE= LGPL21
+# LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= fusefs-libs>2.4.1:${PORTSDIR}/sysutils/fusefs-libs
+
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs \
+ imobiledevice.1:${PORTSDIR}/comms/libimobiledevice
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod \
+ usbmuxd:${PORTSDIR}/comms/usbmuxd
+
+SUB_FILES= pkg-message
+USE_BZIP2= yes
+USE_GNOME= glib20 pkgconfig
+
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_JOBS_SAFE= yes
+CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS}
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>