aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-jmtpfs
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-11-02 01:42:08 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-11-02 01:42:08 +0000
commit742f0069faa66db94e66ed48e4559532d1133665 (patch)
treeb57961fd6b9bf90432d0a7353f71bc857c773e9c /sysutils/fusefs-jmtpfs
parentf92f1c7251e31f00a2bfb05e4322beafbe0cdf4e (diff)
downloadports-742f0069faa66db94e66ed48e4559532d1133665.tar.gz
ports-742f0069faa66db94e66ed48e4559532d1133665.zip
sysutils/fusefs-jmtpfs: add new port
PR: 241558 Submitted by: rozhuk.im@gmail.com
Notes
Notes: svn path=/head/; revision=516281
Diffstat (limited to 'sysutils/fusefs-jmtpfs')
-rw-r--r--sysutils/fusefs-jmtpfs/Makefile33
-rw-r--r--sysutils/fusefs-jmtpfs/distinfo3
-rw-r--r--sysutils/fusefs-jmtpfs/pkg-descr16
3 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/fusefs-jmtpfs/Makefile b/sysutils/fusefs-jmtpfs/Makefile
new file mode 100644
index 000000000000..8d083e376cf6
--- /dev/null
+++ b/sysutils/fusefs-jmtpfs/Makefile
@@ -0,0 +1,33 @@
+# Created by: Rozhuk Ivan <rozhuk.im@gmail.com>
+# $FreeBSD$
+
+PORTNAME= jmtpfs
+DISTVERSION= g20190420
+CATEGORIES= sysutils
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= MTP device filesystem
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libmtp.so:multimedia/libmtp
+
+USE_GITHUB= yes
+GH_ACCOUNT= kiorky
+GH_TAGNAME= af0b79bc555ee60088306fdd2b78b2d51b781da3
+
+USES= autoreconf compiler:c++11-lib fuse pkgconfig
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= AUTHORS NEWS README.rst
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \
+ "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-jmtpfs/distinfo b/sysutils/fusefs-jmtpfs/distinfo
new file mode 100644
index 000000000000..4371cfe4d47c
--- /dev/null
+++ b/sysutils/fusefs-jmtpfs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1572307386
+SHA256 (kiorky-jmtpfs-g20190420-af0b79bc555ee60088306fdd2b78b2d51b781da3_GH0.tar.gz) = 2e442aa0d087422c00e4382fbbd80ee7ee4b87e65cad25782b1a0317cce18c77
+SIZE (kiorky-jmtpfs-g20190420-af0b79bc555ee60088306fdd2b78b2d51b781da3_GH0.tar.gz) = 243976
diff --git a/sysutils/fusefs-jmtpfs/pkg-descr b/sysutils/fusefs-jmtpfs/pkg-descr
new file mode 100644
index 000000000000..e4d1ab3ded99
--- /dev/null
+++ b/sysutils/fusefs-jmtpfs/pkg-descr
@@ -0,0 +1,16 @@
+jmtpfs is a FUSE and libmtp based filesystem for accessing MTP
+(Media Transfer Protocol) devices. It was specifically designed for
+exchaning files between Linux (and Mac OS X) systems and newer Android
+devices that support MTP but not USB Mass Storage.
+
+The goal is to create a well behaved filesystem, allowing tools like
+find and rsync to work as expected. MTP file types are set automatically
+based on file type detection using libmagic. Setting the file appears
+to be necessary for some Android apps, like Gallery, to be able to find
+and use the files.
+
+Since it is meant as an Android file transfer utility, and I don't have
+any non-Android MTP devices to test with, playlists and other non-file
+based data are not supported.
+
+WWW: https://github.com/kiorky/jmtpfs