aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-libs/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-24 14:42:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-24 14:42:52 +0000
commitd1523e64f1adcca2f492e76f6dfcfae5aec455b9 (patch)
tree8c5660503a9108f763b705a30a96855a2db7301b /sysutils/fusefs-libs/Makefile
parentea8e7855e3ababb03df6e7093497c265d77218b6 (diff)
downloadports-d1523e64f1adcca2f492e76f6dfcfae5aec455b9.tar.gz
ports-d1523e64f1adcca2f492e76f6dfcfae5aec455b9.zip
Notes
Diffstat (limited to 'sysutils/fusefs-libs/Makefile')
-rw-r--r--sysutils/fusefs-libs/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/sysutils/fusefs-libs/Makefile b/sysutils/fusefs-libs/Makefile
index affa322ee453..a16254557d07 100644
--- a/sysutils/fusefs-libs/Makefile
+++ b/sysutils/fusefs-libs/Makefile
@@ -2,15 +2,17 @@
# $FreeBSD$
PORTNAME= fusefs
-PORTVERSION= 2.9.2
+PORTVERSION= 2.9.3
CATEGORIES= sysutils
MASTER_SITES= SF/fuse/fuse-2.X/${PORTVERSION}
PKGNAMESUFFIX= -libs
DISTNAME= fuse-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bapt@FreeBSD.org
COMMENT= FUSE allows filesystem implementation in userspace
+OPTIONS_DEFINE= DOCS
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= MOUNT_FUSE_PATH=${PREFIX}/sbin
USE_LDCONFIG= yes
@@ -20,18 +22,21 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
TXT_DOCS= how-fuse-works \
kernel.txt
+MAN1= fusermount.1 \
+ ulockmgr_server.1
+MAN8= mount.fuse.8
+
+
+.include <bsd.port.options.mk>
+
post-install:
${INSTALL_DATA} ${WRKSRC}/include/fuse_kernel.h ${PREFIX}/include/fuse
-
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/libs
.for i in ${TXT_DOCS}
@${INSTALL_DATA} ${WRKSRC}/doc/$i ${DOCSDIR}/libs
.endfor
.endif
-MAN1= fusermount.1 \
- ulockmgr_server.1
-MAN8= mount.fuse.8
.include <bsd.port.mk>