aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-ntfs
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2007-07-17 15:24:50 +0000
committerMax Khon <fjoe@FreeBSD.org>2007-07-17 15:24:50 +0000
commit9091466ac83f01556d4f6ba1576712715229dbde (patch)
treeb3101248ae5c6bb2049e1710f9fac13b7c25871a /sysutils/fusefs-ntfs
parenta1a53f584ee35030b3ec8cb1540f4606f0800293 (diff)
downloadports-9091466ac83f01556d4f6ba1576712715229dbde.tar.gz
ports-9091466ac83f01556d4f6ba1576712715229dbde.zip
Notes
Diffstat (limited to 'sysutils/fusefs-ntfs')
-rw-r--r--sysutils/fusefs-ntfs/Makefile4
-rw-r--r--sysutils/fusefs-ntfs/distinfo6
-rw-r--r--sysutils/fusefs-ntfs/files/patch-configure12
-rw-r--r--sysutils/fusefs-ntfs/files/patch-libntfs-3g__unix_io.c60
-rw-r--r--sysutils/fusefs-ntfs/pkg-plist2
5 files changed, 38 insertions, 46 deletions
diff --git a/sysutils/fusefs-ntfs/Makefile b/sysutils/fusefs-ntfs/Makefile
index 86384fcf7443..85b3acde4284 100644
--- a/sysutils/fusefs-ntfs/Makefile
+++ b/sysutils/fusefs-ntfs/Makefile
@@ -5,8 +5,7 @@
#
PORTNAME= ntfs
-PORTVERSION= 1.417
-PORTREVISION= 2
+PORTVERSION= 1.710
CATEGORIES= sysutils
MASTER_SITES= http://www.ntfs-3g.org/:ntfs \
${MASTER_SITE_LOCAL:S|$|alepulver/:ublio|}
@@ -26,6 +25,7 @@ ONLY_FOR_ARCHS= i386 amd64
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --mandir=${PREFIX}/man --exec-prefix=${PREFIX}
OPTIONS= LOCK "Lock the device when mounting (avoids access)" off \
UBLIO "Enable user space cache for improved speed" on
diff --git a/sysutils/fusefs-ntfs/distinfo b/sysutils/fusefs-ntfs/distinfo
index 2e1faba390e2..49cd6b98b6e1 100644
--- a/sysutils/fusefs-ntfs/distinfo
+++ b/sysutils/fusefs-ntfs/distinfo
@@ -1,6 +1,6 @@
-MD5 (ntfs-3g-1.417.tgz) = 9e451f1084461795a96170adb6c4376b
-SHA256 (ntfs-3g-1.417.tgz) = 6eff152c670cb9cab1c3d423aac1ce7825f3bc5f53be5ff1857c0079bd27ecc0
-SIZE (ntfs-3g-1.417.tgz) = 562094
+MD5 (ntfs-3g-1.710.tgz) = d42e8d59daca61f5725ea97a08a12142
+SHA256 (ntfs-3g-1.710.tgz) = 9aa99b2951336ea7fe07239cf5a3e6f7645801a1475dbab143d5ce918c32cc52
+SIZE (ntfs-3g-1.710.tgz) = 580731
MD5 (libublio-20070103.tar.gz) = ec8b05fe4d831111f29485b0ab8a0161
SHA256 (libublio-20070103.tar.gz) = 7c87d1cd7a65ab5ab61f9d7b5279bab6c8169d33d552148d396995c767be919f
SIZE (libublio-20070103.tar.gz) = 17238
diff --git a/sysutils/fusefs-ntfs/files/patch-configure b/sysutils/fusefs-ntfs/files/patch-configure
index 038f6153aa27..583950785751 100644
--- a/sysutils/fusefs-ntfs/files/patch-configure
+++ b/sysutils/fusefs-ntfs/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Tue Jul 25 23:41:16 2006
-+++ configure Tue Jul 25 23:40:37 2006
-@@ -19956,7 +19956,7 @@
+--- configure.orig Mon Jul 16 08:10:12 2007
++++ configure Mon Jul 16 08:10:48 2007
+@@ -20038,7 +20038,7 @@
case "$target_os" in
--linux*)
-+linux*|freebsd*)
+-linux*|darwin*|netbsd*)
++linux*|darwin*|netbsd*|freebsd*)
- succeeded=no
+ if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
diff --git a/sysutils/fusefs-ntfs/files/patch-libntfs-3g__unix_io.c b/sysutils/fusefs-ntfs/files/patch-libntfs-3g__unix_io.c
index 41dc4af32b20..a1759380abf0 100644
--- a/sysutils/fusefs-ntfs/files/patch-libntfs-3g__unix_io.c
+++ b/sysutils/fusefs-ntfs/files/patch-libntfs-3g__unix_io.c
@@ -1,5 +1,5 @@
---- libntfs-3g/unix_io.c.orig Tue Dec 12 20:16:43 2006
-+++ libntfs-3g/unix_io.c Thu May 3 22:27:13 2007
+--- libntfs-3g/unix_io.c.orig Fri Jun 8 23:35:33 2007
++++ libntfs-3g/unix_io.c Mon Jul 16 07:58:02 2007
@@ -54,6 +54,22 @@
#include <linux/fd.h>
#endif
@@ -264,12 +264,11 @@
if (!NDevOpen(dev)) {
errno = EBADF;
-@@ -155,14 +325,21 @@
- }
- if (NDevDirty(dev))
- fsync(DEV_FD(dev));
+@@ -160,12 +330,19 @@
+ return -1;
+ }
+
+#if USE_LOCK
- /* Release exclusive (mandatory) lock on the whole device. */
memset(&flk, 0, sizeof(flk));
flk.l_type = F_UNLCK;
flk.l_whence = SEEK_SET;
@@ -277,18 +276,16 @@
- if (fcntl(DEV_FD(dev), F_SETLK, &flk))
+
+ if (!NDevBlock(dev) && fcntl(DEV_FD(dev), F_SETLK, &flk))
- ntfs_log_perror("ntfs_device_unix_io_close: Warning: Could not "
-- "unlock %s", dev->d_name);
-+ "unlock %s", dev->d_name);
+ ntfs_log_perror("Could not unlock %s", dev->d_name);
+#endif
+#if USE_UBLIO
+ if (DEV_HANDLE(dev)->ublio_fh)
+ ublio_close(DEV_HANDLE(dev)->ublio_fh);
+#endif
- /* Close the file descriptor and clear our open flag. */
- if (close(DEV_FD(dev)))
+ if (close(DEV_FD(dev))) {
+ ntfs_log_perror("Failed to close device %s", dev->d_name);
return -1;
-@@ -185,10 +362,235 @@
+@@ -189,9 +366,234 @@
static s64 ntfs_device_unix_io_seek(struct ntfs_device *dev, s64 offset,
int whence)
{
@@ -325,8 +322,8 @@
+#else
return lseek(DEV_FD(dev), offset, whence);
+#endif
-+}
-+
+ }
+
+#if USE_ALIGNED_IO
+
+#if USE_UBLIO
@@ -408,9 +405,9 @@
+ if (nr > count)
+ nr = count;
+ return nr;
- }
-
- /**
++}
++
++/**
+ * aligned_pwrite - Perform an aligned positioned write from the device
+ */
+static s64 aligned_pwrite(struct ntfs_device *dev, void *buf, s64 count, s64 offset)
@@ -520,11 +517,10 @@
+
+#endif
+
-+/**
+ /**
* ntfs_device_unix_io_read - Read from the device, from the current location
* @dev:
- * @buf:
-@@ -201,6 +603,29 @@
+@@ -205,6 +607,29 @@
static s64 ntfs_device_unix_io_read(struct ntfs_device *dev, void *buf,
s64 count)
{
@@ -554,7 +550,7 @@
return read(DEV_FD(dev), buf, count);
}
-@@ -222,6 +647,28 @@
+@@ -226,6 +651,28 @@
return -1;
}
NDevSetDirty(dev);
@@ -583,7 +579,7 @@
return write(DEV_FD(dev), buf, count);
}
-@@ -239,6 +686,13 @@
+@@ -243,6 +690,13 @@
static s64 ntfs_device_unix_io_pread(struct ntfs_device *dev, void *buf,
s64 count, s64 offset)
{
@@ -597,7 +593,7 @@
return pread(DEV_FD(dev), buf, count, offset);
}
-@@ -261,6 +715,13 @@
+@@ -265,6 +719,13 @@
return -1;
}
NDevSetDirty(dev);
@@ -611,13 +607,10 @@
return pwrite(DEV_FD(dev), buf, count, offset);
}
-@@ -275,7 +736,16 @@
- static int ntfs_device_unix_io_sync(struct ntfs_device *dev)
- {
+@@ -281,6 +742,13 @@
+ int res = 0;
+
if (!NDevReadOnly(dev)) {
-- int res = fsync(DEV_FD(dev));
-+ int res;
-+
+#if USE_UBLIO
+ if (DEV_HANDLE(dev)->ublio_fh) {
+ res = ublio_fsync(DEV_HANDLE(dev)->ublio_fh);
@@ -625,7 +618,6 @@
+ return res;
+ }
+#endif
-+ res = fsync(DEV_FD(dev));
- if (!res)
- NDevClearDirty(dev);
- return res;
+ res = fsync(DEV_FD(dev));
+ if (res)
+ ntfs_log_perror("Failed to sync device %s", dev->d_name);
diff --git a/sysutils/fusefs-ntfs/pkg-plist b/sysutils/fusefs-ntfs/pkg-plist
index 8a0db0f2683d..deaeee1295d7 100644
--- a/sysutils/fusefs-ntfs/pkg-plist
+++ b/sysutils/fusefs-ntfs/pkg-plist
@@ -31,5 +31,5 @@ include/ntfs-3g/volume.h
lib/libntfs-3g.a
lib/libntfs-3g.la
lib/libntfs-3g.so
-lib/libntfs-3g.so.1
+lib/libntfs-3g.so.5
@dirrm include/ntfs-3g