aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-simple-mtpfs
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-24 16:14:28 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-24 16:14:28 +0000
commitb2edba82013a8f93e2a008ce3ad2ec5a04c9a0e7 (patch)
tree8a15b869da28fb2608150af51400c92fea8c8534 /sysutils/fusefs-simple-mtpfs
parent990eee49c44ea60563b1d13cbd633b9cefd01324 (diff)
downloadports-b2edba82013a8f93e2a008ce3ad2ec5a04c9a0e7.tar.gz
ports-b2edba82013a8f93e2a008ce3ad2ec5a04c9a0e7.zip
Add sysutils/fusefs-simple-mtpfs.
Simple FUSE filesystem for reading from and writing to MTP devices. SIMPLE-MTPFS (Simple Media Transfer Protocol FileSystem) is a file system for Linux (and other operating systems with a FUSE implementation, such as Mac OS X or FreeBSD) capable of operating on files on MTP devices attached via USB to local machine. WWW: https://github.com/phatina/simple-mtpfs PR: 192552 Submitted by: Jan Beich
Notes
Notes: svn path=/head/; revision=365953
Diffstat (limited to 'sysutils/fusefs-simple-mtpfs')
-rw-r--r--sysutils/fusefs-simple-mtpfs/Makefile42
-rw-r--r--sysutils/fusefs-simple-mtpfs/distinfo2
-rw-r--r--sysutils/fusefs-simple-mtpfs/pkg-descr8
3 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/fusefs-simple-mtpfs/Makefile b/sysutils/fusefs-simple-mtpfs/Makefile
new file mode 100644
index 000000000000..c52872683c69
--- /dev/null
+++ b/sysutils/fusefs-simple-mtpfs/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= simple-mtpfs
+PORTVERSION= 0.2.s20140709
+CATEGORIES= sysutils
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= jbeich@vfemail.net
+COMMENT= Simple MTP fuse filesystem driver
+
+LICENSE= GPLv2 # or any later version
+
+LIB_DEPENDS= libmtp.so:${PORTSDIR}/multimedia/libmtp
+
+USE_GITHUB= yes
+GH_ACCOUNT= phatina
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 74dfce6
+
+USES= compiler:c++11-lib fuse pkgconfig
+USE_AUTOTOOLS= aclocal autoconf autoheader automake
+AUTOMAKE_ARGS= --add-missing
+MAKEFILE= makefile
+MAKE_ENV= V=1
+INSTALL_TARGET= install-strip
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+PORTDOCS= AUTHORS NEWS README.md
+
+OPTIONS_DEFINE= DOCS
+
+.if !exists(/usr/libdata/pkgconfig/libusb-1.0.pc)
+CONFIGURE_ENV+= LIBUSB1_CFLAGS=" " LIBUSB1_LIBS="-lusb"
+.endif
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:C|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-simple-mtpfs/distinfo b/sysutils/fusefs-simple-mtpfs/distinfo
new file mode 100644
index 000000000000..461ff871ef5a
--- /dev/null
+++ b/sysutils/fusefs-simple-mtpfs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (simple-mtpfs-0.2.s20140709.tar.gz) = ef1f96d17b594513cac65e32ca75d8b1368c3bd6b916f446b060984030fb394e
+SIZE (simple-mtpfs-0.2.s20140709.tar.gz) = 35333
diff --git a/sysutils/fusefs-simple-mtpfs/pkg-descr b/sysutils/fusefs-simple-mtpfs/pkg-descr
new file mode 100644
index 000000000000..68fdce876bb3
--- /dev/null
+++ b/sysutils/fusefs-simple-mtpfs/pkg-descr
@@ -0,0 +1,8 @@
+Simple FUSE filesystem for reading from and writing to MTP devices.
+
+SIMPLE-MTPFS (Simple Media Transfer Protocol FileSystem) is a file system for
+Linux (and other operating systems with a FUSE implementation, such as Mac OS X
+or FreeBSD) capable of operating on files on MTP devices attached via USB to
+local machine.
+
+WWW: https://github.com/phatina/simple-mtpfs