aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-smbnetfs
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-30 19:27:27 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-30 19:27:27 +0000
commita5f2be50aac571b898ed936a7b6b970546818caf (patch)
treef244d1c731626d69f6bc9e6804919f98a71a65ae /sysutils/fusefs-smbnetfs
parent0d3c33f3bbddd87fd3c3aca3e90fa2f9c5fe77a3 (diff)
downloadports-a5f2be50aac571b898ed936a7b6b970546818caf.tar.gz
ports-a5f2be50aac571b898ed936a7b6b970546818caf.zip
sysutils/fusefs-smbnetfs: fix build with GCC-based architectures
This port requires USES=compiler:c11 and including strings.h in one source file to build on GCC architectures. event.o:(.text+0x838): undefined reference to `g_atomic_int_get' event.o:(.text+0x9c4): undefined reference to `g_atomic_int_get' event.o:(.text+0x9dc): undefined reference to `g_atomic_int_set' PR: 237221 Approved by: mi@ALDAN.algebra.com (maintainer timeout), mat (mentor) Differential Revision: https://reviews.freebsd.org/D20108
Notes
Notes: svn path=/head/; revision=500560
Diffstat (limited to 'sysutils/fusefs-smbnetfs')
-rw-r--r--sysutils/fusefs-smbnetfs/Makefile2
-rw-r--r--sysutils/fusefs-smbnetfs/files/patch-src_fusepod__util.h10
2 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/fusefs-smbnetfs/Makefile b/sysutils/fusefs-smbnetfs/Makefile
index 5c02384d9bfe..00fe22a02f5c 100644
--- a/sysutils/fusefs-smbnetfs/Makefile
+++ b/sysutils/fusefs-smbnetfs/Makefile
@@ -22,7 +22,7 @@ LIBSECRET_LIB_DEPENDS= libsecret-*.so:security/libsecret
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-USES= fuse iconv pkgconfig samba:lib tar:bzip2
+USES= compiler:c11 fuse iconv pkgconfig samba:lib tar:bzip2
USE_GNOME= glib20:build
GNU_CONFIGURE= yes
diff --git a/sysutils/fusefs-smbnetfs/files/patch-src_fusepod__util.h b/sysutils/fusefs-smbnetfs/files/patch-src_fusepod__util.h
new file mode 100644
index 000000000000..e4bb07a47865
--- /dev/null
+++ b/sysutils/fusefs-smbnetfs/files/patch-src_fusepod__util.h
@@ -0,0 +1,10 @@
+--- src/fusepod_util.h.orig 2019-04-09 11:38:35 UTC
++++ src/fusepod_util.h
+@@ -15,6 +15,7 @@
+ #ifndef _FUSEPOD_UTIL_H_
+ #define _FUSEPOD_UTIL_H_
+
++#include <strings.h>
+ #include <vector>
+ #include <string>
+