aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-sshfs
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-06-05 14:46:31 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-06-05 14:46:31 +0000
commit87096d40bb6fba52cb7471fe19826511a1a8d857 (patch)
treed71800e09ce6b76f5bea2de4ed0814826dff5e40 /sysutils/fusefs-sshfs
parent3d5a9361da054793530e695c82e25955611a6cc0 (diff)
downloadports-87096d40bb6fba52cb7471fe19826511a1a8d857.tar.gz
ports-87096d40bb6fba52cb7471fe19826511a1a8d857.zip
sysutils/fusefs-sshfs: Improve FreeBSD support
- include posix_openpt() usage patch - add workaround for readdir() issue: #211 - fix few warnings - Add DOCS option - remove gettext dep Upstream patches: https://github.com/libfuse/sshfs/pull/212 https://github.com/libfuse/sshfs/issues/211 PR: 246325 Submitted by: rozhuk.im@gmail.com
Notes
Notes: svn path=/head/; revision=538024
Diffstat (limited to 'sysutils/fusefs-sshfs')
-rw-r--r--sysutils/fusefs-sshfs/Makefile17
-rw-r--r--sysutils/fusefs-sshfs/distinfo4
-rw-r--r--sysutils/fusefs-sshfs/files/patch-sshfs.c11
3 files changed, 15 insertions, 17 deletions
diff --git a/sysutils/fusefs-sshfs/Makefile b/sysutils/fusefs-sshfs/Makefile
index 9ebaa60dabca..252695215968 100644
--- a/sysutils/fusefs-sshfs/Makefile
+++ b/sysutils/fusefs-sshfs/Makefile
@@ -4,18 +4,21 @@
PORTNAME= sshfs
PORTVERSION= 3.7.0
DISTVERSIONPREFIX= ${PORTNAME}-
+PORTREVISION= 1
CATEGORIES= sysutils
PKGNAMEPREFIX= fusefs-
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 952a9c3fda977bce61303ae3311a3adca3d338bf.patch:-p1 # https://github.com/libfuse/sshfs/pull/212
+
MAINTAINER= bofh@FreeBSD.org
COMMENT= Mount remote directories over ssh
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= rst2man:textproc/py-docutils
-
-USES= compiler:c11 fuse:3 gettext gnome meson pkgconfig
+USES= compiler:c11 fuse:3 gnome meson pkgconfig
+USE_GNOME= glib20
USE_GITHUB= yes
GH_ACCOUNT= libfuse
@@ -23,7 +26,11 @@ GH_ACCOUNT= libfuse
USE_GNOME= glib20
CFLAGS+= -DNDEBUG
-PLIST_FILES= bin/sshfs \
- man/man1/sshfs.1.gz
+PLIST_FILES= bin/sshfs
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= rst2man:textproc/py-docutils
+DOCS_PLIST_FILES= man/man1/sshfs.1.gz
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-sshfs/distinfo b/sysutils/fusefs-sshfs/distinfo
index 861ee557732e..88e668f2610d 100644
--- a/sysutils/fusefs-sshfs/distinfo
+++ b/sysutils/fusefs-sshfs/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1580925910
+TIMESTAMP = 1589058688
SHA256 (libfuse-sshfs-sshfs-3.7.0_GH0.tar.gz) = 4037add37cfcd9bb4386c28d1eeed89b56ef5001bcbc3f001f73f38f41a40b73
SIZE (libfuse-sshfs-sshfs-3.7.0_GH0.tar.gz) = 62912
+SHA256 (952a9c3fda977bce61303ae3311a3adca3d338bf.patch) = 9b55c00a9b63715eeb836c253683240d78e23f824cbf07c07570e74ec2c6b507
+SIZE (952a9c3fda977bce61303ae3311a3adca3d338bf.patch) = 6826
diff --git a/sysutils/fusefs-sshfs/files/patch-sshfs.c b/sysutils/fusefs-sshfs/files/patch-sshfs.c
deleted file mode 100644
index e7122232805b..000000000000
--- a/sysutils/fusefs-sshfs/files/patch-sshfs.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- sshfs.c.orig 2018-01-08 21:05:08 UTC
-+++ sshfs.c
-@@ -971,7 +971,7 @@ static int pty_master(char **name)
- {
- int mfd;
-
-- mfd = open("/dev/ptmx", O_RDWR | O_NOCTTY);
-+ mfd = posix_openpt(O_RDWR | O_NOCTTY);
- if (mfd == -1) {
- perror("failed to open pty");
- return -1;