aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-sshfs
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2017-10-28 21:36:28 +0000
committerStefan Eßer <se@FreeBSD.org>2017-10-28 21:36:28 +0000
commita9e0dfb648698b1cb123f72e337c6cedb484d12d (patch)
tree4827545dc10d4b764e6507134803a7732cc5a951 /sysutils/fusefs-sshfs
parent08578bc178947c34ce02346565b881e79954b8f3 (diff)
downloadports-a9e0dfb648698b1cb123f72e337c6cedb484d12d.tar.gz
ports-a9e0dfb648698b1cb123f72e337c6cedb484d12d.zip
Notes
Diffstat (limited to 'sysutils/fusefs-sshfs')
-rw-r--r--sysutils/fusefs-sshfs/Makefile9
-rw-r--r--sysutils/fusefs-sshfs/distinfo6
-rw-r--r--sysutils/fusefs-sshfs/files/patch-meson.build19
-rw-r--r--sysutils/fusefs-sshfs/files/patch-sshfs.c4
-rw-r--r--sysutils/fusefs-sshfs/files/patch-test_meson.build11
5 files changed, 40 insertions, 9 deletions
diff --git a/sysutils/fusefs-sshfs/Makefile b/sysutils/fusefs-sshfs/Makefile
index 70f7acc9d993..fa4d8b40c74f 100644
--- a/sysutils/fusefs-sshfs/Makefile
+++ b/sysutils/fusefs-sshfs/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= sshfs
-PORTVERSION= 2.9
+PORTVERSION= 3.3.0
DISTVERSIONPREFIX= ${PORTNAME}-
-PORTREVISION= 1
CATEGORIES= sysutils
PKGNAMEPREFIX= fusefs-
@@ -14,11 +13,13 @@ COMMENT= Mount remote directories over ssh
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= rst2man:textproc/py-docutils
+
+USES= fuse:3 gettext meson pkgconfig
+
USE_GITHUB= yes
GH_ACCOUNT= libfuse
-GNU_CONFIGURE= yes
-USES= autoreconf fuse gettext pkgconfig
USE_GNOME= glib20
PLIST_FILES= bin/sshfs \
diff --git a/sysutils/fusefs-sshfs/distinfo b/sysutils/fusefs-sshfs/distinfo
index a8bf5f4607f0..8bd0d18ee5a2 100644
--- a/sysutils/fusefs-sshfs/distinfo
+++ b/sysutils/fusefs-sshfs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496617699
-SHA256 (libfuse-sshfs-sshfs-2.9_GH0.tar.gz) = 8ab824024104508d90b9e10292b2c27a34a248aca6712593e5695cfbae20f633
-SIZE (libfuse-sshfs-sshfs-2.9_GH0.tar.gz) = 51000
+TIMESTAMP = 1507553211
+SHA256 (libfuse-sshfs-sshfs-3.3.0_GH0.tar.gz) = 6cb256a894d0284a4ca9967c9f0c35c5c761e8a7496b81343aac0d45d73c1466
+SIZE (libfuse-sshfs-sshfs-3.3.0_GH0.tar.gz) = 54703
diff --git a/sysutils/fusefs-sshfs/files/patch-meson.build b/sysutils/fusefs-sshfs/files/patch-meson.build
new file mode 100644
index 000000000000..54d1b672f374
--- /dev/null
+++ b/sysutils/fusefs-sshfs/files/patch-meson.build
@@ -0,0 +1,19 @@
+--- meson.build.orig 2017-09-20 17:08:27 UTC
++++ meson.build
+@@ -58,15 +58,10 @@ executable('sshfs', sshfs_sources,
+ if rst2man.found()
+ custom_target('manpages', input: [ 'sshfs.rst' ], output: [ 'sshfs.1' ],
+ command: [rst2man, '@INPUT@', '@OUTPUT@'], install: true,
+- install_dir: join_paths(get_option('mandir'), '1'))
++ install_dir: join_paths(get_option('mandir'), 'man1'))
+ else
+ message('rst2man not found, not building manual page.')
+ endif
+-
+-meson.add_install_script('utils/install_helper.sh',
+- get_option('sbindir'),
+- get_option('bindir'))
+-
+
+ subdir('test')
+
diff --git a/sysutils/fusefs-sshfs/files/patch-sshfs.c b/sysutils/fusefs-sshfs/files/patch-sshfs.c
index d89f099f08b9..dd4e469ac2b7 100644
--- a/sysutils/fusefs-sshfs/files/patch-sshfs.c
+++ b/sysutils/fusefs-sshfs/files/patch-sshfs.c
@@ -1,6 +1,6 @@
---- sshfs.c.orig 2017-03-17 21:07:50 UTC
+--- sshfs.c.orig 2017-09-20 17:08:27 UTC
+++ sshfs.c
-@@ -1027,7 +1027,7 @@ static int pty_master(char **name)
+@@ -965,7 +965,7 @@ static int pty_master(char **name)
{
int mfd;
diff --git a/sysutils/fusefs-sshfs/files/patch-test_meson.build b/sysutils/fusefs-sshfs/files/patch-test_meson.build
new file mode 100644
index 000000000000..994ceaabc377
--- /dev/null
+++ b/sysutils/fusefs-sshfs/files/patch-test_meson.build
@@ -0,0 +1,11 @@
+--- test/meson.build.orig 2017-09-20 17:08:27 UTC
++++ test/meson.build
+@@ -2,7 +2,7 @@ test_scripts = [ 'conftest.py', 'pytest.ini', 'test_ss
+ 'util.py' ]
+ custom_target('test_scripts', input: test_scripts,
+ output: test_scripts, build_by_default: true,
+- command: ['cp', '-fP', '--preserve=mode',
++ command: ['cp', '-fPp',
+ '@INPUT@', meson.current_build_dir() ])
+
+ # Provide something helpful when running 'ninja test'