aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-sshfs
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-01-08 21:58:18 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-01-08 21:58:18 +0000
commitf09f8484f08f59450273ec1a84bac6485fae19d1 (patch)
treeab448db9feee4f5ee65f964e289689326463eadd /sysutils/fusefs-sshfs
parentc3d0e41e712dadaabe02e4a3dc89384f0c80c365 (diff)
downloadports-f09f8484f08f59450273ec1a84bac6485fae19d1.tar.gz
ports-f09f8484f08f59450273ec1a84bac6485fae19d1.zip
Notes
Diffstat (limited to 'sysutils/fusefs-sshfs')
-rw-r--r--sysutils/fusefs-sshfs/Makefile3
-rw-r--r--sysutils/fusefs-sshfs/distinfo6
-rw-r--r--sysutils/fusefs-sshfs/files/patch-meson.build14
-rw-r--r--sysutils/fusefs-sshfs/files/patch-sshfs.c4
-rw-r--r--sysutils/fusefs-sshfs/files/patch-test_meson.build11
5 files changed, 11 insertions, 27 deletions
diff --git a/sysutils/fusefs-sshfs/Makefile b/sysutils/fusefs-sshfs/Makefile
index fa4d8b40c74f..53226049f879 100644
--- a/sysutils/fusefs-sshfs/Makefile
+++ b/sysutils/fusefs-sshfs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sshfs
-PORTVERSION= 3.3.0
+PORTVERSION= 3.3.1
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= sysutils
PKGNAMEPREFIX= fusefs-
@@ -21,6 +21,7 @@ USE_GITHUB= yes
GH_ACCOUNT= libfuse
USE_GNOME= glib20
+CFLAGS+= -DNDEBUG
PLIST_FILES= bin/sshfs \
man/man1/sshfs.1.gz
diff --git a/sysutils/fusefs-sshfs/distinfo b/sysutils/fusefs-sshfs/distinfo
index 8bd0d18ee5a2..442596c0d4fe 100644
--- a/sysutils/fusefs-sshfs/distinfo
+++ b/sysutils/fusefs-sshfs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1507553211
-SHA256 (libfuse-sshfs-sshfs-3.3.0_GH0.tar.gz) = 6cb256a894d0284a4ca9967c9f0c35c5c761e8a7496b81343aac0d45d73c1466
-SIZE (libfuse-sshfs-sshfs-3.3.0_GH0.tar.gz) = 54703
+TIMESTAMP = 1515443900
+SHA256 (libfuse-sshfs-sshfs-3.3.1_GH0.tar.gz) = 5310cb14424ba2101e389bd5463a97fbea044674d1cd3275e1a4f5cba2016668
+SIZE (libfuse-sshfs-sshfs-3.3.1_GH0.tar.gz) = 54928
diff --git a/sysutils/fusefs-sshfs/files/patch-meson.build b/sysutils/fusefs-sshfs/files/patch-meson.build
index 54d1b672f374..7922ced06d4f 100644
--- a/sysutils/fusefs-sshfs/files/patch-meson.build
+++ b/sysutils/fusefs-sshfs/files/patch-meson.build
@@ -1,19 +1,13 @@
---- meson.build.orig 2017-09-20 17:08:27 UTC
+--- meson.build.orig 2017-10-25 18:32:34 UTC
+++ meson.build
-@@ -58,15 +58,10 @@ executable('sshfs', sshfs_sources,
- if rst2man.found()
- custom_target('manpages', input: [ 'sshfs.rst' ], output: [ 'sshfs.1' ],
- command: [rst2man, '@INPUT@', '@OUTPUT@'], install: true,
-- install_dir: join_paths(get_option('mandir'), '1'))
-+ install_dir: join_paths(get_option('mandir'), 'man1'))
- else
+@@ -63,10 +63,5 @@ else
message('rst2man not found, not building manual page.')
endif
--
+
-meson.add_install_script('utils/install_helper.sh',
- get_option('sbindir'),
- get_option('bindir'))
-
-
+-
subdir('test')
diff --git a/sysutils/fusefs-sshfs/files/patch-sshfs.c b/sysutils/fusefs-sshfs/files/patch-sshfs.c
index dd4e469ac2b7..e7122232805b 100644
--- a/sysutils/fusefs-sshfs/files/patch-sshfs.c
+++ b/sysutils/fusefs-sshfs/files/patch-sshfs.c
@@ -1,6 +1,6 @@
---- sshfs.c.orig 2017-09-20 17:08:27 UTC
+--- sshfs.c.orig 2018-01-08 21:05:08 UTC
+++ sshfs.c
-@@ -965,7 +965,7 @@ static int pty_master(char **name)
+@@ -971,7 +971,7 @@ static int pty_master(char **name)
{
int mfd;
diff --git a/sysutils/fusefs-sshfs/files/patch-test_meson.build b/sysutils/fusefs-sshfs/files/patch-test_meson.build
deleted file mode 100644
index 994ceaabc377..000000000000
--- a/sysutils/fusefs-sshfs/files/patch-test_meson.build
+++ /dev/null
@@ -1,11 +0,0 @@
---- test/meson.build.orig 2017-09-20 17:08:27 UTC
-+++ test/meson.build
-@@ -2,7 +2,7 @@ test_scripts = [ 'conftest.py', 'pytest.ini', 'test_ss
- 'util.py' ]
- custom_target('test_scripts', input: test_scripts,
- output: test_scripts, build_by_default: true,
-- command: ['cp', '-fP', '--preserve=mode',
-+ command: ['cp', '-fPp',
- '@INPUT@', meson.current_build_dir() ])
-
- # Provide something helpful when running 'ninja test'