aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-unionfs
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-03-03 09:03:35 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-03-03 09:03:35 +0000
commit2eb17dde3366e8032f262ef4cd75c31f22829058 (patch)
tree38527076da7f2f8f848e7683daea712af75c3933 /sysutils/fusefs-unionfs
parentb846e9d5a199eae7eb1e5c6099fdd4282cda62cf (diff)
downloadports-2eb17dde3366e8032f262ef4cd75c31f22829058.tar.gz
ports-2eb17dde3366e8032f262ef4cd75c31f22829058.zip
- Update to 0.24
Notes
Notes: svn path=/head/; revision=270179
Diffstat (limited to 'sysutils/fusefs-unionfs')
-rw-r--r--sysutils/fusefs-unionfs/Makefile6
-rw-r--r--sysutils/fusefs-unionfs/distinfo5
-rw-r--r--sysutils/fusefs-unionfs/files/patch-unionfs.c14
3 files changed, 5 insertions, 20 deletions
diff --git a/sysutils/fusefs-unionfs/Makefile b/sysutils/fusefs-unionfs/Makefile
index 7171957179c1..cd863fab1680 100644
--- a/sysutils/fusefs-unionfs/Makefile
+++ b/sysutils/fusefs-unionfs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= unionfs
-PORTVERSION= 0.20
+PORTVERSION= 0.24
CATEGORIES= sysutils
MASTER_SITES= http://podgorny.cz/unionfs-fuse/releases/
PKGNAMEPREFIX= fusefs-
@@ -23,12 +23,12 @@ PLIST_FILES= bin/unionfs
USE_BZIP2= yes
do-build:
- (cd ${WRKSRC} && \
+ (cd ${WRKSRC}/src && \
${CC} ${CFLAGS} -I${LOCALBASE}/include/fuse \
-D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=26 -U_POSIX_SYNCHRONIZED_IO \
-o unionfs *.c -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lfuse -lm)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unionfs ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/unionfs ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-unionfs/distinfo b/sysutils/fusefs-unionfs/distinfo
index 374bb787bb16..02255ca30852 100644
--- a/sysutils/fusefs-unionfs/distinfo
+++ b/sysutils/fusefs-unionfs/distinfo
@@ -1,3 +1,2 @@
-MD5 (unionfs-fuse-0.20.tar.bz2) = 5d4e1371b2e5ed1bf00eeed5a83ee078
-SHA256 (unionfs-fuse-0.20.tar.bz2) = c1963796132cb1b45571ff50aacbf4613ed1c02332127e3e26c4b2571e7f43a7
-SIZE (unionfs-fuse-0.20.tar.bz2) = 22907
+SHA256 (unionfs-fuse-0.24.tar.bz2) = d8abc855eb618ac356b1e716599c82f8f0f74dbaee36d4062edc707567121937
+SIZE (unionfs-fuse-0.24.tar.bz2) = 30381
diff --git a/sysutils/fusefs-unionfs/files/patch-unionfs.c b/sysutils/fusefs-unionfs/files/patch-unionfs.c
deleted file mode 100644
index 52938c5dbe0d..000000000000
--- a/sysutils/fusefs-unionfs/files/patch-unionfs.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- unionfs.c.orig Tue Mar 6 10:40:41 2007
-+++ unionfs.c Tue Mar 6 10:46:09 2007
-@@ -192,11 +192,7 @@
-
- int res;
- if (isdatasync) {
--#ifdef _POSIX_SYNCHRONIZED_IO
-- res = fdatasync(fi->fh);
--#else
- res = fsync(fi->fh);
--#endif
- } else {
- res = fsync(fi->fh);
- }