aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-unionfs
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-08-16 15:59:47 +0000
committerSteve Wills <swills@FreeBSD.org>2018-08-16 15:59:47 +0000
commitae922df4516ce639ed863fafbf23e4be49b286f2 (patch)
tree9e4461e348f80c8f3dafa1570d2aa6e3112028fa /sysutils/fusefs-unionfs
parentfa418e04f3d878e23c052f3c263babb360ae7ef2 (diff)
downloadports-ae922df4516ce639ed863fafbf23e4be49b286f2.tar.gz
ports-ae922df4516ce639ed863fafbf23e4be49b286f2.zip
sysutils/fusefs-unionfs: Update to 2.0
While here, assign maintainership to submitter PR: 230521 Submitted by: Nathan <ndowens@yahoo.com>
Notes
Notes: svn path=/head/; revision=477354
Diffstat (limited to 'sysutils/fusefs-unionfs')
-rw-r--r--sysutils/fusefs-unionfs/Makefile4
-rw-r--r--sysutils/fusefs-unionfs/distinfo5
-rw-r--r--sysutils/fusefs-unionfs/files/patch-src__unionfs.c51
3 files changed, 5 insertions, 55 deletions
diff --git a/sysutils/fusefs-unionfs/Makefile b/sysutils/fusefs-unionfs/Makefile
index 8ae73bb0fbeb..5599e3b455c6 100644
--- a/sysutils/fusefs-unionfs/Makefile
+++ b/sysutils/fusefs-unionfs/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= unionfs
-PORTVERSION= 1.0
+PORTVERSION= 2.0
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
PKGNAMEPREFIX= fusefs-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ndowens@yahoo.com
COMMENT= FUSE based implementation of the well-known unionfs
LICENSE= BSD3CLAUSE
diff --git a/sysutils/fusefs-unionfs/distinfo b/sysutils/fusefs-unionfs/distinfo
index 162d32834bc4..982115198e00 100644
--- a/sysutils/fusefs-unionfs/distinfo
+++ b/sysutils/fusefs-unionfs/distinfo
@@ -1,2 +1,3 @@
-SHA256 (rpodgorny-unionfs-fuse-v1.0_GH0.tar.gz) = 2ee80bd0634a61adb2159212e155d607a0a82ad659214ae6edb3530396cccc09
-SIZE (rpodgorny-unionfs-fuse-v1.0_GH0.tar.gz) = 48149
+TIMESTAMP = 1533965149
+SHA256 (rpodgorny-unionfs-fuse-v2.0_GH0.tar.gz) = f24d7dd64c678cefacbebf2727b61e3127b8ecb6bb9176d7117dd31503455643
+SIZE (rpodgorny-unionfs-fuse-v2.0_GH0.tar.gz) = 46537
diff --git a/sysutils/fusefs-unionfs/files/patch-src__unionfs.c b/sysutils/fusefs-unionfs/files/patch-src__unionfs.c
deleted file mode 100644
index 6b9fcbd1afee..000000000000
--- a/sysutils/fusefs-unionfs/files/patch-src__unionfs.c
+++ /dev/null
@@ -1,51 +0,0 @@
---- src/unionfs.c.orig 2015-01-14 10:08:20 UTC
-+++ src/unionfs.c
-@@ -65,6 +65,13 @@
- #include "conf.h"
- #include "uioctl.h"
-
-+// Patch pushed upstream:
-+// https://github.com/rpodgorny/unionfs-fuse/pull/40
-+// Remove this as soon as pushed into a release.
-+#ifdef IOCPARM_LEN
-+#define _IOC_SIZE(nr) IOCPARM_LEN(nr)
-+#endif
-+
- static struct fuse_opt unionfs_opts[] = {
- FUSE_OPT_KEY("chroot=%s,", KEY_CHROOT),
- FUSE_OPT_KEY("cow", KEY_COW),
-@@ -92,7 +99,12 @@ static int unionfs_chmod(const char *pat
- char p[PATHLEN_MAX];
- if (BUILD_PATH(p, uopt.branches[i].path, path)) RETURN(-ENAMETOOLONG);
-
-+// Unsure of origin. Patch needs review.
-+#if __FreeBSD__
-+ int res = lchmod(p, mode);
-+#else
- int res = chmod(p, mode);
-+#endif
- if (res == -1) RETURN(-errno);
-
- RETURN(0);
-@@ -671,6 +683,9 @@ static int unionfs_truncate(const char *
- RETURN(0);
- }
-
-+// Patch pushed upstream:
-+// https://github.com/rpodgorny/unionfs-fuse/pull/39
-+// Remove this as soon as pushed into a release.
- static int unionfs_utimens(const char *path, const struct timespec ts[2]) {
- DBG("%s\n", path);
-
-@@ -685,9 +700,9 @@ static int unionfs_utimens(const char *p
- #else
- struct timeval tv[2];
- tv[0].tv_sec = ts[0].tv_sec;
-- tv[0].tv_usec = ts[0].tv_nsec * 1000;
-+ tv[0].tv_usec = ts[0].tv_nsec / 1000;
- tv[1].tv_sec = ts[1].tv_sec;
-- tv[1].tv_usec = ts[1].tv_nsec * 1000;
-+ tv[1].tv_usec = ts[1].tv_nsec / 1000;
- int res = utimes(p, tv);
- #endif
-