aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gaffitter
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-29 08:06:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-29 08:06:12 +0000
commitd60cd5d193991695368bd5b66d4450c134ce20dc (patch)
treea78bb3adc12897c91869f48deaf7b286d1107dbe /sysutils/gaffitter
parent1be34a98417515606a33183ab00074718038ef47 (diff)
downloadports-d60cd5d193991695368bd5b66d4450c134ce20dc.tar.gz
ports-d60cd5d193991695368bd5b66d4450c134ce20dc.zip
- Fix parallel builds, by fixing makefile and USES'ing gmake
- Always install manual pages like we normally do - Cleanup Makefile header and COMMENT line while here - Synchronize port description text with upstream Reported by: pointyhat-west
Notes
Notes: svn path=/head/; revision=323872
Diffstat (limited to 'sysutils/gaffitter')
-rw-r--r--sysutils/gaffitter/Makefile15
-rw-r--r--sysutils/gaffitter/pkg-descr20
2 files changed, 15 insertions, 20 deletions
diff --git a/sysutils/gaffitter/Makefile b/sysutils/gaffitter/Makefile
index 192bb714caae..e41b1db66103 100644
--- a/sysutils/gaffitter/Makefile
+++ b/sysutils/gaffitter/Makefile
@@ -1,4 +1,4 @@
-# Created by: corky1951@comcast.net
+# Created by: Charlie Kester <corky1951@comcast.net>
# $FreeBSD$
PORTNAME= gaffitter
@@ -8,22 +8,23 @@ CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Bin packing utility that uses a genetic algorithm
+COMMENT= Binary packing utility that uses a genetic algorithm
LICENSE= GPLv3 # or later
USE_BZIP2= yes
+USES= gmake # parallel builds (-jX) are broken with BSD make(1)
-.if !defined(NO_INSTALL_MANPAGES)
MAN1= ${PORTNAME}.1
-.endif
-
PLIST_FILES= bin/${PORTNAME}
+# Change "cd foo; $(MAKE)" into "$(MAKE) -C foo" to unbreak parallel builds
+post-patch:
+ @${REINPLACE_CMD} -E 's|cd (.+); (\$$\(MAKE\))|\2 -C \1|' \
+ ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
-.if !defined(NO_INSTALL_MANPAGES)
${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
-.endif
.include <bsd.port.mk>
diff --git a/sysutils/gaffitter/pkg-descr b/sysutils/gaffitter/pkg-descr
index a73485f1fab3..1c10ae92f978 100644
--- a/sysutils/gaffitter/pkg-descr
+++ b/sysutils/gaffitter/pkg-descr
@@ -1,15 +1,9 @@
-Genetic Algorithm File Fitter, GAFFitter for short, is a tool based
-on a genetic algorithm (GA) that tries to fit a collection of items
-into as few as possible volumes of a specific size.
+Genetic Algorithm File Fitter, or just GAFFitter, is a command-line software
+written in C++ that arranges -- via a genetic algorithm -- an input list of
+items or files/directories into volumes of a certain capacity (target), such
+as CD or DVD, in a way that the total wastage is minimized.
-For example, the items might be files/directories and the volumes
-might be CDs or DVDs.
+By smartly arranging the input list, GAFFitter fits better the given items
+and so optimizes (reduces) the number of required volumes to pack them.
-The task of arranging items in such manner that the number of
-required bins is minimized is called Bin Packing, a NP-hard
-combinatorial problem for which no deterministic polynomial-time
-algorithm is known. Using heuristics, such as GAs, it is usually
-possible to approximate -- and often reach -- the best solution for
-the problem within a reasonable time.
-
-WWW: http://gaffitter.sourceforge.net
+WWW: http://gaffitter.sourceforge.net/