aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ganglia-webfrontend
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2011-05-25 23:14:39 +0000
committerBrooks Davis <brooks@FreeBSD.org>2011-05-25 23:14:39 +0000
commit5d71c18168f48fce7a5e910a13272c519e168714 (patch)
treeeaca5d8b1802ddbd22295f84ea8cdbcaa90b1d71 /sysutils/ganglia-webfrontend
parent1032f1fb28bc4338c6ef322e71712f9c3a484f88 (diff)
downloadports-5d71c18168f48fce7a5e910a13272c519e168714.tar.gz
ports-5d71c18168f48fce7a5e910a13272c519e168714.zip
In addition to arp-1, we need libconfuse and libpcre about to build.
Because gmetad is a RUN_DEPEND and requires them, abuse LIB_DEPEND here even though these are technically build depends. Reported by: pav
Notes
Notes: svn path=/head/; revision=274664
Diffstat (limited to 'sysutils/ganglia-webfrontend')
-rw-r--r--sysutils/ganglia-webfrontend/Makefile9
-rw-r--r--sysutils/ganglia-webfrontend/pkg-plist2
2 files changed, 7 insertions, 4 deletions
diff --git a/sysutils/ganglia-webfrontend/Makefile b/sysutils/ganglia-webfrontend/Makefile
index 7128bdb15a98..a72541fe13a9 100644
--- a/sysutils/ganglia-webfrontend/Makefile
+++ b/sysutils/ganglia-webfrontend/Makefile
@@ -7,6 +7,7 @@
PORTNAME= webfrontend
PORTVERSION= 3.1.7
+PORTREVISION= 1
CATEGORIES= sysutils net parallel www
MASTER_SITES= SF/ganglia/ganglia%20monitoring%20core/${PORTVERSION}
PKGNAMEPREFIX= ganglia-
@@ -15,8 +16,10 @@ DISTNAME= ganglia-${PORTVERSION}
MAINTAINER= brooks@FreeBSD.org
COMMENT= Ganglia cluster monitor, web frontend
-LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1
-RUN_DEPENDS+= ${LOCALBASE}/sbin/gmetad:${PORTSDIR}/sysutils/ganglia-monitor-core
+LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1 \
+ confuse:${PORTSDIR}/devel/libconfuse \
+ pcre:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= ${LOCALBASE}/sbin/gmetad:${PORTSDIR}/sysutils/ganglia-monitor-core
PKGINSTALL= ${WRKDIR}/pkg-install
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -91,7 +94,7 @@ post-install:
build-plist:
@${RM} ${PLIST}
- @${ECHO_CMD} '@unexec cmp -s %D/%%WEBFRONTDIR%%/conf.php %D/%%WEBFRONTDIR%%/conf.php.sample && rm -f %D/%%WEBFRONTDIR%%/conf.php' >> ${PLIST}
+ @${ECHO_CMD} '@unexec cmp -s %D/%%WEBFRONTDIR%%/conf.php %D/%%WEBFRONTDIR%%/conf.php.sample && ${RM} -f %D/%%WEBFRONTDIR%%/conf.php' >> ${PLIST}
@${FIND} ${TMP_WEBFRONTDIR}/* -type f | \
${SED} -e 's|${TMP_WEBFRONTDIR}|%%WEBFRONTDIR%%|' | \
${SORT} >> ${PLIST}
diff --git a/sysutils/ganglia-webfrontend/pkg-plist b/sysutils/ganglia-webfrontend/pkg-plist
index ef21759f9626..6c469c447cb2 100644
--- a/sysutils/ganglia-webfrontend/pkg-plist
+++ b/sysutils/ganglia-webfrontend/pkg-plist
@@ -65,5 +65,5 @@
@dirrm %%WEBFRONTDIR%%/templates/default
@dirrm %%WEBFRONTDIR%%/templates
@dirrm %%WEBFRONTDIR%%/graph.d
-@dirrmtry /bin/rmdir %D/%%WEBFRONTDIR%%
+@dirrmtry rmdir %D/%%WEBFRONTDIR%%
@unexec (test -d %D/%%WEBFRONTDIR%% && (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove %D/%%WEBFRONTDIR%% and its contents manually.")) || true