aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gdisk
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:42:59 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:58:04 +0000
commit68f3c2ea05f7498ae188bdf35bef1b96abe2e1d0 (patch)
tree8c7d6747a576b3a59671d57b3292e423f1a11fda /sysutils/gdisk
parentf2a37fd43d02f24cec8ce323edd1ddb7a20dfec4 (diff)
Diffstat (limited to 'sysutils/gdisk')
-rw-r--r--sysutils/gdisk/Makefile3
-rw-r--r--sysutils/gdisk/distinfo6
-rw-r--r--sysutils/gdisk/files/patch-Makefile.freebsd42
-rw-r--r--sysutils/gdisk/files/patch-parttypes.h11
-rw-r--r--sysutils/gdisk/pkg-descr29
5 files changed, 31 insertions, 60 deletions
diff --git a/sysutils/gdisk/Makefile b/sysutils/gdisk/Makefile
index 732cd7da5c52..d520e0daa39b 100644
--- a/sysutils/gdisk/Makefile
+++ b/sysutils/gdisk/Makefile
@@ -1,8 +1,7 @@
# Created by: Dmitry N Fomin <fdn@okbire.ru>
PORTNAME= gdisk
-PORTVERSION= 1.0.8
-PORTREVISION= 2
+PORTVERSION= 1.0.9
CATEGORIES= sysutils
MASTER_SITES= SF/gptfdisk/gptfdisk/${PORTVERSION}
DISTNAME= gptfdisk-${PORTVERSION}
diff --git a/sysutils/gdisk/distinfo b/sysutils/gdisk/distinfo
index 1698ac05586f..08cac7a4de3a 100644
--- a/sysutils/gdisk/distinfo
+++ b/sysutils/gdisk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1622214008
-SHA256 (gptfdisk-1.0.8.tar.gz) = 95d19856f004dabc4b8c342b2612e8d0a9eebdd52004297188369f152e9dc6df
-SIZE (gptfdisk-1.0.8.tar.gz) = 208958
+TIMESTAMP = 1650228694
+SHA256 (gptfdisk-1.0.9.tar.gz) = dafead2693faeb8e8b97832b23407f6ed5b3219bc1784f482dd855774e2d50c2
+SIZE (gptfdisk-1.0.9.tar.gz) = 215065
diff --git a/sysutils/gdisk/files/patch-Makefile.freebsd b/sysutils/gdisk/files/patch-Makefile.freebsd
index e57054322592..cb01aa7b6ad2 100644
--- a/sysutils/gdisk/files/patch-Makefile.freebsd
+++ b/sysutils/gdisk/files/patch-Makefile.freebsd
@@ -1,37 +1,11 @@
---- Makefile.freebsd.orig 2021-01-13 22:14:27 UTC
+--- Makefile.freebsd.orig 2022-04-14 23:17:12 UTC
+++ Makefile.freebsd
-@@ -1,8 +1,8 @@
--CC=clang
+@@ -1,6 +1,6 @@
-CXX=clang++
-+CC?=gcc
-+CXX?=g++
- CFLAGS+=-D_FILE_OFFSET_BITS=64
- #CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64 -D USE_UTF16 -I/usr/local/include
--CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64 -I /usr/local/include
-+CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64 ${CPPFLAGS}
- LDFLAGS+=
++CXX?=clang++
+ #CXXFLAGS+=-O2 -Wall -D_FILE_OFFSET_BITS=64 -D USE_UTF16 -I/usr/local/include
+-CXXFLAGS+=-O2 -Wall -D_FILE_OFFSET_BITS=64 -I /usr/local/include
++CXXFLAGS+=-O2 -Wall -D_FILE_OFFSET_BITS=64 $(CPPFLAGS)
+ LDFLAGS+=-L/usr/local/lib
+ LDLIBS+=-luuid #-licuio
LIB_NAMES=crc32 support guid gptpart mbrpart basicmbr mbr gpt bsd parttypes attributes diskio diskio-unix
- MBR_LIBS=support diskio diskio-unix basicmbr mbrpart
-@@ -15,18 +15,18 @@ all: gdisk cgdisk sgdisk fixparts
-
- gdisk: $(LIB_OBJS) gdisk.o gpttext.o
- # $(CXX) $(LIB_OBJS) gdisk.o gpttext.o -L/usr/local/lib $(LDFLAGS) -licuio -luuid -o gdisk
-- $(CXX) $(LIB_OBJS) gdisk.o gpttext.o -L/usr/local/lib $(LDFLAGS) -luuid -o gdisk
-+ $(CXX) $(LIB_OBJS) gdisk.o gpttext.o $(LDFLAGS) -luuid -o gdisk
-
- cgdisk: $(LIB_OBJS) cgdisk.o gptcurses.o
- # $(CXX) $(LIB_OBJS) cgdisk.o gptcurses.o -L/usr/local/lib $(LDFLAGS) -licuio -luuid -lncurses -o cgdisk
-- $(CXX) $(LIB_OBJS) cgdisk.o gptcurses.o -L/usr/local/lib $(LDFLAGS) -luuid -lncurses -o cgdisk
-+ $(CXX) $(LIB_OBJS) cgdisk.o gptcurses.o $(LDFLAGS) -luuid -lncurses -o cgdisk
-
- sgdisk: $(LIB_OBJS) sgdisk.o gptcl.o
- # $(CXX) $(LIB_OBJS) sgdisk.o gptcl.o -L/usr/local/lib $(LDFLAGS) -luuid -licuio -lpopt -o sgdisk
-- $(CXX) $(LIB_OBJS) sgdisk.o gptcl.o -L/usr/local/lib $(LDFLAGS) -luuid -lpopt -o sgdisk
-+ $(CXX) $(LIB_OBJS) sgdisk.o gptcl.o $(LDFLAGS) -luuid -lpopt -o sgdisk
-
- fixparts: $(MBR_LIB_OBJS) fixparts.o
-- $(CXX) $(MBR_LIB_OBJS) fixparts.o -L/usr/local/lib $(LDFLAGS) -o fixparts
-+ $(CXX) $(MBR_LIB_OBJS) fixparts.o $(LDFLAGS) -o fixparts
-
- lint: #no pre-reqs
- lint $(SRCS)
diff --git a/sysutils/gdisk/files/patch-parttypes.h b/sysutils/gdisk/files/patch-parttypes.h
index 457b7bcf16fe..349c5a5b1cb5 100644
--- a/sysutils/gdisk/files/patch-parttypes.h
+++ b/sysutils/gdisk/files/patch-parttypes.h
@@ -1,12 +1,13 @@
---- parttypes.h.orig 2021-01-13 22:14:27 UTC
+--- parttypes.h.orig 2022-04-14 23:17:12 UTC
+++ parttypes.h
-@@ -16,6 +16,9 @@
- #include "guid.h"
+@@ -15,6 +15,10 @@
+ #define UnicodeString std::string
+ #endif
- using namespace std;
+#ifdef USE_UTF16
+using namespace icu;
+#endif
-
++
// A partition type
struct AType {
+ // I'm using a custom 16-bit extension of the original MBR 8-bit
diff --git a/sysutils/gdisk/pkg-descr b/sysutils/gdisk/pkg-descr
index ee49547520c6..57e64bc9d32f 100644
--- a/sysutils/gdisk/pkg-descr
+++ b/sysutils/gdisk/pkg-descr
@@ -1,18 +1,15 @@
-GPT fdisk (aka gdisk) by Roderick W. Smith, rodsmith@rodsbooks.com
+GPT fdisk (aka gdisk) is intended as a (somewhat) fdisk-workalike program for
+GPT-partitioned disks. Specific advantages of gdisk, cgdisk and sgdisk include:
-This software is intended as a (somewhat) fdisk-workalike program for
-GPT-partitioned disks. Specific advantages of gdisk, cgdisk and
-sgdisk include:
+- Edit GUID partition table (GPT) definitions in Linux, FreeBSD, MacOS X, or
+ Windows
+- Convert MBR to GPT or back without data loss
+- Convert BSD disklabels to GPT without data loss
+- Create hybrid MBR, which permits GPT-unaware OSes to access up to three GPT
+ partitions on the disk
+- Repair damaged GPT data structures
+- The ability to specify sector-exact partition sizes
+- Clear identification of the number of unallocated sectors on a disk
- * Edit GUID partition table (GPT) definitions in Linux, FreeBSD, MacOS X,
- or Windows
- * Convert MBR to GPT or back without data loss
- * Convert BSD disklabels to GPT without data loss
- * Create hybrid MBR, which permits GPT-unaware
- OSes to access up to three GPT partitions on the disk
- * Repair damaged GPT data structures
- * The ability to specify sector-exact partition sizes
- * Clear identification of the number of unallocated sectors on a disk
-
-WWW: http://www.rodsbooks.com/gdisk/
- http://www.rodsbooks.com/fixparts/
+WWW: https://www.rodsbooks.com/gdisk/
+WWW: https://www.rodsbooks.com/fixparts/