aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gdmap/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-14 14:36:57 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-14 14:36:57 +0000
commitbc4d2655da0aaaaac3e147311d0fa97e3b213e47 (patch)
tree8ecbafe475400f5bf85a01530ec064e0abe25825 /sysutils/gdmap/Makefile
parent84a074775ada8a663fae07a939188da06b7ea7df (diff)
downloadports-bc4d2655da0aaaaac3e147311d0fa97e3b213e47.tar.gz
ports-bc4d2655da0aaaaac3e147311d0fa97e3b213e47.zip
Notes
Diffstat (limited to 'sysutils/gdmap/Makefile')
-rw-r--r--sysutils/gdmap/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/gdmap/Makefile b/sysutils/gdmap/Makefile
new file mode 100644
index 000000000000..7b938c507b96
--- /dev/null
+++ b/sysutils/gdmap/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gdmap
+# Date created: 13 Oct 2005
+# Whom: Rodrigo Graeff <delphus@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdmap
+PORTVERSION= 0.5.0
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gdmap
+
+MAINTAINER= delphus@gmail.com
+COMMENT= Graphical disk map Utility
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack gtk20
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN1= gdmap.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Doesn't build on FreeBSD < 5.x"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,<sys/vfs.h>,<sys/statvfs.h>,'
+ ${WRKSRC}/src/gui_main.c
+
+.include <bsd.port.post.mk>