aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-control-center
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /sysutils/gnome-control-center
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'sysutils/gnome-control-center')
-rw-r--r--sysutils/gnome-control-center/Makefile13
-rw-r--r--sysutils/gnome-control-center/distinfo4
-rw-r--r--sysutils/gnome-control-center/files/patch-capplets_default-applications_gnome-default-applications-properies-structs.c18
-rw-r--r--sysutils/gnome-control-center/files/patch-capplets_desktop-links_Makefile.in11
-rw-r--r--sysutils/gnome-control-center/files/patch-capplets_gnome-keyboard-properties-xkbot.c33
-rw-r--r--sysutils/gnome-control-center/files/patch-capplets_mouse_gnome-mouse-properties.c29
-rw-r--r--sysutils/gnome-control-center/files/patch-configure8
-rw-r--r--sysutils/gnome-control-center/files/patch-gnome-settings-daemon_actions_Makefile.in11
-rw-r--r--sysutils/gnome-control-center/pkg-plist65
9 files changed, 82 insertions, 110 deletions
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index acbe1f0c2451..075ee3b879d6 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -6,27 +6,26 @@
#
PORTNAME= gnomecontrolcenter2
-PORTVERSION= 2.8.2
-PORTREVISION= 2
+PORTVERSION= 2.10.0
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/control-center/2.8
+MASTER_SITE_SUBDIR= sources/control-center/2.10
DISTNAME= control-center-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Control center for GNOME 2 project
-LIB_DEPENDS= xklavier.8:${PORTSDIR}/x11/libxklavier
+LIB_DEPENDS= xklavier.10:${PORTSDIR}/x11/libxklavier
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack gnomehier intlhack metacity nautilus2 \
- desktopfileutils
USE_GSTREAMER= yes
+USE_GNOME= gnomeprefix gnomehack intlhack metacity nautilus2 \
+ gnomemenus desktopfileutils
USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -42,6 +41,8 @@ GCONF_SCHEMAS= apps_gnome_settings_daemon_default_editor.schemas \
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|[{]prefix[}]/share/pixmaps|{datadir}/pixmaps|g'
+ @${REINPLACE_CMD} -e 's|mozilla-thunderbird|thunderbird|g' \
+ ${WRKSRC}/capplets/default-applications/gnome-default-applications-properties-structs.c
post-install:
@-update-desktop-database
diff --git a/sysutils/gnome-control-center/distinfo b/sysutils/gnome-control-center/distinfo
index e5ac6888440c..e8ada3e49980 100644
--- a/sysutils/gnome-control-center/distinfo
+++ b/sysutils/gnome-control-center/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/control-center-2.8.2.tar.bz2) = 898ef25391c0330a31f36812fdc8a02f
-SIZE (gnome2/control-center-2.8.2.tar.bz2) = 2806342
+MD5 (gnome2/control-center-2.10.0.tar.bz2) = 23ee64b8e559cce4aa6beb70ad675130
+SIZE (gnome2/control-center-2.10.0.tar.bz2) = 2617716
diff --git a/sysutils/gnome-control-center/files/patch-capplets_default-applications_gnome-default-applications-properies-structs.c b/sysutils/gnome-control-center/files/patch-capplets_default-applications_gnome-default-applications-properies-structs.c
deleted file mode 100644
index c6b38bd4daa6..000000000000
--- a/sysutils/gnome-control-center/files/patch-capplets_default-applications_gnome-default-applications-properies-structs.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- capplets/default-applications/gnome-default-applications-properties-structs.c.orig Sun Feb 20 16:18:03 2005
-+++ capplets/default-applications/gnome-default-applications-properties-structs.c Mon Feb 21 15:52:04 2005
-@@ -12,6 +12,7 @@
- { N_("Firebird/FireFox"), "mozilla-firebird", "mozilla-firebird %s", FALSE, FALSE },
- { N_("Firebird/FireFox"), "mozilla-firefox", "mozilla-firebird %s", FALSE, FALSE },
- { N_("Firebird/FireFox"), "firefox", "mozilla-firefox %s", FALSE, FALSE },
-+ { N_("Firebird/FireFox"), "firefox", "firefox %s", FALSE, FALSE },
- { N_("Mozilla/Netscape 6"), "mozilla-1.6", "mozilla-1.6 %s", FALSE, FALSE },
- { N_("Mozilla/Netscape 6"), "mozilla", "mozilla %s", FALSE, FALSE },
- { N_("Netscape Communicator"), "netscape", "netscape %s", FALSE, FALSE },
-@@ -40,6 +41,7 @@
- { N_("Balsa"), "balsa", "balsa -m %s", FALSE, FALSE },
- { N_("KMail"), "kmail", "kmail %s", FALSE, FALSE },
- { N_("Mozilla Mail"), "mozilla", "mozilla -mail %s", FALSE, FALSE},
-+ { N_("Thunderbird"), "thunderbird", "thunderbird %s", FALSE, FALSE},
- { N_("Mutt") , "mutt", "mutt %s", TRUE, FALSE },
-
- };
diff --git a/sysutils/gnome-control-center/files/patch-capplets_desktop-links_Makefile.in b/sysutils/gnome-control-center/files/patch-capplets_desktop-links_Makefile.in
deleted file mode 100644
index 5a6b0ba8f2d6..000000000000
--- a/sysutils/gnome-control-center/files/patch-capplets_desktop-links_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- capplets/desktop-links/Makefile.in.orig Tue Dec 30 15:55:28 2003
-+++ capplets/desktop-links/Makefile.in Tue Dec 30 15:55:49 2003
-@@ -190,7 +190,7 @@
-
- pixmaps_pre = $(capplets:=-capplet.png)
- pixmaps_DATA = $(pixmaps_pre) accessibility-directory.png
--pixmapsdir = $(datadir)/icons/gnome/48x48/apps
-+pixmapsdir = $(prefix)/share/icons/gnome/48x48/apps
-
- desktop_files = $(capplets:=.desktop)
- desktop_in_files = $(desktop_files:.desktop=.desktop.in)
diff --git a/sysutils/gnome-control-center/files/patch-capplets_gnome-keyboard-properties-xkbot.c b/sysutils/gnome-control-center/files/patch-capplets_gnome-keyboard-properties-xkbot.c
new file mode 100644
index 000000000000..02374b23ac45
--- /dev/null
+++ b/sysutils/gnome-control-center/files/patch-capplets_gnome-keyboard-properties-xkbot.c
@@ -0,0 +1,33 @@
+--- capplets/keyboard/gnome-keyboard-properties-xkbot.c.orig Wed Jan 19 18:16:13 2005
++++ capplets/keyboard/gnome-keyboard-properties-xkbot.c Wed Feb 9 21:33:00 2005
+@@ -242,21 +242,25 @@
+ Bool allowMultipleSelection,
+ GladeXML * dialog)
+ {
++ gchar *utfGroupName, *titlemarkup;
++ GtkWidget *expander;
++ GtkWidget *vbox;
++ GtkWidget *align;
+ GSList * expanders_list = g_object_get_data (G_OBJECT (dialog), EXPANDERS_PROP);
+
+ current1stLevelId = configItem->name;
+
+- gchar *utfGroupName = xci_desc_to_utf8 (configItem);
+- gchar *titlemarkup = g_strconcat ("<span>", utfGroupName, "</span>", NULL);
++ utfGroupName = xci_desc_to_utf8 (configItem);
++ titlemarkup = g_strconcat ("<span>", utfGroupName, "</span>", NULL);
+
+- GtkWidget *expander = gtk_expander_new (titlemarkup);
++ expander = gtk_expander_new (titlemarkup);
+ g_object_set_data_full (G_OBJECT (expander), "utfGroupName", utfGroupName, g_free);
+
+ g_free (titlemarkup);
+ gtk_expander_set_use_markup (GTK_EXPANDER (expander), TRUE);
+- GtkWidget *align = gtk_alignment_new (0, 0, 1, 1);
++ align = gtk_alignment_new (0, 0, 1, 1);
+ gtk_alignment_set_padding (GTK_ALIGNMENT (align), 6, 12, 12, 0);
+- GtkWidget *vbox = gtk_vbox_new (TRUE, 6);
++ vbox = gtk_vbox_new (TRUE, 6);
+ gtk_container_add (GTK_CONTAINER (align), vbox);
+ gtk_container_add (GTK_CONTAINER (expander), align);
+ currentVbox = vbox;
diff --git a/sysutils/gnome-control-center/files/patch-capplets_mouse_gnome-mouse-properties.c b/sysutils/gnome-control-center/files/patch-capplets_mouse_gnome-mouse-properties.c
deleted file mode 100644
index 9c487d7b8e9d..000000000000
--- a/sysutils/gnome-control-center/files/patch-capplets_mouse_gnome-mouse-properties.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- capplets/mouse/gnome-mouse-properties.c.orig Sat Nov 2 13:40:22 2002
-+++ capplets/mouse/gnome-mouse-properties.c Sun Dec 22 16:33:36 2002
-@@ -591,7 +591,7 @@
- filename = gnome_program_locate_file (program, GNOME_FILE_DOMAIN_APP_PIXMAP, "mouse-cursor-white.png", TRUE, NULL);
- pixbuf = gdk_pixbuf_new_from_file (filename, NULL);
- g_free (filename);
-- font_path = gnome_program_locate_file (program, GNOME_FILE_DOMAIN_DATADIR, "gnome/cursor-fonts/cursor-white.pcf", FALSE, NULL);
-+ font_path = gnome_program_locate_file (program, GNOME_FILE_DOMAIN_DATADIR, "cursor-fonts/cursor-white.pcf", FALSE, NULL);
-
- gtk_list_store_append (GTK_LIST_STORE (model), &iter);
- if (cursor_font && ! strcmp (cursor_font, font_path)) {
-@@ -612,7 +612,7 @@
- filename = gnome_program_locate_file (program, GNOME_FILE_DOMAIN_APP_PIXMAP, "mouse-cursor-normal-large.png", TRUE, NULL);
- pixbuf = gdk_pixbuf_new_from_file (filename, NULL);
- g_free (filename);
-- font_path = gnome_program_locate_file (program, GNOME_FILE_DOMAIN_DATADIR, "gnome/cursor-fonts/cursor-large.pcf", FALSE, NULL);
-+ font_path = gnome_program_locate_file (program, GNOME_FILE_DOMAIN_DATADIR, "cursor-fonts/cursor-large.pcf", FALSE, NULL);
-
- gtk_list_store_append (GTK_LIST_STORE (model), &iter);
- if (cursor_font && ! strcmp (cursor_font, font_path)) {
-@@ -633,7 +633,7 @@
- filename = gnome_program_locate_file (program, GNOME_FILE_DOMAIN_APP_PIXMAP, "mouse-cursor-white-large.png", TRUE, NULL);
- pixbuf = gdk_pixbuf_new_from_file (filename, NULL);
- g_free (filename);
-- font_path = gnome_program_locate_file (program, GNOME_FILE_DOMAIN_DATADIR, "gnome/cursor-fonts/cursor-large-white.pcf", FALSE, NULL);
-+ font_path = gnome_program_locate_file (program, GNOME_FILE_DOMAIN_DATADIR, "cursor-fonts/cursor-large-white.pcf", FALSE, NULL);
-
- gtk_list_store_append (GTK_LIST_STORE (model), &iter);
- if (cursor_font && ! strcmp (cursor_font, font_path)) {
diff --git a/sysutils/gnome-control-center/files/patch-configure b/sysutils/gnome-control-center/files/patch-configure
index f97758e10ba0..d8e861724bd3 100644
--- a/sysutils/gnome-control-center/files/patch-configure
+++ b/sysutils/gnome-control-center/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Feb 21 15:53:01 2005
-+++ configure Mon Feb 21 15:53:01 2005
-@@ -21286,6 +21286,7 @@
+--- configure.orig Thu Jan 13 02:39:28 2005
++++ configure Thu Jan 13 02:39:28 2005
+@@ -22221,6 +22221,7 @@
if eval "test \"\${$as_ac_var+set}\" = set"; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -8,7 +8,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -26646,7 +26647,7 @@
+@@ -27490,7 +27491,7 @@
cat >>confdefs.h <<_ACEOF
diff --git a/sysutils/gnome-control-center/files/patch-gnome-settings-daemon_actions_Makefile.in b/sysutils/gnome-control-center/files/patch-gnome-settings-daemon_actions_Makefile.in
new file mode 100644
index 000000000000..52a627fb20df
--- /dev/null
+++ b/sysutils/gnome-control-center/files/patch-gnome-settings-daemon_actions_Makefile.in
@@ -0,0 +1,11 @@
+--- gnome-settings-daemon/actions/Makefile.in.orig Mon Dec 20 19:19:31 2004
++++ gnome-settings-daemon/actions/Makefile.in Mon Dec 20 19:20:45 2004
+@@ -296,7 +296,7 @@
+ Datadir = $(datadir)/control-center-2.0/interfaces/
+ Data_DATA = acme.glade
+
+-pixmapsdir = $(GNOMECC_PIXMAPS_DIR)
++pixmapsdir = $(prefix)/share/icons/gnome/48x48/apps
+ pixmaps_DATA = acme-brightness.png acme-eject.png gnome-speakernotes-muted.png gnome-speakernotes.png
+
+ EXTRA_DIST = \
diff --git a/sysutils/gnome-control-center/pkg-plist b/sysutils/gnome-control-center/pkg-plist
index 423c553037a3..8787f4495677 100644
--- a/sysutils/gnome-control-center/pkg-plist
+++ b/sysutils/gnome-control-center/pkg-plist
@@ -22,39 +22,36 @@ etc/gnome-vfs-2.0/modules/font-method.conf
etc/gnome-vfs-2.0/modules/theme-method.conf
include/gnome-window-settings-2.0/gnome-window-manager.h
include/gnome-window-settings-2.0/gnome-wm-manager.h
-lib/bonobo/libthemus-theme-properties-view.so
lib/gnome-vfs-2.0/modules/libfont-method.so
lib/gnome-vfs-2.0/modules/libtheme-method.so
lib/libgnome-window-settings.a
lib/libgnome-window-settings.so
lib/libgnome-window-settings.so.1
+lib/nautilus/extensions-1.0/libnautilus-fontilus.so
+lib/nautilus/extensions-1.0/libnautilus-themus.so
lib/window-manager-settings/libmetacity.a
lib/window-manager-settings/libmetacity.so
libdata/bonobo/servers/GNOME_SettingsDaemon.server
-libdata/bonobo/servers/Themus_Properties_View.server
-libdata/bonobo/servers/fontilus.server
libdata/pkgconfig/gnome-window-settings-2.0.pc
-libexec/fontilus-context-menu
libexec/gnome-settings-daemon
-share/gnome/application-registry/fontilus.applications
-share/gnome/application-registry/themus.applications
+share/gnome/applications/accessibility-keyboard.desktop
+share/gnome/applications/at-properties.desktop
+share/gnome/applications/background.desktop
+share/gnome/applications/default-applications.desktop
+share/gnome/applications/display-properties.desktop
+share/gnome/applications/font-properties.desktop
share/gnome/applications/gnome-font-viewer.desktop
+share/gnome/applications/gnome-network-preferences.desktop
+share/gnome/applications/gnome-settings-mouse.desktop
+share/gnome/applications/gnome-settings-sound.desktop
+share/gnome/applications/gnome-ui-properties.desktop
share/gnome/applications/gnomecc.desktop
+share/gnome/applications/gtk-theme-selector.desktop
+share/gnome/applications/keybinding.desktop
+share/gnome/applications/keyboard.desktop
+share/gnome/applications/themus-theme-applier.desktop
+share/gnome/applications/window-properties.desktop
@exec update-desktop-database > /dev/null || /usr/bin/true
-share/gnome/control-center-2.0/capplets/accessibility-keyboard.desktop
-share/gnome/control-center-2.0/capplets/at-properties.desktop
-share/gnome/control-center-2.0/capplets/background.desktop
-share/gnome/control-center-2.0/capplets/default-applications.desktop
-share/gnome/control-center-2.0/capplets/display-properties.desktop
-share/gnome/control-center-2.0/capplets/font-properties.desktop
-share/gnome/control-center-2.0/capplets/gnome-network-preferences.desktop
-share/gnome/control-center-2.0/capplets/gnome-settings-mouse.desktop
-share/gnome/control-center-2.0/capplets/gnome-settings-sound.desktop
-share/gnome/control-center-2.0/capplets/gnome-ui-properties.desktop
-share/gnome/control-center-2.0/capplets/gtk-theme-selector.desktop
-share/gnome/control-center-2.0/capplets/keybinding.desktop
-share/gnome/control-center-2.0/capplets/keyboard.desktop
-share/gnome/control-center-2.0/capplets/window-properties.desktop
share/gnome/control-center-2.0/icons/display-capplet.png
share/gnome/control-center-2.0/interfaces/acme.glade
share/gnome/control-center-2.0/interfaces/apply-font.glade
@@ -69,6 +66,7 @@ share/gnome/control-center-2.0/interfaces/gnome-mouse-properties.glade
share/gnome/control-center-2.0/interfaces/gnome-network-preferences.glade
share/gnome/control-center-2.0/interfaces/gnome-ui-properties.glade
share/gnome/control-center-2.0/interfaces/gnome-window-properties.glade
+share/gnome/control-center-2.0/interfaces/modmap-dialog.glade
share/gnome/control-center-2.0/interfaces/sound-properties.glade
share/gnome/control-center-2.0/interfaces/theme-install.glade
share/gnome/control-center-2.0/interfaces/theme-properties.glade
@@ -77,8 +75,6 @@ share/gnome/control-center-2.0/pixmaps/accessibility-keyboard-mousekey.png
share/gnome/control-center-2.0/pixmaps/accessibility-keyboard-slowkey.png
share/gnome/control-center-2.0/pixmaps/accessibility-keyboard-stickykey.png
share/gnome/control-center-2.0/pixmaps/accessibility-keyboard-togglekey.png
-share/gnome/control-center-2.0/pixmaps/acme-brightness.png
-share/gnome/control-center-2.0/pixmaps/acme-eject.png
share/gnome/control-center-2.0/pixmaps/at-startup.png
share/gnome/control-center-2.0/pixmaps/at-support.png
share/gnome/control-center-2.0/pixmaps/bar-disabled.png
@@ -88,8 +84,6 @@ share/gnome/control-center-2.0/pixmaps/bar.png
share/gnome/control-center-2.0/pixmaps/double-click-maybe.png
share/gnome/control-center-2.0/pixmaps/double-click-off.png
share/gnome/control-center-2.0/pixmaps/double-click-on.png
-share/gnome/control-center-2.0/pixmaps/gnome-speakernotes-muted.png
-share/gnome/control-center-2.0/pixmaps/gnome-speakernotes.png
share/gnome/control-center-2.0/pixmaps/keyboard-bell.png
share/gnome/control-center-2.0/pixmaps/keyboard-cursor.png
share/gnome/control-center-2.0/pixmaps/keyboard-repeat.png
@@ -117,23 +111,16 @@ share/gnome/control-center-2.0/xrdb/Xaw.ad
share/gnome/cursor-fonts/cursor-large-white.pcf
share/gnome/cursor-fonts/cursor-large.pcf
share/gnome/cursor-fonts/cursor-white.pcf
-share/gnome/gnome-2.0/ui/gnomecc-ui.xml
share/gnome/idl/ConfigArchiver.idl
share/gnome/idl/GNOME_SettingsDaemon.idl
-share/gnome/mime-info/fontilus.keys
-share/gnome/mime-info/fontilus.mime
-share/gnome/mime-info/themus.keys
-share/gnome/pixmaps/control-center2.png
share/gnome/pixmaps/display-capplet.png
-share/gnome/pixmaps/gnomecc-2/active.png
-share/gnome/pixmaps/gnomecc-2/bcg_top.png
-share/gnome/pixmaps/gnomecc-2/blank.png
-share/gnome/pixmaps/gnomecc-2/title.png
-share/gnome/vfolders/Accessibility.directory
-share/gnome/vfolders/Advanced.directory
share/gnome/vfolders/font-method.directory
share/gnome/vfolders/theme-method.directory
-share/icons/gnome/48x48/apps/accessibility-directory.png
+share/icons/gnome/48x48/apps/acme-brightness.png
+share/icons/gnome/48x48/apps/acme-eject.png
+share/icons/gnome/48x48/apps/gnome-speakernotes-muted.png
+share/icons/gnome/48x48/apps/gnome-speakernotes.png
+share/icons/hicolor/48x48/apps/gnome-control-center.png
share/locale/af/LC_MESSAGES/control-center-2.0.mo
share/locale/am/LC_MESSAGES/control-center-2.0.mo
share/locale/ar/LC_MESSAGES/control-center-2.0.mo
@@ -175,6 +162,7 @@ share/locale/ml/LC_MESSAGES/control-center-2.0.mo
share/locale/mn/LC_MESSAGES/control-center-2.0.mo
share/locale/ms/LC_MESSAGES/control-center-2.0.mo
share/locale/nb/LC_MESSAGES/control-center-2.0.mo
+share/locale/ne/LC_MESSAGES/control-center-2.0.mo
share/locale/nl/LC_MESSAGES/control-center-2.0.mo
share/locale/nn/LC_MESSAGES/control-center-2.0.mo
share/locale/no/LC_MESSAGES/control-center-2.0.mo
@@ -200,17 +188,14 @@ share/locale/wa/LC_MESSAGES/control-center-2.0.mo
share/locale/zh_CN/LC_MESSAGES/control-center-2.0.mo
share/locale/zh_TW/LC_MESSAGES/control-center-2.0.mo
share/locale/zu/LC_MESSAGES/control-center-2.0.mo
-@unexec rmdir %D/share/locale/zu/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/zu 2> /dev/null || true
@unexec rmdir %D/share/locale/nso/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/nso 2> /dev/null || true
-@dirrm share/gnome/pixmaps/gnomecc-2
@dirrm share/gnome/gnome-background-properties
@dirrm share/gnome/cursor-fonts
@dirrm share/gnome/control-center-2.0/xrdb
@dirrm share/gnome/control-center-2.0/pixmaps
@dirrm share/gnome/control-center-2.0/interfaces
-@dirrm share/gnome/control-center-2.0/icons
+@unexec rmdir %D/share/gnome/control-center-2.0/icons 2> /dev/null || true
@dirrm lib/window-manager-settings
@dirrm include/gnome-window-settings-2.0
@unexec update-desktop-database > /dev/null || /usr/bin/true