aboutsummaryrefslogtreecommitdiff
path: root/sysutils/goaccess
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2010-11-19 09:44:17 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2010-11-19 09:44:17 +0000
commit9d9201dcc52b48630eae2ecec8bc20ed0761c80b (patch)
treec78c18c7281ef05aeaa41f17f0de40c220c2d570 /sysutils/goaccess
parentc682a5ab029d04f3339e9a1c935bff2b859da6e2 (diff)
downloadports-9d9201dcc52b48630eae2ecec8bc20ed0761c80b.tar.gz
ports-9d9201dcc52b48630eae2ecec8bc20ed0761c80b.zip
GoAccess is an open source real-time Apache web log analyzer and interactive
viewer that runs in a terminal and provides fast and valuable HTTP statistics for system administrators that require a visual report on the fly. WWW: http://goaccess.prosoftcorp.com/ PR: ports/152332 Submitted by: Sofian Brabez <sbrabez at gmail.com>
Notes
Notes: svn path=/head/; revision=264799
Diffstat (limited to 'sysutils/goaccess')
-rw-r--r--sysutils/goaccess/Makefile44
-rw-r--r--sysutils/goaccess/distinfo2
-rw-r--r--sysutils/goaccess/files/patch-util.c10
-rw-r--r--sysutils/goaccess/pkg-descr5
4 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/goaccess/Makefile b/sysutils/goaccess/Makefile
new file mode 100644
index 000000000000..d44efef52d93
--- /dev/null
+++ b/sysutils/goaccess/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: goaccess
+# Date created: 2010-11-17
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= goaccess
+PORTVERSION= 0.3.3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= Real-time Apache web log analyzer
+
+LIB_DEPENDS= glib-2.0:${PORTSDIR}/devel/glib20 \
+ GeoIP.5:${PORTSDIR}/net/GeoIP
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
+
+PLIST_FILES= bin/${PORTNAME}
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= ${PLIST_FILES:S,bin/,,:S,$,.1,}
+.endif
+
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${MAN1:S,^,${WRKSRC}/,} ${PREFIX}/man/man1
+.endif
+ ${INSTALL_SCRIPT} ${PORTNAME:S,^,${WRKSRC}/,} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/goaccess/distinfo b/sysutils/goaccess/distinfo
new file mode 100644
index 000000000000..0d028e420521
--- /dev/null
+++ b/sysutils/goaccess/distinfo
@@ -0,0 +1,2 @@
+SHA256 (goaccess-0.3.3.tar.gz) = da716e4127e09a0f367ff8d41bd013531b78b67779f6a7a3c636e324349c2fe2
+SIZE (goaccess-0.3.3.tar.gz) = 121955
diff --git a/sysutils/goaccess/files/patch-util.c b/sysutils/goaccess/files/patch-util.c
new file mode 100644
index 000000000000..92fd1e7aa66d
--- /dev/null
+++ b/sysutils/goaccess/files/patch-util.c
@@ -0,0 +1,10 @@
+--- ./util.c.orig 2010-11-17 11:23:54.000000000 +0100
++++ ./util.c 2010-11-17 11:24:10.000000000 +0100
+@@ -29,6 +29,7 @@
+ #include <stdlib.h>
+ #include <netdb.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <unistd.h>
+ #include <sys/stat.h>
+ #include <errno.h>
diff --git a/sysutils/goaccess/pkg-descr b/sysutils/goaccess/pkg-descr
new file mode 100644
index 000000000000..db733cacceee
--- /dev/null
+++ b/sysutils/goaccess/pkg-descr
@@ -0,0 +1,5 @@
+GoAccess is an open source real-time Apache web log analyzer and interactive
+viewer that runs in a terminal and provides fast and valuable HTTP statistics
+for system administrators that require a visual report on the fly.
+
+WWW: http://goaccess.prosoftcorp.com/