aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gotop
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-18 06:37:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-18 06:37:12 +0000
commitfbf3654f76fa5c0b53e01c55a2853c82daf9fd2c (patch)
tree587525d178bd33234d854df41561bd9906da9cae /sysutils/gotop
parent9a013f37c3542b24fe1dae6502cf57f1cad49dd8 (diff)
downloadports-fbf3654f76fa5c0b53e01c55a2853c82daf9fd2c.tar.gz
ports-fbf3654f76fa5c0b53e01c55a2853c82daf9fd2c.zip
sysutils/gotop: Unbreak by switching to USES=go
Notes
Notes: svn path=/head/; revision=501915
Diffstat (limited to 'sysutils/gotop')
-rw-r--r--sysutils/gotop/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/sysutils/gotop/Makefile b/sysutils/gotop/Makefile
index 88a1a38f04e9..55a0abaef996 100644
--- a/sysutils/gotop/Makefile
+++ b/sysutils/gotop/Makefile
@@ -8,27 +8,19 @@ MAINTAINER= yuri@FreeBSD.org
COMMENT= Terminal based graphical activity monitor inspired by gtop and vtop
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/LICENSE
-
-BROKEN= fails to extract
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= go:lang/go
-USE_GITHUB= nodefault # the main code is in GH_TUPLE
+USES= go
+USE_GITHUB= yes
GH_ACCOUNT= cjbassi
-GH_TUPLE= cjbassi:gotop:${DISTVERSIONFULL}:main/src/github.com/cjbassi/gotop \
- docopt:docopt.go:ee0de3b:docopt/src/github.com/docopt/docopt-go \
+GH_TUPLE= docopt:docopt.go:ee0de3b:docopt/src/github.com/docopt/docopt-go \
shirou:gopsutil:v2.19.01:gopsutil/src/github.com/shirou/gopsutil \
golang:sys:37707fd:sys/src/golang.org/x/sys
-GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
-
-PLIST_FILES= bin/${PORTNAME}
-do-build:
- @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME} && \
- ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install ./...
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+PLIST_FILES= bin/${PORTNAME}
.include <bsd.port.mk>