aboutsummaryrefslogtreecommitdiff
path: root/sysutils/grok/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-09-21 21:24:58 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-09-21 21:24:58 +0000
commit021a6e7a9d586a984d7fe63a4f794bd68cf77aa0 (patch)
treeb4e51f0010b7499c32b995671df83cfd11b4e9b7 /sysutils/grok/Makefile
parent3a9ac11757958216c32047a5fdc1b402a2cd73ae (diff)
downloadports-021a6e7a9d586a984d7fe63a4f794bd68cf77aa0.tar.gz
ports-021a6e7a9d586a984d7fe63a4f794bd68cf77aa0.zip
Notes
Diffstat (limited to 'sysutils/grok/Makefile')
-rw-r--r--sysutils/grok/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/sysutils/grok/Makefile b/sysutils/grok/Makefile
index 3aec805fbba2..c7055e62ca36 100644
--- a/sysutils/grok/Makefile
+++ b/sysutils/grok/Makefile
@@ -1,12 +1,12 @@
# Ports collection makefile for: grok
# Date created: 07 March 2006
-# Whom: Wesley Shields <wxs@csh.rit.edu>
+# Whom: Wesley Shields <wxs@atarininja.org>
#
# $FreeBSD$
#
PORTNAME= grok
-PORTVERSION= 20070402
+PORTVERSION= 20070915
CATEGORIES= sysutils
MASTER_SITES= http://www.semicomplete.com/files/grok/ \
http://www.atarininja.org/~wxs/distfiles/
@@ -27,17 +27,29 @@ NO_BUILD= yes
SUB_FILES= pkg-message
SUB_LIST= PERL=${PERL}
+PORTDOCS= CHANGELIST
+PORTEXAMPLES= line-to-byte-offset.conf
MAN1= grok.1
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/grok ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/grok.conf ${PREFIX}/etc/grok.conf.sample
- ${INSTALL_MAN} ${WRKSRC}/grok.1 ${PREFIX}/man/man1
+ @${INSTALL_SCRIPT} ${WRKSRC}/grok ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/grok_patfind.pl ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/grok.conf ${PREFIX}/etc/grok.conf.sample
+ @${INSTALL_MAN} ${WRKSRC}/grok.1 ${MANPREFIX}/man/man1
post-install:
@if [ ! -f ${PREFIX}/etc/grok.conf ]; then \
${CP} -p ${PREFIX}/etc/grok.conf.sample ${PREFIX}/etc/grok.conf ; \
fi
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${INSTALL} -d ${EXAMPLESDIR}/
+ @cd ${WRKSRC}/examples/ && \
+ ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}/
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>