aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gtk-imonc
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-05-11 21:11:48 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-05-11 21:11:48 +0000
commitce801f61faa880090859854a53063d1110e2acdc (patch)
treed5dd6caa3fad4ad4369e51e4a838d9b81a75ba7b /sysutils/gtk-imonc
parente1629c50f3f2375dbcd6ea6d734e817591c00639 (diff)
downloadports-ce801f61faa880090859854a53063d1110e2acdc.tar.gz
ports-ce801f61faa880090859854a53063d1110e2acdc.zip
Upgrade to 0.4.4.
PR: ports/52077 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=80696
Diffstat (limited to 'sysutils/gtk-imonc')
-rw-r--r--sysutils/gtk-imonc/Makefile10
-rw-r--r--sysutils/gtk-imonc/distinfo2
-rw-r--r--sysutils/gtk-imonc/files/patch-timer.c48
3 files changed, 5 insertions, 55 deletions
diff --git a/sysutils/gtk-imonc/Makefile b/sysutils/gtk-imonc/Makefile
index cd31e0340b5d..bab41805787c 100644
--- a/sysutils/gtk-imonc/Makefile
+++ b/sysutils/gtk-imonc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gtk-imonc
-PORTVERSION= 0.3a
+PORTVERSION= 0.4.4
CATEGORIES= sysutils
MASTER_SITES= http://userpage.fu-berlin.de/~zeank/gtk-imonc/download/
@@ -17,13 +17,11 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
ALL_TARGET= #empty
HAS_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gtk12 gnomehier
+USE_GNOME= gtk12
USE_REINPLACE= yes
USE_X_PREFIX= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|gtk-config|gtk12-config|g ; \
- s|/usr/local|${X11BASE}|g' \
- ${WRKSRC}/configure
+pre-configure:
+ @${REINPLACE_CMD} -e 's|ac_default_prefix=/usr/local|ac_default_prefix=${PREFIX}|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/sysutils/gtk-imonc/distinfo b/sysutils/gtk-imonc/distinfo
index 1216d4472ad3..9130e77b30e0 100644
--- a/sysutils/gtk-imonc/distinfo
+++ b/sysutils/gtk-imonc/distinfo
@@ -1 +1 @@
-MD5 (gtk-imonc-0.3a.tar.gz) = b4718cea4076e7af1581092ade9b61f1
+MD5 (gtk-imonc-0.4.4.tar.gz) = 4e6a6a5f5bdbba928940571d8b2d3774
diff --git a/sysutils/gtk-imonc/files/patch-timer.c b/sysutils/gtk-imonc/files/patch-timer.c
deleted file mode 100644
index 60d2cf5b24c4..000000000000
--- a/sysutils/gtk-imonc/files/patch-timer.c
+++ /dev/null
@@ -1,48 +0,0 @@
---- gtk-imonc/timer.c.orig Fri Aug 16 21:52:15 2002
-+++ gtk-imonc/timer.c Sat Oct 26 15:43:20 2002
-@@ -183,12 +183,12 @@
- row[i] = chargebuf;
- break;
- case 8: /* IBytes */
-- tmpbytes = atoll (strtok (NULL, " "));
-+ tmpbytes = atoi (strtok (NULL, " "));
- ibytes += tmpbytes;
- row[i] = get_bytes (tmpbytes, ibytebuf);
- break;
- case 9: /* OBytes */
-- tmpbytes = atoll (strtok (NULL, " "));
-+ tmpbytes = atoi (strtok (NULL, " "));
- obytes += tmpbytes;
- row[i] = get_bytes (tmpbytes, obytebuf);
- break;
-@@ -773,8 +773,8 @@
- gtk_clist_set_text (GTK_CLIST (clist), j, 2, get_answer (fd));
-
- send_command (fd, "quantity pppoe");
-- gtk_clist_set_text (GTK_CLIST (clist), j, 3, get_bytes (atoll (strtok (get_answer (fd), " ")), buf));
-- gtk_clist_set_text (GTK_CLIST (clist), j, 4, get_bytes (atoll (strtok (NULL, " ")), buf));
-+ gtk_clist_set_text (GTK_CLIST (clist), j, 3, get_bytes (atoi (strtok (get_answer (fd), " ")), buf));
-+ gtk_clist_set_text (GTK_CLIST (clist), j, 4, get_bytes (atoi (strtok (NULL, " ")), buf));
-
- send_command (fd, "online-time pppoe");
- gtk_clist_set_text (GTK_CLIST (clist), j, 5, get_answer (fd));
-@@ -814,8 +814,8 @@
-
- sprintf (buf, "quantity %i", i);
- send_command (fd, buf);
-- gtk_clist_set_text (GTK_CLIST (clist), (j+i-1), 3, get_bytes (atoll (strtok (get_answer (fd), " ")), buf));
-- gtk_clist_set_text (GTK_CLIST (clist), (j+i-1), 4, get_bytes (atoll (strtok (NULL, " ")), buf));
-+ gtk_clist_set_text (GTK_CLIST (clist), (j+i-1), 3, get_bytes (atoi (strtok (get_answer (fd), " ")), buf));
-+ gtk_clist_set_text (GTK_CLIST (clist), (j+i-1), 4, get_bytes (atoi (strtok (NULL, " ")), buf));
-
- sprintf (buf, "online-time %i", i);
- send_command (fd, buf);
-@@ -892,7 +892,7 @@
- return buf;
- }
-
-- sprintf (buf, "%lu", (ulong) bytes);
-+ sprintf (buf, "%lu", (long) bytes);
- return buf;
-
- } /* get_bytes (bytes, *buf) */