aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hcloud
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-11-01 15:36:45 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-11-01 15:36:45 +0000
commitf80066491e1f05cec97de984a7536e506d554687 (patch)
treebe6094a3644ffc6e8a677cb140f99c90741375f6 /sysutils/hcloud
parenta1a74b6e856556a0b890f46594e74f2f1cf4d712 (diff)
downloadports-f80066491e1f05cec97de984a7536e506d554687.tar.gz
ports-f80066491e1f05cec97de984a7536e506d554687.zip
New port: sysutils/hcloud
A command-line interface for interacting with Hetzner Cloud. WWW: https://github.com/hetznercloud/cli PR: 241640 Submitted by: Zsolt Udvari (uzsolt@uzsolt.hu) Approved by: tz (mentor, implicit)
Notes
Notes: svn path=/head/; revision=516232
Diffstat (limited to 'sysutils/hcloud')
-rw-r--r--sysutils/hcloud/Makefile37
-rw-r--r--sysutils/hcloud/distinfo29
-rw-r--r--sysutils/hcloud/pkg-descr3
3 files changed, 69 insertions, 0 deletions
diff --git a/sysutils/hcloud/Makefile b/sysutils/hcloud/Makefile
new file mode 100644
index 000000000000..46e54efb475b
--- /dev/null
+++ b/sysutils/hcloud/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= hcloud
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.13.0
+CATEGORIES= sysutils
+
+MAINTAINER= uzsolt@uzsolt.hu
+COMMENT= Official Hetzner Cloud command-line interface
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= hetznercloud
+GH_PROJECT= cli
+GH_TUPLE= \
+ dustin:go-humanize:bb3d318650d4:dustin_go_humanize/vendor/github.com/dustin/go-humanize \
+ fatih:structs:ebf56d35bba7:fatih_structs/vendor/github.com/fatih/structs \
+ golang:crypto:d6449816ce06:golang_crypto/vendor/golang.org/x/crypto \
+ golang:sys:3b87a42e500a:golang_sys/vendor/golang.org/x/sys \
+ gosuri:uilive:ac356e6e42cd:gosuri_uilive/vendor/github.com/gosuri/uilive \
+ gosuri:uiprogress:d0567a9d84a1:gosuri_uiprogress/vendor/github.com/gosuri/uiprogress \
+ hetznercloud:hcloud-go:v1.14.0:hetznercloud_hcloud_go/vendor/github.com/hetznercloud/hcloud-go \
+ inconshreveable:mousetrap:v1.0.0:inconshreveable_mousetrap/vendor/github.com/inconshreveable/mousetrap \
+ mattn:go-isatty:v0.0.3:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
+ pelletier:go-toml:v1.1.0:pelletier_go_toml/vendor/github.com/pelletier/go-toml \
+ spf13:cobra:615425954c3b:spf13_cobra/vendor/github.com/spf13/cobra \
+ spf13:pflag:v1.0.1:spf13_pflag/vendor/github.com/spf13/pflag \
+ thcyron:uiprogress:25e98ffb0e98:thcyron_uiprogress/vendor/github.com/thcyron/uiprogress
+
+GO_TARGET= ./cmd/hcloud
+
+PLIST_FILES= bin/hcloud
+
+.include <bsd.port.mk>
diff --git a/sysutils/hcloud/distinfo b/sysutils/hcloud/distinfo
new file mode 100644
index 000000000000..d74a806a12c8
--- /dev/null
+++ b/sysutils/hcloud/distinfo
@@ -0,0 +1,29 @@
+TIMESTAMP = 1572601164
+SHA256 (hetznercloud-cli-v1.13.0_GH0.tar.gz) = d1baa87a867091a24d8c56279306df585664296ee20743bc74a73c3a94cdc300
+SIZE (hetznercloud-cli-v1.13.0_GH0.tar.gz) = 42502
+SHA256 (dustin-go-humanize-bb3d318650d4_GH0.tar.gz) = 2528a929daba61ff84ee81b397321b022b2f1cc134068f0afac5edaeb4894894
+SIZE (dustin-go-humanize-bb3d318650d4_GH0.tar.gz) = 16387
+SHA256 (fatih-structs-ebf56d35bba7_GH0.tar.gz) = 4320aab14a390c4b58d7383b234d89caf672f92c41250560fe26d304e2d19aca
+SIZE (fatih-structs-ebf56d35bba7_GH0.tar.gz) = 14439
+SHA256 (golang-crypto-d6449816ce06_GH0.tar.gz) = 9823aa127fbec75aab6e223494b10dac39bbb721695b50481a1053342a2df090
+SIZE (golang-crypto-d6449816ce06_GH0.tar.gz) = 1456262
+SHA256 (golang-sys-3b87a42e500a_GH0.tar.gz) = f47049c9c85c138e46f38d1e1f32085afb1c1708fe87d03d8696c2559f9700d9
+SIZE (golang-sys-3b87a42e500a_GH0.tar.gz) = 802238
+SHA256 (gosuri-uilive-ac356e6e42cd_GH0.tar.gz) = e69a472c86b1baa1da1ad5288fe4344dada058146a8366b66a0c65e73ede87f1
+SIZE (gosuri-uilive-ac356e6e42cd_GH0.tar.gz) = 152167
+SHA256 (gosuri-uiprogress-d0567a9d84a1_GH0.tar.gz) = 5b303e04ff65dfef89b764e10e30cc86f1c16db4dcad04dbf753cae281aa8049
+SIZE (gosuri-uiprogress-d0567a9d84a1_GH0.tar.gz) = 1655274
+SHA256 (hetznercloud-hcloud-go-v1.14.0_GH0.tar.gz) = 3a51aabae044aa184b7c37edc10fcc4fab0e2c5715094682c8881e14188ce70c
+SIZE (hetznercloud-hcloud-go-v1.14.0_GH0.tar.gz) = 50418
+SHA256 (inconshreveable-mousetrap-v1.0.0_GH0.tar.gz) = 5edc7731c819c305623568e317aa253d342be3447def97f1fa9e10eb5ad819f6
+SIZE (inconshreveable-mousetrap-v1.0.0_GH0.tar.gz) = 2290
+SHA256 (mattn-go-isatty-v0.0.3_GH0.tar.gz) = daf68970a6506650b05bac72082865f88d582ecdb74418b95ac5621d5392b633
+SIZE (mattn-go-isatty-v0.0.3_GH0.tar.gz) = 3364
+SHA256 (pelletier-go-toml-v1.1.0_GH0.tar.gz) = 7bbfdb5c0ad8af831a43fc2474aa137e0c237258fbc3a843f9de32d3fc41f143
+SIZE (pelletier-go-toml-v1.1.0_GH0.tar.gz) = 56991
+SHA256 (spf13-cobra-615425954c3b_GH0.tar.gz) = f3636befeca5dce1f260b36c13206629fa45c3f035ceca5eacc84f20fe6888ef
+SIZE (spf13-cobra-615425954c3b_GH0.tar.gz) = 101176
+SHA256 (spf13-pflag-v1.0.1_GH0.tar.gz) = 3fd7b88585a49ffdf09d72c5320de616334064f79aca4c0152b72a0d7864733b
+SIZE (spf13-pflag-v1.0.1_GH0.tar.gz) = 43244
+SHA256 (thcyron-uiprogress-25e98ffb0e98_GH0.tar.gz) = 0d219dacb940274ff28089048d16827a48cc317c74f9e147f82a02e742be4115
+SIZE (thcyron-uiprogress-25e98ffb0e98_GH0.tar.gz) = 1655276
diff --git a/sysutils/hcloud/pkg-descr b/sysutils/hcloud/pkg-descr
new file mode 100644
index 000000000000..08d6c015740d
--- /dev/null
+++ b/sysutils/hcloud/pkg-descr
@@ -0,0 +1,3 @@
+A command-line interface for interacting with Hetzner Cloud.
+
+WWW: https://github.com/hetznercloud/cli