aboutsummaryrefslogtreecommitdiff
path: root/sysutils/heirloom
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-03-02 19:56:56 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-03-02 19:56:56 +0000
commit7c8ecf9e01fed8bed34eefaac2d78eab0d4b3799 (patch)
tree32331fcd8215029e2ab6a04afd98c22949d570bd /sysutils/heirloom
parent0c29a5eb0bb39fb2973834657143fc2d378df84e (diff)
downloadports-7c8ecf9e01fed8bed34eefaac2d78eab0d4b3799.tar.gz
ports-7c8ecf9e01fed8bed34eefaac2d78eab0d4b3799.zip
- Add patch to work on -CURRENT
Submitted by: ed@ via private e-mail
Notes
Notes: svn path=/head/; revision=229364
Diffstat (limited to 'sysutils/heirloom')
-rw-r--r--sysutils/heirloom/Makefile10
-rw-r--r--sysutils/heirloom/files/patch-stty::stty.c29
2 files changed, 31 insertions, 8 deletions
diff --git a/sysutils/heirloom/Makefile b/sysutils/heirloom/Makefile
index 5d6231778443..caf429078a02 100644
--- a/sysutils/heirloom/Makefile
+++ b/sysutils/heirloom/Makefile
@@ -7,7 +7,7 @@
PORTNAME= heirloom
PORTVERSION= 070715
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= SF
@@ -96,10 +96,4 @@ install-doc:
#. endfor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800045
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/heirloom/files/patch-stty::stty.c b/sysutils/heirloom/files/patch-stty::stty.c
new file mode 100644
index 000000000000..636eb2250fb2
--- /dev/null
+++ b/sysutils/heirloom/files/patch-stty::stty.c
@@ -0,0 +1,29 @@
+--- stty/stty.c
++++ stty/stty.c
+@@ -79,7 +79,7 @@
+ static void lcase(int);
+ #endif
+ static void ek(int);
+-#ifdef TABDLY
++#if 0
+ static void tty33(int);
+ static void tty37(int);
+ static void vt05(int);
+@@ -410,7 +410,7 @@
+ #ifdef OFDEL
+ { "fill", fill, 0, 0, 040, M_FUNCT },
+ #endif
+-#ifdef TABDLY
++#if 0
+ { "tty33", tty33, 0, 0, 040, M_FUNCT },
+ { "tty37", tty37, 0, 0, 040, M_FUNCT },
+ { "vt05", vt05, 0, 0, 040, M_FUNCT },
+@@ -1125,7 +1125,7 @@
+ ts.c_cc[VKILL] = '\25';
+ }
+
+-#ifdef TABDLY
++#if 0
+ static void
+ tty33(int not)
+ {