aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hexpeek
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-23 22:17:09 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-23 22:17:09 +0000
commit0d7c9661d9aa0590c903a348ae59b4871a98147d (patch)
treec929c759029a88377bb77715852791998a4fb790 /sysutils/hexpeek
parent4362f33ceb59d3a3a6b8a4451dd73ea814e9e70a (diff)
downloadports-0d7c9661d9aa0590c903a348ae59b4871a98147d.tar.gz
ports-0d7c9661d9aa0590c903a348ae59b4871a98147d.zip
Make test/Makefile use system CFLAGS
While here reformat the Makefile with portfmt.
Notes
Notes: svn path=/head/; revision=549858
Diffstat (limited to 'sysutils/hexpeek')
-rw-r--r--sysutils/hexpeek/Makefile14
-rw-r--r--sysutils/hexpeek/files/patch-test_Makefile22
2 files changed, 31 insertions, 5 deletions
diff --git a/sysutils/hexpeek/Makefile b/sysutils/hexpeek/Makefile
index bdfe105a210f..a4d8b35fbbb3 100644
--- a/sysutils/hexpeek/Makefile
+++ b/sysutils/hexpeek/Makefile
@@ -4,7 +4,7 @@
PORTNAME= hexpeek
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.20200804
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= https://www.hexpeek.com/releases/${DISTNAME}/
@@ -14,13 +14,17 @@ COMMENT= Hex file editor
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= tar:bzip2 libedit ncurses
+USES= libedit ncurses tar:bzip2
USE_CSTD= c99
-CFLAGS+= -Isrc -D_WITH_GETLINE -L${LOCALBASE}/lib
+CFLAGS+= -D_WITH_GETLINE -Isrc -L${LOCALBASE}/lib
-PLIST_FILES= bin/hexdiff bin/hexDump bin/hexpack bin/hexpeek bin/hexview
-PLIST_FILES+= share/man/man1/hexpeek.1.gz
+PLIST_FILES= bin/hexdiff \
+ bin/hexDump \
+ bin/hexpack \
+ bin/hexpeek \
+ bin/hexview \
+ share/man/man1/hexpeek.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/bin
diff --git a/sysutils/hexpeek/files/patch-test_Makefile b/sysutils/hexpeek/files/patch-test_Makefile
new file mode 100644
index 000000000000..a77da7a1d467
--- /dev/null
+++ b/sysutils/hexpeek/files/patch-test_Makefile
@@ -0,0 +1,22 @@
+--- test/Makefile.orig 2020-08-04 05:58:52 UTC
++++ test/Makefile
+@@ -24,11 +24,7 @@
+ # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+ # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+-SRCDIR := .
+-BINDIR := .
+-EXEC := $(BINDIR)/simplediff
+-CC ?= clang
+-CFLAGS := -O3 -Wall #-fPIC
++EXEC = simplediff
+
+ all: $(EXEC)
+ make -C base
+@@ -37,5 +33,4 @@ clear:
+ rm -f $(EXEC)
+ make -C base clear
+
+-$(BINDIR)/simplediff: $(SRCDIR)/simplediff.c
+- $(CC) $(CFLAGS) -o $@ $(SRCDIR)/simplediff.c
++$(EXEC): simplediff.c