aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hexpeek
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-23 18:55:27 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-23 18:55:27 +0000
commitfc9b6e0d8c136cce3db1b11ac327da905c4d2a5d (patch)
tree197b76b5d12b69cb0ab0ccf45435b365bbc9ff67 /sysutils/hexpeek
parente58cc2ab65d1bf804c11ebaf5c43530c6ed0e283 (diff)
downloadports-fc9b6e0d8c136cce3db1b11ac327da905c4d2a5d.tar.gz
ports-fc9b6e0d8c136cce3db1b11ac327da905c4d2a5d.zip
Improve port's Makefile:
- use LOCALBASE instead of PREFIX in reference to local library directory - install man-page to share/man/man1 instead of man/man1 - use DISTVERSIONPREFIX instead of complex DISTNAME specification Submitted by: 0mp
Notes
Notes: svn path=/head/; revision=549819
Diffstat (limited to 'sysutils/hexpeek')
-rw-r--r--sysutils/hexpeek/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/sysutils/hexpeek/Makefile b/sysutils/hexpeek/Makefile
index a8222bc534e8..428782f12907 100644
--- a/sysutils/hexpeek/Makefile
+++ b/sysutils/hexpeek/Makefile
@@ -3,9 +3,10 @@
PORTNAME= hexpeek
DISTVERSION= 1.0.20200804
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://www.hexpeek.com/releases/${DISTNAME}/
-DISTNAME= ${PORTNAME}-v${PORTVERSION}
+DISTVERSIONPREFIX= v
MAINTAINER= se@freebsd.org
COMMENT= Hex file editor
@@ -15,13 +16,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= tar:bzip2 libedit ncurses
-CFLAGS+= -Isrc -D_WITH_GETLINE -L${PREFIX}/lib
+CFLAGS+= -Isrc -D_WITH_GETLINE -L${LOCALBASE}/lib
PLIST_FILES= bin/hexdiff bin/hexDump bin/hexpack bin/hexpeek bin/hexview
-PLIST_FILES+= man/man1/hexpeek.1.gz
+PLIST_FILES+= share/man/man1/hexpeek.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/etc/hexpeek.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/etc/hexpeek.1 ${STAGEDIR}${MANPREFIX}/share/man/man1
.include <bsd.port.mk>