aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hfsexplorer
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-27 01:57:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-27 01:57:02 +0000
commit6c8ea8b9ab7f7807cd0cf7afdf01e00cc487884b (patch)
tree54058081de2d45c033667513c21a6f60195d6301 /sysutils/hfsexplorer
parent44ba19f998d1d09c7fd443ae7e8a29e2e1ae72e4 (diff)
downloadports-6c8ea8b9ab7f7807cd0cf7afdf01e00cc487884b.tar.gz
ports-6c8ea8b9ab7f7807cd0cf7afdf01e00cc487884b.zip
1: Stagify.
2: switch to options helper. Approved by: portmgr@ (blanket approval)
Notes
Notes: svn path=/head/; revision=359433
Diffstat (limited to 'sysutils/hfsexplorer')
-rw-r--r--sysutils/hfsexplorer/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/sysutils/hfsexplorer/Makefile b/sysutils/hfsexplorer/Makefile
index 00106bfe5dc6..9281a97c2d30 100644
--- a/sysutils/hfsexplorer/Makefile
+++ b/sysutils/hfsexplorer/Makefile
@@ -22,10 +22,11 @@ DESKTOP_ENTRIES="hfsexplorer" "reader Mac-formatted harddisk" \
USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6
-
+OPTIONS_DEFINE= DOCS
WRKSRC= ${WRKDIR}
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
do-configure:
@cd ${WRKSRC}/dist && ${REINPLACE_CMD} -e 's|lib/|${DATADIR}/lib/|g' \
hfsx.sh resview.sh unhfs.sh
@@ -36,19 +37,19 @@ do-build:
@cd ${WRKSRC} && ${SH} buildall.sh
do-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/dist/doc && ${COPYTREE_SHARE} html ${DOCSDIR}/
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC}/dist/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}/
.endif
post-install:
- @${MKDIR} ${DATADIR}/lib
- @${MKDIR} ${DATADIR}/res
+ @${MKDIR} ${STAGEDIR}${DATADIR}/lib
+ @${MKDIR} ${STAGEDIR}${DATADIR}/res
.for f in hfsx.sh resview.sh unhfs.sh
- @cd ${WRKSRC} && ${INSTALL_SCRIPT} dist/${f} ${PREFIX}/bin
+ @cd ${WRKSRC} && ${INSTALL_SCRIPT} dist/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
- @cd ${WRKSRC} && ${INSTALL_SCRIPT} dist/runfsb.sh ${PREFIX}/bin/${PORTNAME}
- @cd ${WRKSRC} && ${INSTALL_DATA} dist/lib/*.jar ${DATADIR}/lib
- @cd ${WRKSRC} && ${INSTALL_DATA} dist/res/icon.png ${DATADIR}/res
+ @cd ${WRKSRC} && ${INSTALL_SCRIPT} dist/runfsb.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @cd ${WRKSRC} && ${INSTALL_DATA} dist/lib/*.jar ${STAGEDIR}${DATADIR}/lib
+ @cd ${WRKSRC} && ${INSTALL_DATA} dist/res/icon.png ${STAGEDIR}${DATADIR}/res
.include <bsd.port.mk>