aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hfsutils
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-23 03:53:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-23 03:53:41 +0000
commit0cbf270d03be8ece025c7db5539e2b2f146ff23c (patch)
tree2eaee9926e35fbebebebda255035aded43b98496 /sysutils/hfsutils
parent86facf381ebe3dcef9fccfcd876428ea42648846 (diff)
downloadports-0cbf270d03be8ece025c7db5539e2b2f146ff23c.tar.gz
ports-0cbf270d03be8ece025c7db5539e2b2f146ff23c.zip
Move `emulators/hfsutils' to a more appropriate category (sysutils).
Notes
Notes: svn path=/head/; revision=318838
Diffstat (limited to 'sysutils/hfsutils')
-rw-r--r--sysutils/hfsutils/Makefile77
-rw-r--r--sysutils/hfsutils/distinfo2
-rw-r--r--sysutils/hfsutils/files/patch-ab36
-rw-r--r--sysutils/hfsutils/pkg-descr16
-rw-r--r--sysutils/hfsutils/pkg-plist15
5 files changed, 146 insertions, 0 deletions
diff --git a/sysutils/hfsutils/Makefile b/sysutils/hfsutils/Makefile
new file mode 100644
index 000000000000..6df1a64bdf88
--- /dev/null
+++ b/sysutils/hfsutils/Makefile
@@ -0,0 +1,77 @@
+# Created by: Vanilla I. Shu <vanilla@MinJe.com.TW>
+# $FreeBSD$
+
+PORTNAME= hfsutils
+PORTVERSION= 3.2.6
+PORTREVISION= 3
+CATEGORIES= emulators tk
+MASTER_SITES= ftp://ftp.mars.org/pub/hfs/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Utilities for accessing Apple's HFS volumes
+
+LICENSE= GPLv2
+
+CONFLICTS= hfs-[0-9]*
+
+GNU_CONFIGURE= yes
+ALL_TARGET= all hfsck/hfsck
+
+MAN1= hattrib.1 \
+ hcd.1 \
+ hcopy.1 \
+ hdel.1 \
+ hdir.1 \
+ hformat.1 \
+ hfsutils.1 \
+ hls.1 \
+ hmkdir.1 \
+ hmount.1 \
+ hpwd.1 \
+ hrename.1 \
+ hrmdir.1 \
+ humount.1 \
+ hvol.1
+
+OPTIONS_DEFINE= TCLTK DOCS
+TCLTK_DESC= Build tools that require Tcl/Tk support
+
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTCLTK}
+USE_TCL= 84+
+USE_TK= 84+
+
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR}
+CPPFLAGS+= -I${LOCALBASE}/include
+
+MAN1+= hfs.1 \
+ hfssh.1 \
+ xhfs.1
+
+PLIST_FILES+= bin/hfs \
+ bin/hfssh \
+ bin/xhfs
+.else
+CONFIGURE_ARGS= --without-tcl --without-tk
+.endif
+
+post-patch:
+# Unbreak against Tcl 8.6
+ @${ECHO_CMD} '#define USE_INTERP_RESULT 1' >> ${WRKSRC}/config.h.in
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hfsck/hfsck ${PREFIX}/bin
+.if ${PORT_OPTIONS:MTCLTK}
+ @${CHMOD} 755 ${PREFIX}/bin/hfs
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+. for f in BLURB CHANGES README TODO doc/*.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/hfsutils/distinfo b/sysutils/hfsutils/distinfo
new file mode 100644
index 000000000000..5d584efcafce
--- /dev/null
+++ b/sysutils/hfsutils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hfsutils-3.2.6.tar.gz) = bc9d22d6d252b920ec9cdf18e00b7655a6189b3f34f42e58d5bb152957289840
+SIZE (hfsutils-3.2.6.tar.gz) = 207697
diff --git a/sysutils/hfsutils/files/patch-ab b/sysutils/hfsutils/files/patch-ab
new file mode 100644
index 000000000000..e703993a1dad
--- /dev/null
+++ b/sysutils/hfsutils/files/patch-ab
@@ -0,0 +1,36 @@
+--- Makefile.in.orig Tue Sep 1 02:40:14 1998
++++ Makefile.in Wed Nov 4 17:32:21 1998
+@@ -64,7 +64,8 @@
+
+ CLITARGETS = hattrib hcd hcopy hdel hdir hformat hls hmkdir hmount hpwd \
+ hrename hrmdir humount hvol
+-TCLTARGETS = hfssh hfs
++TCLTARGETS = hfssh
++TCLSCRIPTS = hfs
+ TKTARGETS = xhfs
+
+ LIBHFS = libhfs/libhfs.a
+@@ -96,7 +97,7 @@
+ all :: @MAKE_TARGETS@
+
+ all_cli :: $(CLITARGETS)
+-all_tcl :: $(TCLTARGETS)
++all_tcl :: $(TCLTARGETS) $(TCLSCRIPTS)
+ all_tk :: $(TKTARGETS)
+ all_lib :: $(LIBHFS) $(LIBRSRC)
+
+@@ -129,9 +130,13 @@
+ $(BININSTALL) $$file "$(BINDEST)/."; \
+ done
+
++ for file in $(TCLSCRIPTS); do \
++ $(LIBINSTALL) $$file "$(BINDEST)/."; \
++ done
++
+ if [ -f "$(BINDEST)/hfs" ]; then \
+ sed -e '1d' "$(BINDEST)/hfs" > "$(BINDEST)/hfs.new"; \
+- $(BININSTALL) "$(BINDEST)/hfs.new" "$(BINDEST)/hfs"; \
++ $(LIBINSTALL) "$(BINDEST)/hfs.new" "$(BINDEST)/hfs"; \
+ rm -f "$(BINDEST)/hfs.new"; \
+ fi
+
diff --git a/sysutils/hfsutils/pkg-descr b/sysutils/hfsutils/pkg-descr
new file mode 100644
index 000000000000..773ec5415632
--- /dev/null
+++ b/sysutils/hfsutils/pkg-descr
@@ -0,0 +1,16 @@
+HFS is the "Hierarchical File System" used on modern Macintosh computers.
+With this package, you can read and write Macintosh-formatted media such as
+floppy disks, CD-ROMs, and SCSI hard disks on most UNIX platforms. You can
+also format raw media into an HFS volume.
+
+This package contains a number of different tools:
+
+ - Several command-line programs (hmount, hls, hcopy, et al.)
+ - Tk-based front-end for browsing and copying files through a
+ variety of transfer modes (MacBinary, BinHex, text, etc.)
+ - Tcl package and interface for scriptable access to volumes
+ - C library for low-level access to volumes
+
+Support for Apple's new Extended Format (HFS+) is currently not available.
+
+WWW: http://www.mars.org/home/rob/proj/hfs/
diff --git a/sysutils/hfsutils/pkg-plist b/sysutils/hfsutils/pkg-plist
new file mode 100644
index 000000000000..3fd0b2c7ae93
--- /dev/null
+++ b/sysutils/hfsutils/pkg-plist
@@ -0,0 +1,15 @@
+bin/hattrib
+bin/hcd
+bin/hcopy
+bin/hdel
+bin/hdir
+bin/hformat
+bin/hfsck
+bin/hls
+bin/hmkdir
+bin/hmount
+bin/hpwd
+bin/hrename
+bin/hrmdir
+bin/humount
+bin/hvol