aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hpacucli
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-23 16:33:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-23 16:33:46 +0000
commit6114d34fce79ec9ca8c5d904081ac5f55cda38f6 (patch)
tree4089b4fde25254204b2307eb26945cab19667814 /sysutils/hpacucli
parentd266ebcea1aa46210451b2c803a4fefefdd50f61 (diff)
downloadports-6114d34fce79ec9ca8c5d904081ac5f55cda38f6.tar.gz
ports-6114d34fce79ec9ca8c5d904081ac5f55cda38f6.zip
- Fix library installation
- Check OPSYS along with OSVERSION
Notes
Notes: svn path=/head/; revision=390429
Diffstat (limited to 'sysutils/hpacucli')
-rw-r--r--sysutils/hpacucli/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/sysutils/hpacucli/Makefile b/sysutils/hpacucli/Makefile
index 80be0039c9d0..5cf191cabeeb 100644
--- a/sysutils/hpacucli/Makefile
+++ b/sysutils/hpacucli/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hpacucli
PORTVERSION= 7.50
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= LOCAL/brooks
@@ -24,7 +24,7 @@ post-patch:
do-install:
@${MKDIR} ${STAGEDIR}${APP_PREFIX}
- ${CP} -a ${WRKSRC}/lib* ${STAGEDIR}${APP_PREFIX}
+ ${INSTALL_LIB} ${WRKSRC}/lib*.so ${STAGEDIR}${APP_PREFIX}
${INSTALL_PROGRAM} ${WRKSRC}/.${PORTNAME} ${STAGEDIR}${PREFIX}/libexec
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
@@ -32,7 +32,7 @@ do-install:
.if ${ARCH} == amd64
USE_LDCONFIG32= ${APP_PREFIX}
-. if ${OSVERSION} < 1000019
+. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000019
BROKEN= currently does not work on amd64 (see PR ports/128288)
. endif
.else