aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hpacucli
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-19 08:06:34 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-19 08:06:34 +0000
commitd8bf402db2485e75ac846dcf540bba539787c59a (patch)
treee96f7ee34c9a5f9037da3d152fdd3fac5eff9604 /sysutils/hpacucli
parent49c41ff9d38412891f08505f1cad3c1e6f21b85a (diff)
downloadports-d8bf402db2485e75ac846dcf540bba539787c59a.tar.gz
ports-d8bf402db2485e75ac846dcf540bba539787c59a.zip
Sanitize formatting, unmute installation commands, etc.
Notes
Notes: svn path=/head/; revision=314624
Diffstat (limited to 'sysutils/hpacucli')
-rw-r--r--sysutils/hpacucli/Makefile43
-rw-r--r--sysutils/hpacucli/pkg-descr9
2 files changed, 24 insertions, 28 deletions
diff --git a/sysutils/hpacucli/Makefile b/sysutils/hpacucli/Makefile
index 3944b775dc18..209995ae1dce 100644
--- a/sysutils/hpacucli/Makefile
+++ b/sysutils/hpacucli/Makefile
@@ -1,41 +1,42 @@
# Created by: SriSaiGanesh
# $FreeBSD$
-PORTNAME= hpacucli
-PORTVERSION= 7.50
-PORTREVISION= 3
-CATEGORIES= sysutils
-MASTER_SITES= LOCAL/brooks
+PORTNAME= hpacucli
+PORTVERSION= 7.50
+PORTREVISION= 3
+CATEGORIES= sysutils
+MASTER_SITES= LOCAL/brooks
-MAINTAINER= ports@FreeBSD.org
-COMMENT= HP ARRAY CONFIGURATION UTILITY for Smart Array RAID cards
+MAINTAINER= ports@FreeBSD.org
+COMMENT= HP configuration utility for Smart Array RAID cards
-USE_BZIP2= yes
-NO_BUILD= yes
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x \
+ c.5:${PORTSDIR}/misc/compat5x
+
+USE_BZIP2= yes
+NO_BUILD= yes
IA32_BINARY_PORT= yes
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
+APP_PREFIX= ${PREFIX}/lib/compaq/hpacucli
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/${PORTNAME}
do-install:
- @${MKDIR} -m 0755 -p ${PREFIX}/${APP_PREFIX}
- @${CP} ${WRKSRC}/lib* ${PREFIX}/${APP_PREFIX}/
- @${INSTALL_PROGRAM} ${WRKSRC}/.${PORTNAME} ${PREFIX}/libexec/
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin/
+ @${MKDIR} ${APP_PREFIX}
+ ${CP} -a ${WRKSRC}/lib* ${APP_PREFIX}
+ ${INSTALL_PROGRAM} ${WRKSRC}/.${PORTNAME} ${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
.include <bsd.port.pre.mk>
-APP_PREFIX= lib/compaq/hpacucli
.if ${ARCH} == amd64
-USE_LDCONFIG32= ${PREFIX}/${APP_PREFIX}
-.if ${OSVERSION} < 1000019
-BROKEN= currently does not work on amd64 (see ports/128288)
-.endif
+USE_LDCONFIG32= ${APP_PREFIX}
+. if ${OSVERSION} < 1000019
+BROKEN= currently does not work on amd64 (see PR ports/128288)
+. endif
.else
-USE_LDCONFIG= ${PREFIX}/${APP_PREFIX}
+USE_LDCONFIG= ${APP_PREFIX}
.endif
.include <bsd.port.post.mk>
diff --git a/sysutils/hpacucli/pkg-descr b/sysutils/hpacucli/pkg-descr
index f9e44a95647c..28de71d0a995 100644
--- a/sysutils/hpacucli/pkg-descr
+++ b/sysutils/hpacucli/pkg-descr
@@ -1,8 +1,3 @@
-HP Array Configuration Utility CLI
-
-The Array Configuration Utility CLI is a commandline-based disk
-configuration program for Smart Array Controllers and
+This port installs Linux version of HP Array Configuration Utility CLI, a
+a command-line disk configuration program for Smart Array Controllers and
RAID Array Controllers.
-
-* All other product names mentioned herein may be trademarks of their
-respective companies.