aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ipa
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-01-03 13:45:54 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-01-03 13:45:54 +0000
commit7fa62b9067945e17a8073e11b7801ef4582d765f (patch)
treef0277f31a390cc7657b6da900f2ecac792fb3047 /sysutils/ipa
parent178ff290b703a42da0b8a6345efcd5e1080e8c72 (diff)
downloadports-7fa62b9067945e17a8073e11b7801ef4582d765f.tar.gz
ports-7fa62b9067945e17a8073e11b7801ef4582d765f.zip
Fix build on sparc64
Notified by: pointyhat via kris Submitted by: Andrey Simonenko <simon@comsys.ntu-kpi.kiev.ua> (maintainer by mail)
Notes
Notes: svn path=/head/; revision=152656
Diffstat (limited to 'sysutils/ipa')
-rw-r--r--sysutils/ipa/Makefile1
-rw-r--r--sysutils/ipa/files/patch-memfunc.c46
-rw-r--r--sysutils/ipa/files/patch-parser.c11
3 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/ipa/Makefile b/sysutils/ipa/Makefile
index e2616369a7eb..d4258d15f1b4 100644
--- a/sysutils/ipa/Makefile
+++ b/sysutils/ipa/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ipa
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://ipa-system.sourceforge.net/ \
http://www.mirrors.wiretapped.net/security/network-monitoring/ipa/ \
diff --git a/sysutils/ipa/files/patch-memfunc.c b/sysutils/ipa/files/patch-memfunc.c
new file mode 100644
index 000000000000..f3e8370d8700
--- /dev/null
+++ b/sysutils/ipa/files/patch-memfunc.c
@@ -0,0 +1,46 @@
+--- src/memfunc.c.orig Sat Dec 3 11:28:00 2005
++++ src/memfunc.c Tue Jan 3 13:44:56 2006
+@@ -575,8 +575,8 @@
+ mem_type->name);
+
+ if ( (mem = malloc(size + MEM_DESC_BUF_OFFSET + sizeof(gbytes))) == NULL) {
+- logmsgx("mem_malloc(%lu + %u, %s) failed: malloc: %s",
+- (u_long)size, MEM_DESC_BUF_OFFSET, mem_type->name,
++ logmsgx("mem_malloc(%lu + %lu, %s) failed: malloc: %s",
++ (u_long)size, (u_long)MEM_DESC_BUF_OFFSET, mem_type->name,
+ strerror(errno));
+ return NULL;
+ }
+@@ -614,8 +614,8 @@
+
+ size *= number;
+ if ( (mem = malloc(size + MEM_DESC_BUF_OFFSET + sizeof(gbytes))) == NULL) {
+- logmsgx("mem_calloc(%lu + %u, %s) failed: %s",
+- (u_long)size, MEM_DESC_BUF_OFFSET, mem_type->name,
++ logmsgx("mem_calloc(%lu + %lu, %s) failed: %s",
++ (u_long)size, (u_long)MEM_DESC_BUF_OFFSET, mem_type->name,
+ strerror(errno));
+ return NULL;
+ }
+@@ -714,8 +714,8 @@
+ #ifdef WITH_MEMFUNC_DEBUG
+ /* malloc() --> memcpy() --> free() */
+ if ( (mem2 = malloc(size2 + MEM_DESC_BUF_OFFSET + sizeof(gbytes))) == NULL) {
+- logmsgx("mem_realloc(%s): malloc(%lu + %u) failed: %s",
+- mem_type->name, (u_long)size2, MEM_DESC_BUF_OFFSET,
++ logmsgx("mem_realloc(%s): malloc(%lu + %lu) failed: %s",
++ mem_type->name, (u_long)size2, (u_long)MEM_DESC_BUF_OFFSET,
+ strerror(errno));
+ return NULL;
+ }
+@@ -733,8 +733,8 @@
+ /* True realloc(). */
+ mem1->signature = MEM_NOSIGNATURE;
+ if ( (mem2 = realloc(mem1, size2 + MEM_DESC_BUF_OFFSET + sizeof(gbytes))) == NULL) {
+- logmsgx("mem_realloc(%lu + %u, %s) failed: %s",
+- (u_long)size2, MEM_DESC_BUF_OFFSET, mem_type->name,
++ logmsgx("mem_realloc(%lu + %lu, %s) failed: %s",
++ (u_long)size2, (u_long)MEM_DESC_BUF_OFFSET, mem_type->name,
+ strerror(errno));
+ mem1->signature = MEM_SIGNATURE & (int)size1;
+ return NULL;
diff --git a/sysutils/ipa/files/patch-parser.c b/sysutils/ipa/files/patch-parser.c
new file mode 100644
index 000000000000..3b8651217d6a
--- /dev/null
+++ b/sysutils/ipa/files/patch-parser.c
@@ -0,0 +1,11 @@
+--- src/parser.c.orig Sat Dec 3 11:28:00 2005
++++ src/parser.c Tue Jan 3 13:44:50 2006
+@@ -533,7 +533,7 @@
+ * outside of this function.
+ */
+ struct parser_pbuf *
+-parser_new_pbuf(u_int size)
++parser_new_pbuf(size_t size)
+ {
+ struct parser_pbuf *pbuf;
+