aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ipad_charge
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2012-01-13 06:38:24 +0000
committerKevin Lo <kevlo@FreeBSD.org>2012-01-13 06:38:24 +0000
commit061f4ff1a503bb3b733a04225a099fb04b80c65d (patch)
tree6e7f1535e90876390653618d31e1c41fa3fdb2cf /sysutils/ipad_charge
parent894214b30d876621e50980631872cd42b8f302f1 (diff)
downloadports-061f4ff1a503bb3b733a04225a099fb04b80c65d.tar.gz
ports-061f4ff1a503bb3b733a04225a099fb04b80c65d.zip
Initial import of ipad_charge-1.1
ipad_charge is an iPad USB charging control utility.
Notes
Notes: svn path=/head/; revision=289085
Diffstat (limited to 'sysutils/ipad_charge')
-rw-r--r--sysutils/ipad_charge/Makefile38
-rw-r--r--sysutils/ipad_charge/distinfo2
-rw-r--r--sysutils/ipad_charge/files/patch-ipad_charge.c11
-rw-r--r--sysutils/ipad_charge/pkg-descr3
4 files changed, 54 insertions, 0 deletions
diff --git a/sysutils/ipad_charge/Makefile b/sysutils/ipad_charge/Makefile
new file mode 100644
index 000000000000..0f09f885e519
--- /dev/null
+++ b/sysutils/ipad_charge/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ipad_charge
+# Date created: 13 January 2012
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipad_charge
+PORTVERSION= 1.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.rainbow-software.org/linux_files/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= An iPad/iPad2 USB charging utility
+
+LDFLAGS+= -lusb
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PLIST_FILES= bin/ipad_charge
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+BROKEN= does not compile
+.endif
+
+do-build:
+ ${CC} ${CFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.c \
+ -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/ipad_charge/distinfo b/sysutils/ipad_charge/distinfo
new file mode 100644
index 000000000000..d4ca64e052f5
--- /dev/null
+++ b/sysutils/ipad_charge/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ipad_charge_1.1.tar.gz) = 85b73b4deb0a0ef287bf1f34720937c99795f3e55ac1f038fef62a6fea2422c4
+SIZE (ipad_charge_1.1.tar.gz) = 9170
diff --git a/sysutils/ipad_charge/files/patch-ipad_charge.c b/sysutils/ipad_charge/files/patch-ipad_charge.c
new file mode 100644
index 000000000000..1a940cb04165
--- /dev/null
+++ b/sysutils/ipad_charge/files/patch-ipad_charge.c
@@ -0,0 +1,11 @@
+--- ipad_charge.c.orig 2011-05-11 03:59:12.000000000 +0800
++++ ipad_charge.c 2012-01-13 14:07:58.000000000 +0800
+@@ -4,7 +4,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+-#include <libusb-1.0/libusb.h>
++#include <libusb.h>
+
+ #define VERSION "1.0"
+
diff --git a/sysutils/ipad_charge/pkg-descr b/sysutils/ipad_charge/pkg-descr
new file mode 100644
index 000000000000..434db5d48470
--- /dev/null
+++ b/sysutils/ipad_charge/pkg-descr
@@ -0,0 +1,3 @@
+ipad_charge is an iPad USB charging control utility.
+
+WWW: http://www.rainbow-software.org/linux/