aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ipfs-go
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-09-09 13:12:42 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-09-09 13:12:42 +0000
commit4433042cae843daf30a55ad4e4015689b98c6852 (patch)
treec2cf168db9c7864468c4fb0f898ac5ea2080ada9 /sysutils/ipfs-go
parent66983f0a8e08ae52c19eb97daced43bf0d9f8c45 (diff)
downloadports-4433042cae843daf30a55ad4e4015689b98c6852.tar.gz
ports-4433042cae843daf30a55ad4e4015689b98c6852.zip
sysutils/ipfs-go: Unbreak with go1.13
===> Building for ipfs-go-0.4.21 go: bazil.org/fuse@v0.0.0-20180421153158-65cc252bf669: Get https://proxy.golang.org/bazil.org/fuse/@v/v0.0.0-20180421153158-65cc252bf669.mod: dial tcp: lookup proxy.golang.org on 209.222.18.218:53: write udp 127.0.0.1:14240->209.222.18.218:53: write: permission denied *** Error code 1 - Switch to USES=go:modules - Remove GO_PKGNAME, not needed with modules PR: 240318 Submitted by: Dmitri Goutnik <dg@syrec.org> Pointy hat: jlaffaye
Notes
Notes: svn path=/head/; revision=511627
Diffstat (limited to 'sysutils/ipfs-go')
-rw-r--r--sysutils/ipfs-go/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/sysutils/ipfs-go/Makefile b/sysutils/ipfs-go/Makefile
index c942c029353b..b158e96a3eef 100644
--- a/sysutils/ipfs-go/Makefile
+++ b/sysutils/ipfs-go/Makefile
@@ -16,12 +16,10 @@ LICENSE_COMB= dual
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
LICENSE_FILE_APACHE= ${WRKSRC}/LICENSE-APACHE
-BROKEN= fails to build
ONLY_FOR_ARCHS= amd64 i386
-USES= go
+USES= go:modules
-GO_PKGNAME= github.com/ipfs/go-ipfs
GO_TARGET= ./cmd/ipfs
NO_WRKSUBDIR= yes
@@ -45,6 +43,15 @@ GROUPS= ${IPFS_GROUP}
FULLNAME= ${PORTNAME}${PKGNAMESUFFIX}
+# unbreak vendored golang.org/x/xerrors with go1.13
+# can be removed after vendor/golang.org/x/xerrors is updated to a985d3407aa7 or later
+post-patch:
+ @${RM} ${WRKSRC}/vendor/golang.org/x/xerrors/adaptor_go1_13.go
+ @${RM} ${WRKSRC}/vendor/golang.org/x/xerrors/format_go1_13.go
+ @${REINPLACE_CMD} '/build !go1.13/d' ${WRKSRC}/vendor/golang.org/x/xerrors/adaptor_go1_12.go
+ @${REINPLACE_CMD} '/build !go1.13/d' ${WRKSRC}/vendor/golang.org/x/xerrors/format_go1_12.go
+ @${REINPLACE_CMD} '/build !go1.13/d' ${WRKSRC}/vendor/golang.org/x/xerrors/frame_go1_12.go
+
do-install:
@${MKDIR} ${STAGEDIR}${IPFS_HOME}
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/ipfs ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}