aboutsummaryrefslogtreecommitdiff
path: root/sysutils/isc-cron
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-23 14:45:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-23 14:45:54 +0000
commitbb392f570ab5ac5c49b523575214620d61d5fc76 (patch)
tree36d5f61ab6f76489f5bb48dcd647f9531c3127fb /sysutils/isc-cron
parent93a32e0841510b836b87e6b1ab5d32349c8a33c5 (diff)
downloadports-bb392f570ab5ac5c49b523575214620d61d5fc76.tar.gz
ports-bb392f570ab5ac5c49b523575214620d61d5fc76.zip
Notes
Diffstat (limited to 'sysutils/isc-cron')
-rw-r--r--sysutils/isc-cron/Makefile17
-rw-r--r--sysutils/isc-cron/files/patch-Makefile17
2 files changed, 23 insertions, 11 deletions
diff --git a/sysutils/isc-cron/Makefile b/sysutils/isc-cron/Makefile
index 9ebeb0eaf143..630172ab34e0 100644
--- a/sysutils/isc-cron/Makefile
+++ b/sysutils/isc-cron/Makefile
@@ -3,29 +3,32 @@
PORTNAME= isc-cron
PORTVERSION= 4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ISC/cron
DISTNAME= cron_${PORTVERSION}.shar
-EXTRACT_SUFX=
+EXTRACT_SUFX= # none
MAINTAINER= ports@FreeBSD.org
COMMENT= ISC Cron, former Vixie Cron
+LICENSE= ISCL
+
WRKSRC= ${WRKDIR}
SUB_FILES= pkg-message
-PLIST_FILES= sbin/cron bin/crontab man/man1/crontab.1.gz \
- man/man5/crontab.5.gz man/man8/cron.8.gz
-PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST_FILES= sbin/cron \
+ "@(root,wheel,4755) bin/crontab" \
+ man/man1/crontab.1.gz \
+ man/man5/crontab.5.gz \
+ man/man8/cron.8.gz
do-extract:
- ${MKDIR} ${WRKSRC}
+ @${MKDIR} ${WRKSRC}
cd ${WRKSRC} && ${SH} ${DISTDIR}/${DISTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cron ${STAGEDIR}${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/crontab ${STAGEDIR}${PREFIX}/bin
- ${CHMOD} 4555 ${STAGEDIR}${PREFIX}/bin/crontab
${INSTALL_MAN} ${WRKSRC}/crontab.1 ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/crontab.5 ${STAGEDIR}${MANPREFIX}/man/man5
${INSTALL_MAN} ${WRKSRC}/cron.8 ${STAGEDIR}${MANPREFIX}/man/man8
diff --git a/sysutils/isc-cron/files/patch-Makefile b/sysutils/isc-cron/files/patch-Makefile
index ec4bda7cbbc2..6d91a6f94878 100644
--- a/sysutils/isc-cron/files/patch-Makefile
+++ b/sysutils/isc-cron/files/patch-Makefile
@@ -1,11 +1,20 @@
---- Makefile.orig 2013-10-18 04:21:17.000000000 +1100
-+++ Makefile 2013-10-18 04:21:22.000000000 +1100
-@@ -66,7 +66,7 @@
+--- Makefile.orig 2016-11-23 12:27:46 UTC
++++ Makefile
+@@ -66,7 +66,7 @@ CDEBUG = -g
#<<lint flags of choice?>>
LINTFLAGS = -hbxa $(INCLUDE) $(DEBUGGING)
#<<want to use a nonstandard CC?>>
-CC = gcc -Wall -Wno-unused -Wno-comment
-+CC = cc -Wall -Wno-unused -Wno-comment
++CC += -Wall -Wno-unused -Wno-comment
#<<manifest defines>>
DEFS =
#(SGI IRIX systems need this)
+@@ -79,7 +79,7 @@ LDFLAGS =
+ #################################### end configurable stuff
+
+ SHELL = /bin/sh
+-CFLAGS = $(CDEBUG) $(INCLUDE) $(DEFS)
++CFLAGS += $(INCLUDE) $(DEFS)
+
+ INFOS = README CHANGES FEATURES INSTALL CONVERSION THANKS MAIL
+ MANPAGES = bitstring.3 crontab.5 crontab.1 cron.8 putman.sh