aboutsummaryrefslogtreecommitdiff
path: root/sysutils/isomaster
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-04-29 05:09:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-04-29 05:09:40 +0000
commit3f77298083af73d336b4605f4a4d10f8d2966fe9 (patch)
treed382057c238afcb085cd0468e663d3fab9284901 /sysutils/isomaster
parente68bf90ca629c896a721927d80bd0679877b7117 (diff)
downloadports-3f77298083af73d336b4605f4a4d10f8d2966fe9.tar.gz
ports-3f77298083af73d336b4605f4a4d10f8d2966fe9.zip
- Update to 1.3.11
PR: 188866 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=352571
Diffstat (limited to 'sysutils/isomaster')
-rw-r--r--sysutils/isomaster/Makefile40
-rw-r--r--sysutils/isomaster/distinfo4
-rw-r--r--sysutils/isomaster/files/patch-bk__bk.h20
-rw-r--r--sysutils/isomaster/files/patch-bk__bkCache.c27
-rw-r--r--sysutils/isomaster/files/patch-bk__bkMisc.c30
-rw-r--r--sysutils/isomaster/pkg-plist10
6 files changed, 26 insertions, 105 deletions
diff --git a/sysutils/isomaster/Makefile b/sysutils/isomaster/Makefile
index fbc081aed195..864a782379a3 100644
--- a/sysutils/isomaster/Makefile
+++ b/sysutils/isomaster/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= isomaster
-PORTVERSION= 1.3.9
+PORTVERSION= 1.3.11
CATEGORIES= sysutils
MASTER_SITES= http://littlesvr.ca/isomaster/releases/
@@ -14,39 +14,39 @@ LICENSE= GPLv2
LIB_DEPENDS= iniparser:${PORTSDIR}/devel/iniparser
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
-USE_BZIP2= yes
-USE_GNOME= intlhack gnomehier gtk20
-USES= desktop-file-utils gettext gmake pkgconfig
+USES= desktop-file-utils gettext gmake pkgconfig tar:bzip2
+USE_GNOME= gtk20
MAKE_ENV= DEFAULT_VIEWER="xdg-open" USE_SYSTEM_INIPARSER=1
CPPFLAGS+= -I${LOCALBASE}/include -Diniparser_setstr=iniparser_set
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-PLIST_SUB= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
-
-MAN1= isomaster.1
-
-NO_STAGE= yes
post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|<time.h>|<sys/time.h>|' ${WRKSRC}/bk/bkMisc.c
@${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
's|@$$(CC)|$$(CC)|'
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} isomaster ${PREFIX}/bin)
- (cd ${WRKSRC} && ${INSTALL_MAN} isomaster.1 ${MANPREFIX}/man/man1)
- @${MKDIR} ${DATADIR}/icons
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} isomaster \
+ ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} isomaster.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1)
+ @${MKDIR} ${STAGEDIR}${DATADIR}/icons
.for i in add2-kearone.png delete-kearone.png extract2-kearone.png \
folder-new-kearone.png go-back-kearone.png isomaster.png
- (cd ${WRKSRC}/icons && ${INSTALL_DATA} ${i} ${DATADIR}/icons)
+ (cd ${WRKSRC}/icons && ${INSTALL_DATA} ${i} \
+ ${STAGEDIR}${DATADIR}/icons)
.endfor
-.for i in ar be@latin bg ca cs da de el es et fi fo fr he hr hu id it ja \
- lt lv nb nl nn pl pt pt_BR ro ru sk sl sq sr sr@Latn sr@latin sv \
- tr uk ur_PK zh_CN zh_TW
- @${MKDIR} ${PREFIX}/share/locale/${i}/LC_MESSAGES
+.for i in ar be@latin bg bn_IN ca cs da de el es et fi fo fr gl he hr hu \
+ id it ja lt lv nb nl nn pl pt pt_BR ro ru sk sl sq sr sr@Latn \
+ sr@latin sv tr uk ur_PK zh_CN zh_TW
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${i}/LC_MESSAGES
(cd ${WRKSRC}/po && ${INSTALL_DATA} ${i}.mo \
- ${PREFIX}/share/locale/${i}/LC_MESSAGES/isomaster.mo)
+ ${STAGEDIR}${PREFIX}/share/locale/${i}/LC_MESSAGES/isomaster.mo)
.endfor
- @${MKDIR} ${DESKTOPDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} isomaster.desktop ${DESKTOPDIR})
+ @${MKDIR} ${STAGEDIR}${DESKTOPDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} isomaster.desktop \
+ ${STAGEDIR}${DESKTOPDIR})
.include <bsd.port.mk>
diff --git a/sysutils/isomaster/distinfo b/sysutils/isomaster/distinfo
index e473ee266ae9..50525b711da9 100644
--- a/sysutils/isomaster/distinfo
+++ b/sysutils/isomaster/distinfo
@@ -1,2 +1,2 @@
-SHA256 (isomaster-1.3.9.tar.bz2) = 2bf798a19af43113391144c4a3f2f3b33366f640c5695d356c151e83c49dc853
-SIZE (isomaster-1.3.9.tar.bz2) = 223514
+SHA256 (isomaster-1.3.11.tar.bz2) = ab8c334d6df1996fc1872affc01e82aa3917b9d3ae37300e41491b7b2666b857
+SIZE (isomaster-1.3.11.tar.bz2) = 232153
diff --git a/sysutils/isomaster/files/patch-bk__bk.h b/sysutils/isomaster/files/patch-bk__bk.h
deleted file mode 100644
index 3b2a9cc12c9a..000000000000
--- a/sysutils/isomaster/files/patch-bk__bk.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- bk/bk.h.orig
-+++ bk/bk.h
-@@ -30,7 +30,7 @@
- #include <stdlib.h>
- #include <sys/types.h>
- #include <limits.h>
--#include <sys/timeb.h>
-+#include <sys/time.h>
- #include <stdio.h>
-
- #include "bkError.h"
-@@ -186,7 +186,7 @@
- int imageForWriting;
- void(*progressFunction)(struct VolInfo*);
- void(*writeProgressFunction)(struct VolInfo*, double);
-- struct timeb lastTimeCalledProgress;
-+ struct timeval lastTimeCalledProgress;
- bk_off_t estimatedIsoSize;
- BkHardLink* fileLocations; /* list of where to find regular files */
- char readWriteBuffer[READ_WRITE_BUFFER_SIZE];
diff --git a/sysutils/isomaster/files/patch-bk__bkCache.c b/sysutils/isomaster/files/patch-bk__bkCache.c
deleted file mode 100644
index 27ebf3d37644..000000000000
--- a/sysutils/isomaster/files/patch-bk__bkCache.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- bk/bkCache.c.orig
-+++ bk/bkCache.c
-@@ -21,7 +21,7 @@
-
- #include <string.h>
- #include <stdio.h>
--#include <sys/timeb.h>
-+#include <sys/time.h>
- #include <sys/types.h>
- #include <sys/stat.h>
-
-@@ -57,11 +57,11 @@
-
- if(volInfo->writeProgressFunction != NULL)
- {
-- struct timeb timeNow;
-- ftime(&timeNow);
-+ struct timeval timeNow;
-+ gettimeofday(&timeNow, NULL);
-
-- if(timeNow.time - volInfo->lastTimeCalledProgress.time >= 1 ||
-- timeNow.millitm - volInfo->lastTimeCalledProgress.millitm >= 100)
-+ if(timeNow.tv_sec - volInfo->lastTimeCalledProgress.tv_sec >= 1 ||
-+ timeNow.tv_usec/1000 - volInfo->lastTimeCalledProgress.tv_usec/1000 >= 100)
- {
- BkStatStruct statStruct;
- double percentComplete;
diff --git a/sysutils/isomaster/files/patch-bk__bkMisc.c b/sysutils/isomaster/files/patch-bk__bkMisc.c
deleted file mode 100644
index 9df17272df23..000000000000
--- a/sysutils/isomaster/files/patch-bk__bkMisc.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- bk/bkMisc.c.orig
-+++ bk/bkMisc.c
-@@ -12,22 +12,22 @@
- *
- ******************************************************************************/
-
--#include <time.h>
-+#include <sys/time.h>
-
- #include "bkInternal.h"
- #include "bkMisc.h"
-
- void maybeUpdateProgress(VolInfo* volInfo)
- {
-- struct timeb timeNow;
-+ struct timeval timeNow;
-
- if(volInfo->progressFunction == NULL)
- return;
-
-- ftime(&timeNow);
-+ gettimeofday(&timeNow, NULL);
-
-- if(timeNow.time - volInfo->lastTimeCalledProgress.time >= 1 ||
-- timeNow.millitm - volInfo->lastTimeCalledProgress.millitm >= 100)
-+ if(timeNow.tv_sec - volInfo->lastTimeCalledProgress.tv_sec >= 1 ||
-+ timeNow.tv_usec/1000 - volInfo->lastTimeCalledProgress.tv_usec/1000 >= 100)
- {
- volInfo->progressFunction(volInfo);
-
diff --git a/sysutils/isomaster/pkg-plist b/sysutils/isomaster/pkg-plist
index c29f9fa853c3..78975514cd67 100644
--- a/sysutils/isomaster/pkg-plist
+++ b/sysutils/isomaster/pkg-plist
@@ -1,5 +1,6 @@
bin/isomaster
-%%DESKTOPDIR%%/isomaster.desktop
+man/man1/isomaster.1.gz
+share/applications/isomaster.desktop
%%DATADIR%%/icons/add2-kearone.png
%%DATADIR%%/icons/delete-kearone.png
%%DATADIR%%/icons/extract2-kearone.png
@@ -9,6 +10,7 @@ bin/isomaster
share/locale/ar/LC_MESSAGES/isomaster.mo
share/locale/be@latin/LC_MESSAGES/isomaster.mo
share/locale/bg/LC_MESSAGES/isomaster.mo
+share/locale/bn_IN/LC_MESSAGES/isomaster.mo
share/locale/ca/LC_MESSAGES/isomaster.mo
share/locale/cs/LC_MESSAGES/isomaster.mo
share/locale/da/LC_MESSAGES/isomaster.mo
@@ -19,6 +21,7 @@ share/locale/et/LC_MESSAGES/isomaster.mo
share/locale/fi/LC_MESSAGES/isomaster.mo
share/locale/fo/LC_MESSAGES/isomaster.mo
share/locale/fr/LC_MESSAGES/isomaster.mo
+share/locale/gl/LC_MESSAGES/isomaster.mo
share/locale/he/LC_MESSAGES/isomaster.mo
share/locale/hr/LC_MESSAGES/isomaster.mo
share/locale/hu/LC_MESSAGES/isomaster.mo
@@ -49,12 +52,7 @@ share/locale/zh_CN/LC_MESSAGES/isomaster.mo
share/locale/zh_TW/LC_MESSAGES/isomaster.mo
@dirrmtry share/locale/ur_PK/LC_MESSAGES
@dirrmtry share/locale/ur_PK
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/fo/LC_MESSAGES
@dirrmtry share/locale/fo
-@dirrmtry share/locale/be@latin/LC_MESSAGES
-@dirrmtry share/locale/be@latin
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%
-@dirrmtry %%DESKTOPDIR%%