aboutsummaryrefslogtreecommitdiff
path: root/sysutils/jtop
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-27 03:46:23 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-27 03:46:23 +0000
commitc9bbfe2c2f69f2d42a848ad167133c5ca52665be (patch)
treeb7a0ae0eb1a8762a7d2e0adce12aab3bdf45c698 /sysutils/jtop
parentb5dcba72319540e1a68a3c0035a96f5018fb5116 (diff)
downloadports-c9bbfe2c2f69f2d42a848ad167133c5ca52665be.tar.gz
ports-c9bbfe2c2f69f2d42a848ad167133c5ca52665be.zip
Stagify.
Approved by: portmgr@ (blanket approval)
Notes
Notes: svn path=/head/; revision=359446
Diffstat (limited to 'sysutils/jtop')
-rw-r--r--sysutils/jtop/Makefile8
-rw-r--r--sysutils/jtop/files/patch-Makefile13
2 files changed, 16 insertions, 5 deletions
diff --git a/sysutils/jtop/Makefile b/sysutils/jtop/Makefile
index f1b9d422ace5..be6f1faf3eb0 100644
--- a/sysutils/jtop/Makefile
+++ b/sysutils/jtop/Makefile
@@ -12,10 +12,8 @@ COMMENT= Wrapper to top(1) that maps pids to jails
BUILD_DEPENDS= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
RUN_DEPENDS:= ${BUILD_DEPENDS}
-MAN1= jtop.1
-MANCOMPRESSED= yes
-USES= perl5
-PLIST_FILES= bin/jtop
+USES= perl5 shebangfix
+PLIST_FILES= bin/jtop man/man1/jtop.1.gz
+SHEBANG_FILES= jtop.pl
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/sysutils/jtop/files/patch-Makefile b/sysutils/jtop/files/patch-Makefile
new file mode 100644
index 000000000000..c6ecd85390d7
--- /dev/null
+++ b/sysutils/jtop/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2014-06-27 11:43:49.474359774 +0800
++++ Makefile 2014-06-27 11:44:04.348361308 +0800
+@@ -40,8 +40,8 @@ clean:
+ ${RM} -rf ${TARGETS}
+
+ install: all
+- ${INSTALL_BIN} ${PKG} ${PFX}/bin
+- ${INSTALL_MAN} ${PKG}.${MAN_SFX}.gz ${PFX}/${MAN_DIR}
++ ${INSTALL_BIN} ${PKG} $(DESTDIR)${PFX}/bin
++ ${INSTALL_MAN} ${PKG}.${MAN_SFX}.gz $(DESTDIR)${PFX}/${MAN_DIR}
+
+ deinstall:
+ ${RM} -f ${PFX}/bin/${PKG}