aboutsummaryrefslogtreecommitdiff
path: root/sysutils/kdeadmin
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
commit1d206a3483e848f4589962473bdf169313ea740f (patch)
tree269caee3e56d61cd6318b44d85c3ff64b32d57b6 /sysutils/kdeadmin
parentfb2c030e15fb4b426c06fee701c06b7f44c272ab (diff)
downloadports-1d206a3483e848f4589962473bdf169313ea740f.tar.gz
ports-1d206a3483e848f4589962473bdf169313ea740f.zip
Upgrade KDE to 2.2.2:
* General: - Support for objprelink. - Hack for autoconf 2.13/automake 1.4. Note that we can't use the standard USE_AUTO* because they change things in work/*; KDE has its own way of doing that. - Light cleanup of extra dirs in the PLISTs provided by my mkplistpkg[1] script. - Speedups of both compile and runtime through the usage of --disable-debug and --enable-final. The latter did not work with the kdemultimedia package, unfortunately. - Patch updates. * audio/kdemultimedia2: - Patch to fix KSCD on FreeBSD[2]. It works very well now. * deskutils/kdepim: - Enable kpilot[3]. Pull in the latest pilot-link stuff. * devel/kdesdk, * devel/kdevelop: - No specific changes. * devel/qt-designer: - Make this port depend almost entirely on qt23 to make it more maintainable, so I don't have to keep hacking the patches to get them to apply. * editors/koffice, * games/kdegames, * graphics/kdegraphics: - No specific changes. * misc/kdeaddons: - SDL is required now. Cull SDL PLIST_SUB and such. - Fix breakage from hardcoding "sdl-config". * misc/kdeutils2: - Fix problem with klaptopdaemon[4] where it didn't properly display the battery time. This patch is untested, but applied. * net/kdenetwork2: - Fix DCC for KSIRC[5]. - Remove ktalkd from the build. It requires some weird thing in the configure script that I don't have time to look at. * sysutils/kdeadmin: - No specific changes. * textproc/kdoc: - Remove bogus requirement that kdoc requires Perl 5.6.0; it sure seems to operate fine with >= 5.005. But I'll let time tell. * www/quanta: - No specific changes (--disable-debug support only). * x11/kde2: - No specific changes. * x11/kdebase2: - Fix ksysguard compile by merging the files from the HEAD branch of KDE CVS that were missing at release time for FreeBSD[6]. :\ * x11/kdelibs2: - Recognize CUPS' spinoff[7]. - Add libxslt dependency since it was removed from kdelibs. - Fix libxml compile problems[8] (accomplished by upgrading). - Remove libkformula from port Makefile; this library has been spun off into koffice. - Fix mode problems with DCOP[9]. This allows you to save files properly. It also seems to be a FreeBSD specific problem. - Fix bashisms in kdeprint/imagetops script[10]. * x11-clocks/kdetoys2: - No specific changes. * x11-toolkits/qt23: - Do NOT upgrade to QT 2.3.2[11]. - Allow devel/qt-designer to depend on this port entirely for the patches by adding a perlre to accomplish this. * x11-wm/kdeartwork: - No specific changes. Thanks to the FreeBSD/KDE[1] team[12] who helped me test these out! [1] http://freebsd.kde.org/; http://www.databits.net/cgi-bin/cvsweb.cgi/scripts/portbuild/mkplistpkg [2] Submitted by: Matthew Holmes <matt@speakeasy.net> [3] PR: 31914 Submitted by: Alan Eldridge <alane@geeksrus.net> [4] PR: 28475 Submitted by: Arun Sharma <arun@sharmas.dhs.org> [5] Submitted by: Luc Morin <luc_m@videotron.ca> [6] Found at: http://webcvs.kde.org/kdebase/ksysguard/ksysguardd/FreeBSD/ [7] PR: 32321 Reported by: gad Submitted by: James A. Halstead <jah4007@cs.rit.edu> [8] PR: 32055 Reported by: William Richard <wrichard@trivalley.com>, others [9] PR: 31629 Submitted by: Alan Eldridge <alane@geeksrus.net> [10] PR: 32358 Submitted by: Alexander N. Kabaev <ak03@gte.com> [11] PR: 31809 Requested by: Nathan Ahlstrom <nrahlstr@winternet.com> (denied) [12] http://freebsd.kde.org/contact.shtml; http://lists.csociety.org/pipermail/kde-freebsd; http://lists.csociety.org/listinfo/kde-freebsd
Notes
Notes: svn path=/head/; revision=51005
Diffstat (limited to 'sysutils/kdeadmin')
-rw-r--r--sysutils/kdeadmin/Makefile22
-rw-r--r--sysutils/kdeadmin/distinfo2
-rw-r--r--sysutils/kdeadmin/pkg-plist4
3 files changed, 23 insertions, 5 deletions
diff --git a/sysutils/kdeadmin/Makefile b/sysutils/kdeadmin/Makefile
index 46501eeaad4e..98b2edb3d56f 100644
--- a/sysutils/kdeadmin/Makefile
+++ b/sysutils/kdeadmin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeadmin
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES= sysutils kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,13 +14,33 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+
USE_KDELIBS_VER=2
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s@DO_NOT_COMPILE qt@DO_NOT_COMPILE kuser qt@g" ${WRKSRC}/configure
find ${WRKSRC}/kpackage -name "*.cpp" -or -name "*.c" -or -name "*.h" \
| xargs ${PERL} -pi -e "s#typedef __off64_t off64_t;##g"
diff --git a/sysutils/kdeadmin/distinfo b/sysutils/kdeadmin/distinfo
index f4e6a311c053..a4523451c489 100644
--- a/sysutils/kdeadmin/distinfo
+++ b/sysutils/kdeadmin/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdeadmin-2.2.1.tar.bz2) = 8ad5e9b7bdca7b294b42f61359f70020
+MD5 (KDE/kdeadmin-2.2.2.tar.bz2) = 5f97fe83d9a2efe3bfb679a679693a45
diff --git a/sysutils/kdeadmin/pkg-plist b/sysutils/kdeadmin/pkg-plist
index 0fafa91e4c89..f8499b354419 100644
--- a/sysutils/kdeadmin/pkg-plist
+++ b/sysutils/kdeadmin/pkg-plist
@@ -63,17 +63,15 @@ share/icons/hicolor/32x32/apps/kcron.png
share/icons/hicolor/32x32/apps/kpackage.png
share/icons/hicolor/48x48/apps/kpackage.png
share/mimelnk/application/x-debian-package.desktop
-@dirrm share/mimelnk/application
@dirrm share/icons/hicolor/48x48/apps
@dirrm share/icons/hicolor/32x32/apps
-@dirrm share/icons/hicolor/16x16/apps
@dirrm share/doc/HTML/en/kwuftpd
@dirrm share/doc/HTML/en/kuser
@dirrm share/doc/HTML/en/ksysv
@dirrm share/doc/HTML/en/kpackage
@dirrm share/doc/HTML/en/kcron
-@dirrm share/doc/HTML/en
@dirrm share/apps/kpackage/toolbar
@dirrm share/apps/kpackage/pics
@dirrm share/apps/kpackage
@dirrm share/applnk/System
+@dirrm share/applnk