aboutsummaryrefslogtreecommitdiff
path: root/sysutils/kdeadmin
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-01-11 06:17:04 +0000
committerWill Andrews <will@FreeBSD.org>2002-01-11 06:17:04 +0000
commitbda8e9b3d49318473fad79469eabd56286ac2396 (patch)
tree3e1572e95d90613e6ab697273311a81aae4badcb /sysutils/kdeadmin
parent5e3850ca618efeebd500ce6b65354eafb867c4db (diff)
downloadports-bda8e9b3d49318473fad79469eabd56286ac2396.tar.gz
ports-bda8e9b3d49318473fad79469eabd56286ac2396.zip
Bring in a few changes to the KDE ports infrastructure, and some fixes.
- Move all stuff specific to kde core ports to x11/kde2/Makefile.kde. + Default to compile optimized for speed, not debugging, in ports builds, not just packages. We don't really get that many backtraces or debugging information, and there's a better way to provide these things to people willing to spend some time working on KDE. It's at (as announced before): http://freebsd.kde.org/. - Remove teTeX dependency for kdegraphics2 upon request, and being unable to find any reason not to. Apparently, kdegraphics still compiles libkdvi and kdvi -- I guess dvips is merely a runtime dependency. Therefore to enable its use one just needs to add the teTeX package. Bump PORTREVISION to reflect dependency change. - Fix koffice port by removing PYTHON_VERSION, which is unnecessary. PR: 33650 (part of) Submitted by: John Merryweather Cooper <jmcoopr@johncoop.MSHOME.bmi.net> Reviewed by: kde-freebsd@lists.csociety.org (teTeX dep removal, and optimizing for speed, not debugging capability)
Notes
Notes: svn path=/head/; revision=52903
Diffstat (limited to 'sysutils/kdeadmin')
-rw-r--r--sysutils/kdeadmin/Makefile18
1 files changed, 2 insertions, 16 deletions
diff --git a/sysutils/kdeadmin/Makefile b/sysutils/kdeadmin/Makefile
index e86ea502b1c2..cf8832c0e7d3 100644
--- a/sysutils/kdeadmin/Makefile
+++ b/sysutils/kdeadmin/Makefile
@@ -16,28 +16,14 @@ MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
USE_KDELIBS_VER=2
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS?=
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
+
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
pre-configure:
${MKDIR} ${WRKSRC}/auto-bin