aboutsummaryrefslogtreecommitdiff
path: root/sysutils/kio-fuse
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-01-12 10:21:41 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-01-12 10:21:41 +0000
commitf7b19cd78a4b7f2352bbf63f6a7de5ff82ba038b (patch)
treee7f82d13e6c65b402d6196917821165e5a61cf3c /sysutils/kio-fuse
parent7cf8523cdb5cccd4fb3fc2e5f7613ca7b192670e (diff)
downloadports-f7b19cd78a4b7f2352bbf63f6a7de5ff82ba038b.tar.gz
ports-f7b19cd78a4b7f2352bbf63f6a7de5ff82ba038b.zip
[New port] sysutils/kio-fuse: FUSE Interface for KIO
KioFuse allows you to mount remote directories into the root hierarchy of your local file system, thereby exposing KDE's advanced access capabilities (SSH, SAMBA/Windows, FTP, TAR/GZip/BZip2, WebDav, etc) to POSIX-compliant applications such as Firefox, OpenOffice, GNOME apps, shell utilities and more. KioFuse works by acting as a bridge between KDE's KIO filesystem design and FUSE. WWW: https://github.com/KDE/kio-fuse
Notes
Notes: svn path=/head/; revision=522775
Diffstat (limited to 'sysutils/kio-fuse')
-rw-r--r--sysutils/kio-fuse/Makefile26
-rw-r--r--sysutils/kio-fuse/distinfo3
-rw-r--r--sysutils/kio-fuse/files/patch-CMakeLists.txt13
-rw-r--r--sysutils/kio-fuse/pkg-descr9
4 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/kio-fuse/Makefile b/sysutils/kio-fuse/Makefile
new file mode 100644
index 000000000000..d508417b8e04
--- /dev/null
+++ b/sysutils/kio-fuse/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= kio-fuse
+DISTVERSIONPREFIX= v
+DISTVERSION= 4.90.0
+CATEGORIES= sysutils kde
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= FUSE Interface for KIO
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfuse3.so:sysutils/fusefs-libs3
+
+USES= cmake kde:5 pkgconfig qt:5
+USE_KDE= config coreaddons kio service
+USE_QT= concurrent core dbus network \
+ buildtools_build qmake_build
+USE_GITHUB= yes
+GH_ACCOUNT= kde
+
+PLIST_FILES= lib/libexec/kio-fuse \
+ share/dbus-1/services/org.kde.KIOFuse.service
+
+.include <bsd.port.mk>
diff --git a/sysutils/kio-fuse/distinfo b/sysutils/kio-fuse/distinfo
new file mode 100644
index 000000000000..2680047ddedf
--- /dev/null
+++ b/sysutils/kio-fuse/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578817979
+SHA256 (kde-kio-fuse-v4.90.0_GH0.tar.gz) = c384af233a7d7c78849973ad1d552cd78fbd64f275506ca156d042d1633c3403
+SIZE (kde-kio-fuse-v4.90.0_GH0.tar.gz) = 44446
diff --git a/sysutils/kio-fuse/files/patch-CMakeLists.txt b/sysutils/kio-fuse/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..b9e7a3f7cab6
--- /dev/null
+++ b/sysutils/kio-fuse/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2020-01-12 09:41:08 UTC
++++ CMakeLists.txt
+@@ -58,7 +58,9 @@ target_compile_definitions(kio-fuse PRIVATE FUSE_USE_V
+ target_link_options(kio-fuse PRIVATE ${FUSE3_LDFLAGS})
+ target_link_libraries(kio-fuse PRIVATE Qt5::Core KF5::KIOCore ${FUSE3_LIBRARIES})
+ install(TARGETS kio-fuse DESTINATION ${KDE_INSTALL_FULL_LIBEXECDIR})
+-install(FILES kio-fuse-tmpfiles.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/tmpfiles.d)
++if(LINUX)
++ install(FILES kio-fuse-tmpfiles.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/tmpfiles.d)
++endif()
+ kdbusaddons_generate_dbus_service_file(kio-fuse org.kde.KIOFuse ${KDE_INSTALL_FULL_LIBEXECDIR})
+
+ feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
diff --git a/sysutils/kio-fuse/pkg-descr b/sysutils/kio-fuse/pkg-descr
new file mode 100644
index 000000000000..e902b1776480
--- /dev/null
+++ b/sysutils/kio-fuse/pkg-descr
@@ -0,0 +1,9 @@
+KioFuse allows you to mount remote directories into the root hierarchy of your
+local file system, thereby exposing KDE's advanced access capabilities (SSH,
+SAMBA/Windows, FTP, TAR/GZip/BZip2, WebDav, etc) to POSIX-compliant
+applications such as Firefox, OpenOffice, GNOME apps, shell utilities and more.
+
+KioFuse works by acting as a bridge between KDE's KIO filesystem design and
+FUSE.
+
+WWW: https://github.com/KDE/kio-fuse