aboutsummaryrefslogtreecommitdiff
path: root/sysutils/kops
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-08-02 21:54:55 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-08-02 21:54:55 +0000
commitb1eef327f214b073aefbe8d69dc42ec5d835329f (patch)
tree356dd521ac494b21750033a83c52af4f2458e5c7 /sysutils/kops
parent2705294776ae24f5546605979e884f0542318067 (diff)
downloadports-b1eef327f214b073aefbe8d69dc42ec5d835329f.tar.gz
ports-b1eef327f214b073aefbe8d69dc42ec5d835329f.zip
- New port: sysutils/kops
kops helps you create, destroy, upgrade and maintain production-grade, highly available, Kubernetes clusters from the command line. AWS (Amazon Web Services) is currently officially supported, with GCE in beta support , and VMware vSphere in alpha, and other platforms planned.
Notes
Notes: svn path=/head/; revision=476251
Diffstat (limited to 'sysutils/kops')
-rw-r--r--sysutils/kops/Makefile35
-rw-r--r--sysutils/kops/distinfo3
-rw-r--r--sysutils/kops/pkg-descr6
3 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/kops/Makefile b/sysutils/kops/Makefile
new file mode 100644
index 000000000000..7e950642f15e
--- /dev/null
+++ b/sysutils/kops/Makefile
@@ -0,0 +1,35 @@
+# Created by: Danilo Egea Gondolfo <danilo@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= kops
+PORTVERSION= 1.9.2
+CATEGORIES= sysutils
+
+MAINTAINER= danilo@FreeBSD.org
+COMMENT= Kubernetes Operations
+
+LICENSE= APACHE20
+
+USES= gmake go
+
+USE_GITHUB= yes
+GH_ACCOUNT= kubernetes
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ ${MKDIR} ${WRKDIR}/src/k8s.io/
+ ${LN} -s ${WRKSRC} ${WRKDIR}/src/k8s.io/${PORTNAME}
+ ${REINPLACE_CMD} -e 's/^GITSHA/#GITSHA/' -e 's/sha1sum/sha1/' \
+ ${WRKSRC}/Makefile
+
+do-build:
+ cd ${WRKSRC} && \
+ GOPATH=${WRKDIR} ${GMAKE}
+
+do-install:
+ ${INSTALL_PROGRAM} \
+ ${WRKDIR}/bin/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/kops/distinfo b/sysutils/kops/distinfo
new file mode 100644
index 000000000000..cf248f050ef4
--- /dev/null
+++ b/sysutils/kops/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533235748
+SHA256 (kubernetes-kops-1.9.2_GH0.tar.gz) = 39cdf50f6bb12ff3e4b6b1798298a22a337bc86dc04ff36cb6afedd9aed61d8f
+SIZE (kubernetes-kops-1.9.2_GH0.tar.gz) = 15610965
diff --git a/sysutils/kops/pkg-descr b/sysutils/kops/pkg-descr
new file mode 100644
index 000000000000..40a727d1785c
--- /dev/null
+++ b/sysutils/kops/pkg-descr
@@ -0,0 +1,6 @@
+kops helps you create, destroy, upgrade and maintain production-grade,
+highly available, Kubernetes clusters from the command line.
+AWS (Amazon Web Services) is currently officially supported, with GCE
+in beta support , and VMware vSphere in alpha, and other platforms planned.
+
+WWW: https://github.com/kubernetes/kops