aboutsummaryrefslogtreecommitdiff
path: root/sysutils/krename
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-07-18 23:31:17 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-07-18 23:31:17 +0000
commit30d7ae8b37412d4f6f4ea6ed3c0d3a6f0523b053 (patch)
treecdf5d58672fafd10517edf35e2e150ff8d7dbfd5 /sysutils/krename
parent9eb83d06fec2448b30dae1f679406cf78e4455e3 (diff)
downloadports-30d7ae8b37412d4f6f4ea6ed3c0d3a6f0523b053.tar.gz
ports-30d7ae8b37412d4f6f4ea6ed3c0d3a6f0523b053.zip
Fix up previous fix:
- with KF5 5.71, each application can have its own FindTaglib, or uses the one from kdelibs4support (I think). This is generally an "old-style" CMake module. - with KF5 5.72, ECM delivers a modern CMake module which is found **first**, but is also incompatible with the old version of FindTaglib. Adjust the patches so they work with KF5 5.71 (now in-tree) and 5.72 (upcoming). Not bumping PORTREVISION here because the packages could not have built with the previous patches. Note to self: do not assume useful backwards-compatibility in CMake modules from different sources. PR: 247907
Notes
Notes: svn path=/head/; revision=542537
Diffstat (limited to 'sysutils/krename')
-rw-r--r--sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch8
1 files changed, 5 insertions, 3 deletions
diff --git a/sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch b/sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch
index 79cba92754b9..5ee9748de534 100644
--- a/sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch
+++ b/sysutils/krename/files/patch-gentoo_git-krename-5.0.0-exiv2-0.27.patch
@@ -135,12 +135,15 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
--- src/CMakeLists.txt
+++ src/CMakeLists.txt
-@@ -23,7 +23,7 @@ if(FREETYPE_FOUND)
+@@ -23,7 +23,10 @@ if(FREETYPE_FOUND)
include_directories(${FREETYPE_INCLUDE_DIRS})
endif()
-add_definitions(${TAGLIB_CFLAGS} ${EXIV2_CFLAGS})
+add_definitions(${TAGLIB_CFLAGS})
++if(NOT TAGLIB_LIBRARIES)
++ set(TAGLIB_LIBRARIES Taglib::Taglib)
++endif()
# Exiv2 needs exceptions
kde_enable_exceptions()
@@ -157,8 +160,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
)
if(TAGLIB_FOUND)
target_link_libraries(krename
-- ${TAGLIB_LIBRARIES}
-+ Taglib::Taglib
+ ${TAGLIB_LIBRARIES}
)
endif()
-if(EXIV2_FOUND)