aboutsummaryrefslogtreecommitdiff
path: root/sysutils/kshutdown
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2006-01-09 20:23:21 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2006-01-09 20:23:21 +0000
commit7ee5501f48ea06572af1489c96875d9e02275880 (patch)
tree1b7926893b22baf261f43efa814e0fba4afb966e /sysutils/kshutdown
parent15182902298c37aa15c2c23a82ad576a4deab576 (diff)
downloadports-7ee5501f48ea06572af1489c96875d9e02275880.tar.gz
ports-7ee5501f48ea06572af1489c96875d9e02275880.zip
Add kshutdown 0.8.1, an advanced shutdown utility for KDE.
Features: o Turn Off Computer (logout and halt the system) o Restart Computer (logout and reboot the system) o Lock Screen (lock the screen using a screen saver) o End Current Session (end the current KDE session and logout the user) o Extras (additional, external user commands) o Time and delay options o Command line and DCOP support o System tray icon and panel applet o Visual and sound notifications o KDE Kiosk support WWW: http://kshutdown.sourceforge.net/
Notes
Notes: svn path=/head/; revision=153156
Diffstat (limited to 'sysutils/kshutdown')
-rw-r--r--sysutils/kshutdown/Makefile27
-rw-r--r--sysutils/kshutdown/distinfo3
-rw-r--r--sysutils/kshutdown/files/patch-appobserver.h11
-rw-r--r--sysutils/kshutdown/files/patch-configuration.cpp14
-rw-r--r--sysutils/kshutdown/files/patch-mtipp.cpp11
-rw-r--r--sysutils/kshutdown/pkg-descr15
-rw-r--r--sysutils/kshutdown/pkg-plist70
7 files changed, 151 insertions, 0 deletions
diff --git a/sysutils/kshutdown/Makefile b/sysutils/kshutdown/Makefile
new file mode 100644
index 000000000000..624f929a2266
--- /dev/null
+++ b/sysutils/kshutdown/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: kshutdown
+# Date created: Mon Jan 9 18:06:42 CET 2006
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= kshutdown
+PORTVERSION= 0.8.1
+CATEGORIES= sysutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= Advanced shutdown utility for KDE
+
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/sysutils/kshutdown/distinfo b/sysutils/kshutdown/distinfo
new file mode 100644
index 000000000000..729f1f37bac7
--- /dev/null
+++ b/sysutils/kshutdown/distinfo
@@ -0,0 +1,3 @@
+MD5 (kshutdown-0.8.1.tar.bz2) = b9b0425b279c400623c4152c4b9492a2
+SHA256 (kshutdown-0.8.1.tar.bz2) = ded50ecc2ae60c7e43d3c4f2d929c8f31c218c08fd3906527b6c03ef965880f7
+SIZE (kshutdown-0.8.1.tar.bz2) = 634172
diff --git a/sysutils/kshutdown/files/patch-appobserver.h b/sysutils/kshutdown/files/patch-appobserver.h
new file mode 100644
index 000000000000..4ba5362e6806
--- /dev/null
+++ b/sysutils/kshutdown/files/patch-appobserver.h
@@ -0,0 +1,11 @@
+--- kshutdown/appobserver.h.orig Mon Jan 9 18:30:18 2006
++++ kshutdown/appobserver.h Mon Jan 9 18:30:35 2006
+@@ -20,6 +20,8 @@
+ #ifndef __APPOBSERVER_H__
+ #define __APPOBSERVER_H__
+
++#include <sys/types.h>
++
+ #include <qhbox.h>
+
+ class QComboBox;
diff --git a/sysutils/kshutdown/files/patch-configuration.cpp b/sysutils/kshutdown/files/patch-configuration.cpp
new file mode 100644
index 000000000000..f1d918219ddf
--- /dev/null
+++ b/sysutils/kshutdown/files/patch-configuration.cpp
@@ -0,0 +1,14 @@
+--- kshutdown/configuration.cpp.orig Mon Jan 9 18:40:46 2006
++++ kshutdown/configuration.cpp Mon Jan 9 19:01:22 2006
+@@ -31,7 +31,11 @@
+ // automation
+ setCurrentGroup("Automation");
+ i_cdTrayClose = addItemBool("cd_tray_close", cdTrayClose, false, "CDTrayClose");
++#ifdef Q_OS_FREEBSD
++ i_cdTrayCloseCommand = addItemString("cd_tray_close_command", cdTrayCloseCommand, "cdcontrol close", "CDTrayCloseCommand");
++#else
+ i_cdTrayCloseCommand = addItemString("cd_tray_close_command", cdTrayCloseCommand, "eject -t", "CDTrayCloseCommand");
++#endif
+
+ // custom message
+ setCurrentGroup("Custom Message");
diff --git a/sysutils/kshutdown/files/patch-mtipp.cpp b/sysutils/kshutdown/files/patch-mtipp.cpp
new file mode 100644
index 000000000000..584a8027356f
--- /dev/null
+++ b/sysutils/kshutdown/files/patch-mtipp.cpp
@@ -0,0 +1,11 @@
+--- kshutdown/mtip.cpp.orig Mon Jan 9 18:34:50 2006
++++ kshutdown/mtip.cpp Mon Jan 9 18:35:25 2006
+@@ -41,7 +41,7 @@
+ {
+ // valign and "center" ?
+ QString leftCell = "<td align=\"center\" valign=\"center\">";
+- leftCell += _iconPath.isEmpty() ? "&nbsp;" : ("<img src=\"" + _iconPath + "\">");
++ leftCell += _iconPath.isEmpty() ? QString::fromLatin1("&nbsp;") : ("<img src=\"" + _iconPath + "\">");
+ leftCell += "</td>";
+ setText(
+ "<qt>" \
diff --git a/sysutils/kshutdown/pkg-descr b/sysutils/kshutdown/pkg-descr
new file mode 100644
index 000000000000..f39fd09d2984
--- /dev/null
+++ b/sysutils/kshutdown/pkg-descr
@@ -0,0 +1,15 @@
+KShutDown is an advanced shutdown utility for KDE.
+
+Features:
+ o Turn Off Computer (logout and halt the system)
+ o Restart Computer (logout and reboot the system)
+ o Lock Screen (lock the screen using a screen saver)
+ o End Current Session (end the current KDE session and logout the user)
+ o Extras (additional, external user commands)
+ o Time and delay options
+ o Command line and DCOP support
+ o System tray icon and panel applet
+ o Visual and sound notifications
+ o KDE Kiosk support
+
+WWW: http://kshutdown.sourceforge.net/
diff --git a/sysutils/kshutdown/pkg-plist b/sysutils/kshutdown/pkg-plist
new file mode 100644
index 000000000000..b3f68034ba36
--- /dev/null
+++ b/sysutils/kshutdown/pkg-plist
@@ -0,0 +1,70 @@
+bin/kshutdown
+lib/kde3/kshutdownlockout_panelapplet.la
+lib/kde3/kshutdownlockout_panelapplet.so
+share/applications/kshutdown.desktop
+share/apps/kconf_update/kshutdown.upd
+share/apps/kicker/applets/kshutdownlockout.desktop
+share/apps/kshutdown/eventsrc
+share/apps/kshutdown/extras/multimedia/.directory
+share/apps/kshutdown/extras/multimedia/amarok.desktop
+share/apps/kshutdown/extras/multimedia/juk.desktop
+share/apps/kshutdown/extras/multimedia/kaffeine.desktop
+share/apps/kshutdown/extras/multimedia/kscd.desktop
+share/apps/kshutdown/extras/multimedia/noatun.desktop
+share/apps/kshutdown/extras/multimedia/xmms.desktop
+share/apps/kshutdown/extras/shutdown/.directory
+share/apps/kshutdown/extras/shutdown/cancelshutdown.desktop
+share/apps/kshutdown/extras/shutdown/fsck.desktop
+share/apps/kshutdown/extras/system/.directory
+share/apps/kshutdown/extras/system/adsl-stop.desktop
+share/apps/kshutdown/extras/system/kdeeject.desktop
+share/apps/kshutdown/extras/system/kppp.desktop
+share/apps/kshutdown/karamba/kshutdown-48x48.png
+share/apps/kshutdown/karamba/kshutdown-classic-notext.theme
+share/apps/kshutdown/karamba/kshutdown-classic-text.theme
+share/apps/kshutdown/sounds/1m.ogg
+share/apps/kshutdown/sounds/5m.ogg
+share/apps/kshutdown/sounds/COPYRIGHT
+share/apps/kshutdown/sounds/one.ogg
+share/apps/kshutdown/sounds/three.ogg
+share/apps/kshutdown/sounds/two.ogg
+share/doc/HTML/de/kshutdown/common
+share/doc/HTML/de/kshutdown/index.cache.bz2
+share/doc/HTML/de/kshutdown/index.docbook
+share/doc/HTML/de/kshutdown/mainwindow.png
+share/doc/HTML/en/kshutdown/common
+share/doc/HTML/en/kshutdown/index.cache.bz2
+share/doc/HTML/en/kshutdown/index.docbook
+share/doc/HTML/en/kshutdown/mainwindow.png
+share/icons/hicolor/32x32/apps/kshutdown.png
+share/icons/hicolor/48x48/apps/kshutdown.png
+share/locale/cs/LC_MESSAGES/kshutdown.mo
+share/locale/de/LC_MESSAGES/kshutdown.mo
+share/locale/es/LC_MESSAGES/kshutdown.mo
+share/locale/hu/LC_MESSAGES/kshutdown.mo
+share/locale/it/LC_MESSAGES/kshutdown.mo
+share/locale/nl/LC_MESSAGES/kshutdown.mo
+share/locale/pl/LC_MESSAGES/kshutdown.mo
+share/locale/pt_BR/LC_MESSAGES/kshutdown.mo
+share/locale/ru/LC_MESSAGES/kshutdown.mo
+share/locale/sk/LC_MESSAGES/kshutdown.mo
+share/locale/sv/LC_MESSAGES/kshutdown.mo
+share/locale/zh_CN/LC_MESSAGES/kshutdown.mo
+@unexec rmdir %D/share/locale/zh_CN/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/zh_CN 2>/dev/null || true
+@unexec rmdir %D/share/locale/sk/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/sk 2>/dev/null || true
+@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/pl 2>/dev/null || true
+@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/cs 2>/dev/null || true
+@dirrm share/doc/HTML/en/kshutdown
+@dirrm share/doc/HTML/de/kshutdown
+@dirrm share/apps/kshutdown/sounds
+@dirrm share/apps/kshutdown/karamba
+@dirrm share/apps/kshutdown/extras/system
+@dirrm share/apps/kshutdown/extras/shutdown
+@dirrm share/apps/kshutdown/extras/multimedia
+@dirrm share/apps/kshutdown/extras
+@dirrm share/apps/kshutdown
+@unexec rmdir %D/share/apps/kconf_update 2>/dev/null || true