aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ldapvi
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-28 14:34:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-28 14:34:08 +0000
commit0e9052fb9205e620a09313298061aca8ed8c66ce (patch)
treefc6fa6b05f5614d0495ce7e6f437d63d264a8d3a /sysutils/ldapvi
parentf15da50639e00c7c8a5bffd2f3ed4e69c2cb70ad (diff)
downloadports-0e9052fb9205e620a09313298061aca8ed8c66ce.tar.gz
ports-0e9052fb9205e620a09313298061aca8ed8c66ce.zip
- Stagify, contract MASTER_SITES, drop an article from COMMENT, drop
LICENSE_FILE for GPLv2 - Modernize LIB_DEPENDS syntax, convert USE_GMAKE, clean up Makefile and port description text while here
Notes
Notes: svn path=/head/; revision=341580
Diffstat (limited to 'sysutils/ldapvi')
-rw-r--r--sysutils/ldapvi/Makefile18
-rw-r--r--sysutils/ldapvi/files/patch-GNUmakefile.in14
-rw-r--r--sysutils/ldapvi/pkg-descr25
3 files changed, 28 insertions, 29 deletions
diff --git a/sysutils/ldapvi/Makefile b/sysutils/ldapvi/Makefile
index 421b51088802..8538b4657529 100644
--- a/sysutils/ldapvi/Makefile
+++ b/sysutils/ldapvi/Makefile
@@ -6,36 +6,32 @@ PORTVERSION= 1.7
PORTREVISION= 3
CATEGORIES= sysutils net
MASTER_SITES= http://www.lichteblau.com/download/ \
- ${MASTER_SITE_LOCAL:S,%SUBDIR%,sbz,}
+ LOCAL/sbz
MAINTAINER= sbz@FreeBSD.org
-COMMENT= A tool to update LDAP entries with a text editor
+COMMENT= Tool to update LDAP entries with a text editor
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
+LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
+USES= gmake iconv pkgconfig
USE_OPENLDAP= yes
USE_GNOME= glib20
-USES= pkgconfig iconv
GNU_CONFIGURE= yes
-USE_GMAKE= yes
MAKEFILE= GNUmakefile
-CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= ${PORTNAME}.1
-PLIST_FILES= bin/${PORTNAME} \
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz \
${DOCSDIR_REL}/manual.css ${DOCSDIR_REL}/manual.xml \
${DOCSDIR_REL}/bg.png ${DOCSDIR_REL}/html.xsl
PLIST_DIRS= ${DOCSDIR_REL}
+# XXX should probably be converted to OptionsNG
.if !defined(WANT_OPENLDAP_SASL) || defined(WITHOUT_SASL)
-CONFIGURE_ARGS+=--without-sasl
+CONFIGURE_ARGS= --without-sasl
.endif
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/sysutils/ldapvi/files/patch-GNUmakefile.in b/sysutils/ldapvi/files/patch-GNUmakefile.in
index 73054d7f42d5..2d2a3b2791c5 100644
--- a/sysutils/ldapvi/files/patch-GNUmakefile.in
+++ b/sysutils/ldapvi/files/patch-GNUmakefile.in
@@ -1,13 +1,17 @@
--- GNUmakefile.in.orig 2007-07-15 15:25:07.653278406 +0200
+++ GNUmakefile.in 2007-07-15 15:26:01.574449285 +0200
-@@ -27,8 +27,8 @@
+@@ -25,10 +25,10 @@ ldapvi.1: version.h ldapvi ldapvi.1.in
+
+ .PHONY: install
install: ldapvi
- mkdir -p @bindir@ @mandir@/man1/ @prefix@/share/doc/ldapvi
- @INSTALL_PROGRAM@ ldapvi @bindir@
+- mkdir -p @bindir@ @mandir@/man1/ @prefix@/share/doc/ldapvi
+- @INSTALL_PROGRAM@ ldapvi @bindir@
- @INSTALL_PROGRAM@ -m 644 ldapvi.1 @mandir@/man1/
- @INSTALL_PROGRAM@ -m 644 manual/manual.css manual/manual.xml manual/bg.png manual/html.xsl @prefix@/share/doc/ldapvi
-+ @INSTALL_DATA@ ldapvi.1 @mandir@/man1/
-+ @INSTALL_DATA@ manual/manual.css manual/manual.xml manual/bg.png manual/html.xsl @prefix@/share/doc/ldapvi
++ mkdir -p $(DESTDIR)@bindir@ $(DESTDIR)@mandir@/man1 $(DESTDIR)@prefix@/share/doc/ldapvi
++ @INSTALL_PROGRAM@ ldapvi $(DESTDIR)@bindir@
++ @INSTALL_DATA@ ldapvi.1 $(DESTDIR)@mandir@/man1
++ @INSTALL_DATA@ manual/manual.css manual/manual.xml manual/bg.png manual/html.xsl $(DESTDIR)@prefix@/share/doc/ldapvi
distclean:
rm -rf configure GNUmakefile config.h config.log autom4te.cache config.status
diff --git a/sysutils/ldapvi/pkg-descr b/sysutils/ldapvi/pkg-descr
index d63e819a1369..71f1cb41c287 100644
--- a/sysutils/ldapvi/pkg-descr
+++ b/sysutils/ldapvi/pkg-descr
@@ -1,16 +1,15 @@
-ldapvi is tool to update LDAP entries with a text editor.
+ldapvi is tool to update LDAP entries with a text editor. It is:
-It is:
-# Written in C.
-# Reasonably fast and small. The ldapvi client needs about as much time for
- receiving entries as the OpenLDAP server needs to sends them, which should be
- fast enough.
-# Shows a summary of changes before committing them. Details of the changes can
- be previewed in LDIF format.
-# Uses an LDIF-like format in the editor (which should be easier to use
- interactively than standard LDIF).
-# Can rename entries.
-# Does not give up easily. On error, you can edit the file again or rebind to
- the server and try again.
+ - Written in C;
+ - Reasonably fast and small. The ldapvi client needs about as much time
+ for receiving entries as the OpenLDAP server needs to send them, which
+ should be fast enough;
+ - Shows a summary of changes before committing them. Details of the
+ changes can be previewed in LDIF format;
+ - Uses an LDIF-like format in the editor (which should be easier to use
+ interactively than standard LDIF);
+ - Can rename entries;
+ - Does not give up easily. On error, you can edit the file again, or
+ rebind to the server and try again.
WWW: http://www.lichteblau.com/ldapvi.html