aboutsummaryrefslogtreecommitdiff
path: root/sysutils/libcdio/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-12-08 22:19:42 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-12-08 22:19:42 +0000
commit898bfc7019aff9b2f47e759c3a1a188c63acd35f (patch)
treea5437bfd8a3769dde761f7220c4724caefd07f2b /sysutils/libcdio/Makefile
parentf87cb7ef527d2808152addd90d0221550eff5edc (diff)
libcdio: Update to 0.71
vcdimager: Update to 0.7.21 vlc: Chase share library bumps, Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=123497
Diffstat (limited to 'sysutils/libcdio/Makefile')
-rw-r--r--sysutils/libcdio/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/sysutils/libcdio/Makefile b/sysutils/libcdio/Makefile
index 9cfe07edae59..03e662a395f4 100644
--- a/sysutils/libcdio/Makefile
+++ b/sysutils/libcdio/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= libcdio
-PORTVERSION= 0.70
+PORTVERSION= 0.71
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libcdio
@@ -13,14 +13,22 @@ MASTER_SITE_SUBDIR= libcdio
MAINTAINER= arved@FreeBSD.org
COMMENT= Compact Disc Input and Control Library
-LIB_DEPENDS= cddb.1:${PORTSDIR}/audio/libcddb
+LIB_DEPENDS= cddb.1:${PORTSDIR}/audio/libcddb \
+ popt.0:${PORTSDIR}/devel/popt
GNU_CONFIGURE= yes
USE_GNOME= gnometarget pkgconfig gnomehack
USE_GMAKE= yes
+USE_ICONV= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS+= --with-libpopt-prefix=${LOCALBASE} \
+ --with-libiconv-prefix=${LOCALBASE}
USE_REINPLACE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -liconv"
INFO= libcdio
+post-patch:
+ ${REINPLACE_CMD} -e "s,freebsd5\.\*,freebsd5\.\*|freebsd6\.\*," ${WRKSRC}/configure
+
.include <bsd.port.mk>